]> TLD Linux GIT Repositories - packages/mc.git/commitdiff
- updated to 4.8.18
authorMarcin Krol <hawk@tld-linux.org>
Fri, 10 Feb 2017 07:29:43 +0000 (07:29 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Fri, 10 Feb 2017 07:29:43 +0000 (07:29 +0000)
mc-confirm-exit.patch
mc-file-find-case-insensitive.patch
mc-no-compute-totals.patch
mc-no-ws-visible.patch
mc-pld-developerfriendly.patch
mc.spec

index bcba97b94ad03c6ef2686930f2178238cdffc649..49f96ff00b52852ac35d1ba55b52606c46c4d451 100644 (file)
@@ -1,7 +1,7 @@
-diff -ur mc-4.8.12.orig/src/setup.c mc-4.8.12/src/setup.c
---- mc-4.8.12.orig/src/setup.c 2014-07-07 19:52:15.000000000 +0000
-+++ mc-4.8.12/src/setup.c      2014-07-07 23:15:03.862724555 +0000
-@@ -100,7 +100,7 @@
+diff -urNp mc-4.8.18.orig/src/setup.c mc-4.8.18/src/setup.c
+--- mc-4.8.18.orig/src/setup.c 2017-02-09 07:50:42.739638780 +0000
++++ mc-4.8.18/src/setup.c      2017-02-09 07:52:18.827637698 +0000
+@@ -100,7 +100,7 @@ int confirm_overwrite = 1;
  /* Asks for confirmation before executing a program by pressing enter */
  int confirm_execute = 0;
  /* Asks for confirmation before leaving the program */
index ce43e74f048061d04e045320c54fdcd7084269c1..2480b1b15bb1102e017fe205924f833aa34c775e 100644 (file)
@@ -1,21 +1,21 @@
-diff -ur mc-4.8.12.orig/src/filemanager/find.c mc-4.8.12/src/filemanager/find.c
---- mc-4.8.12.orig/src/filemanager/find.c      2014-04-01 10:54:01.000000000 +0000
-+++ mc-4.8.12/src/filemanager/find.c   2014-07-07 19:49:44.402848680 +0000
-@@ -291,7 +291,7 @@
+diff -urNp mc-4.8.18.orig/src/filemanager/find.c mc-4.8.18/src/filemanager/find.c
+--- mc-4.8.18.orig/src/filemanager/find.c      2017-02-09 07:49:15.633639761 +0000
++++ mc-4.8.18/src/filemanager/find.c   2017-02-09 07:50:19.801639038 +0000
+@@ -284,7 +284,7 @@ find_load_options (void)
      loaded = TRUE;
  
      options.file_case_sens =
--        mc_config_get_bool (mc_main_config, "FindFile", "file_case_sens", TRUE);
-+        mc_config_get_bool (mc_main_config, "FindFile", "file_case_sens", FALSE);
+-        mc_config_get_bool (mc_global.main_config, "FindFile", "file_case_sens", TRUE);
++        mc_config_get_bool (mc_global.main_config, "FindFile", "file_case_sens", FALSE);
      options.file_pattern =
-         mc_config_get_bool (mc_main_config, "FindFile", "file_shell_pattern", TRUE);
-     options.find_recurs = mc_config_get_bool (mc_main_config, "FindFile", "file_find_recurs", TRUE);
-@@ -301,7 +301,7 @@
-         mc_config_get_bool (mc_main_config, "FindFile", "file_all_charsets", FALSE);
-     options.content_use = mc_config_get_bool (mc_main_config, "FindFile", "content_use", TRUE);
+         mc_config_get_bool (mc_global.main_config, "FindFile", "file_shell_pattern", TRUE);
+     options.find_recurs =
+@@ -294,7 +294,7 @@ find_load_options (void)
+     options.file_all_charsets =
+         mc_config_get_bool (mc_global.main_config, "FindFile", "file_all_charsets", FALSE);
      options.content_case_sens =
--        mc_config_get_bool (mc_main_config, "FindFile", "content_case_sens", TRUE);
-+        mc_config_get_bool (mc_main_config, "FindFile", "content_case_sens", FALSE);
+-        mc_config_get_bool (mc_global.main_config, "FindFile", "content_case_sens", TRUE);
++        mc_config_get_bool (mc_global.main_config, "FindFile", "content_case_sens", FALSE);
      options.content_regexp =
-         mc_config_get_bool (mc_main_config, "FindFile", "content_regexp", FALSE);
+         mc_config_get_bool (mc_global.main_config, "FindFile", "content_regexp", FALSE);
      options.content_first_hit =
index cfe5ed3eb895d63fa7cd497134692b4248edcabb..aee9a4abbd7cfb55470013f8338e0028911c4078 100644 (file)
@@ -1,8 +1,8 @@
-diff -ur mc-4.8.12.orig/src/setup.c mc-4.8.12/src/setup.c
---- mc-4.8.12.orig/src/setup.c 2014-04-01 10:54:01.000000000 +0000
-+++ mc-4.8.12/src/setup.c      2014-07-07 17:48:27.126921091 +0000
-@@ -172,7 +172,7 @@
-  * information about copy/move sizes and bytes transfered
+diff -urNp mc-4.8.18.orig/src/setup.c mc-4.8.18/src/setup.c
+--- mc-4.8.18.orig/src/setup.c 2017-02-09 07:48:30.365640270 +0000
++++ mc-4.8.18/src/setup.c      2017-02-09 07:48:45.664640098 +0000
+@@ -174,7 +174,7 @@ int verbose = 1;
+  * information about copy/move sizes and bytes transferred
   * at the expense of some speed
   */
 -int file_op_compute_totals = 1;
index dc5fe63aa1317f6bebd24f7a3a8f070a02b612b7..bea53bd0e33c122453c1c344d4c0ceb8bcead12a 100644 (file)
@@ -1,12 +1,12 @@
-diff -urNp mc-4.6.2-pre1.orig/edit/editdraw.c mc-4.6.2-pre1/edit/editdraw.c
---- mc-4.6.2-pre1.orig/src/editor/editdraw.c   2007-08-27 14:06:03.000000000 +0200
-+++ mc-4.6.2-pre1/src/editor/editdraw.c        2008-05-05 12:00:49.000000000 +0200
-@@ -296,7 +296,7 @@
-     }
- }
+diff -urNp mc-4.8.18.orig/src/editor/editdraw.c mc-4.8.18/src/editor/editdraw.c
+--- mc-4.8.18.orig/src/editor/editdraw.c       2016-05-07 15:42:52.000000000 +0000
++++ mc-4.8.18/src/editor/editdraw.c    2017-02-09 07:46:34.507641575 +0000
+@@ -63,7 +63,7 @@
+ /* Toggles statusbar draw style */
+ int simple_statusbar = 0;
  
 -int visible_tabs = 1, visible_tws = 1;
 +int visible_tabs = 0, visible_tws = 0;
  
- /* b is a pointer to the beginning of the line */
- static void
+ /*** file scope macro definitions ****************************************************************/
index 1eff213d3ffed759c96ffe197e42e41939cdb1c7..5f338b9700c87f540901bc1ff3b1083d29408a9f 100644 (file)
@@ -25,10 +25,11 @@ diff -urN mc-2006-02-24-22.org/syntax/cvs-userlist.syntax mc-2006-02-24-22/synta
 diff -urN mc-2006-02-24-22.org/syntax/Makefile.am mc-2006-02-24-22/syntax/Makefile.am
 --- mc-2006-02-24-22.org/misc/syntax/Makefile.am       2006-01-30 18:01:58.000000000 +0100
 +++ mc-2006-02-24-22/misc/syntax/Makefile.am   2006-02-28 17:38:02.617073750 +0100
-@@ -11,6 +11,7 @@
+@@ -11,7 +11,8 @@
        debian-sources-list.syntax \
        cs.syntax               \
        css.syntax              \
+       cuda.syntax             \
 +      cvs-userlist.syntax     \
        cxx.syntax              \
        d.syntax                \
diff --git a/mc.spec b/mc.spec
index 4d5ee72cb3bc4dabbaac261e95b9d9a19ac3f8ae..d8b7834dd13a31e4b23b8b08b6df403959487bc5 100644 (file)
--- a/mc.spec
+++ b/mc.spec
@@ -18,13 +18,13 @@ Summary(tr.UTF-8):  Midnight Commander görsel kabuğu
 Summary(uk.UTF-8):     Диспетчер файлів Midnight Commander
 Summary(zh_CN.UTF-8):  一个方便实用的文件管理器和虚拟Shell
 Name:          mc
-Version:       4.8.16
+Version:       4.8.18
 Release:       1
 Epoch:         1
 License:       GPL v3+
 Group:         Applications/Shells
 Source0:       http://ftp.midnight-commander.org/%{name}-%{version}.tar.xz
-# Source0-md5: 5df626a64592ccc5891afd3923edcdbf
+# Source0-md5: 85ff9279f912c5482fe9f110f8892c96
 Source3:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source3-md5: 17d7b574e1b85ad6f8ddceda9e841f19
 Source7:       %{name}.desktop