]> TLD Linux GIT Repositories - packages/munin-plugins-contrib.git/commitdiff
- contrib plugins for Munin, NFY, patches not adjusted
authorMarcin Krol <hawk@tld-linux.org>
Wed, 14 Oct 2015 12:48:06 +0000 (12:48 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Wed, 14 Oct 2015 12:48:06 +0000 (12:48 +0000)
munin-plugins-contrib-apache.patch [new file with mode: 0644]
munin-plugins-contrib-other.patch [new file with mode: 0644]
munin-plugins-contrib-passenger.patch [new file with mode: 0644]
munin-plugins-contrib-php.patch [new file with mode: 0644]
munin-plugins-contrib-postfix.patch [new file with mode: 0644]
munin-plugins-contrib-samba.patch [new file with mode: 0644]
munin-plugins-contrib.spec [new file with mode: 0644]
xen.patch [new file with mode: 0644]

diff --git a/munin-plugins-contrib-apache.patch b/munin-plugins-contrib-apache.patch
new file mode 100644 (file)
index 0000000..8afa09a
--- /dev/null
@@ -0,0 +1,20 @@
+--- munin-plugins/plugins/apache/apache_watch_~        2008-11-30 01:59:30.000000000 +0100
++++ munin-plugins/plugins/apache/apache_watch_ 2009-04-26 20:30:15.107587925 +0200
+@@ -95,7 +95,7 @@
+   print "graph_vlabel activity\n";
+   my $i = 0;
+   foreach my $server (sort (@servers)) {
+-    (my $txtserver = $server) =~ s/(-|\.)/\_/g;
++    (my $txtserver = $server) =~ s/(-|\.|:|\\)/\_/g;
+     my $draw = ($i==0) ? 'AREA' : 'STACK';
+     if ($action eq "bytes") {
+       print "${txtserver}.label $server\n";
+@@ -114,7 +114,7 @@
+ foreach my $string (sort (@data)) {
+   my ($server, $ifInOctets, $ifOutOctets, $ifRequests, $ifDocuments) =
+     split (/\s/, $string);
+-  (my $txtserver = $server) =~ s/(-|\.)/\_/g;
++  (my $txtserver = $server) =~ s/(-|\.|:|\\)/\_/g;
+   if ($action eq "documents") {
+     print "${txtserver}.value $ifDocuments\n";
+   } elsif ($action eq "requests") {
diff --git a/munin-plugins-contrib-other.patch b/munin-plugins-contrib-other.patch
new file mode 100644 (file)
index 0000000..2e16a16
--- /dev/null
@@ -0,0 +1,60 @@
+--- munin-plugins-muninexchange-20081128/plugins/ftp/vsftpd-rel~       2008-11-29 13:19:37.000000000 +0100
++++ munin-plugins-muninexchange-20081128/plugins/ftp/vsftpd-rel        2008-11-29 21:04:06.000000000 +0100
+@@ -37,10 +37,10 @@
+ install_ok()
+ {
+-    tempfile=$(which tempfile)
++    mktemp=$(which mktemp)
+     if [ ! -r ${LOGFILE} -o \
+        -z "${LOGTAIL}" -o ! -x "${LOGTAIL}" -o \
+-       -z "${tempfile}" -o ! -x "${tempfile}" ]
++       -z "${mktemp}" -o ! -x "${mktemp}" ]
+     then
+       return 1
+     fi
+@@ -50,7 +50,7 @@
+ if [ "$1" = "autoconf" ]
+ then
+-    tmpfile=`which tempfile`
++    tmpfile=`which mktemp`
+     if install_ok
+     then
+       echo yes
+@@ -82,7 +82,7 @@
+ test install_ok || exit 1
+ touch -d now-5minutes+30seconds $PIVOT
+-TEMP=`tempfile`
++TEMP=`mktemp`
+ trap "rm -f ${PIVOT} ${TEMP}" INT EXIT
+ test -n "$TEMP" -a -w "$TEMP" || exit 1
+--- munin-plugins-muninexchange-20081128/plugins/nagios/nagiosstatus~  2008-11-29 13:19:37.000000000 +0100
++++ munin-plugins-muninexchange-20081128/plugins/nagios/nagiosstatus   2008-11-30 01:16:55.000000000 +0100
+@@ -113,10 +113,10 @@
+     if($type) {
+       push(@{$values{$type}}, $_);
+     }
+-    if(/^host \{/) {
++    if(/^hoststatus \{/) {
+       $type = "host";
+     }
+-    if(/^service \{/) {
++    if(/^servicestatus \{/) {
+       $type = "service";
+     }
+ }
+--- munin-plugins-muninexchange-20110326/plugins/mail/clamav~  2011-03-29 11:24:10.645146427 +0200
++++ munin-plugins-muninexchange-20110326/plugins/mail/clamav   2011-03-29 12:38:20.435562927 +0200
+@@ -1,7 +1,8 @@
+ #!/bin/sh
+ #%# family=manual
+ #%# capabilities=autoconf
+-log=/var/log/clamav/clamd.log
++
++log=${logfile:-/var/log/clamav/clamd.log}
+ if [ "$1" = "autoconf" ]; then
+         if [ -r $log ]; then 
diff --git a/munin-plugins-contrib-passenger.patch b/munin-plugins-contrib-passenger.patch
new file mode 100644 (file)
index 0000000..32c5beb
--- /dev/null
@@ -0,0 +1,11 @@
+--- munin-plugins-muninexchange-20110326/plugins/passenger/passenger_status~   2011-03-31 13:50:53.205407638 +0200
++++ munin-plugins-muninexchange-20110326/plugins/passenger/passenger_status    2011-03-31 13:51:08.129407638 +0200
+@@ -26,7 +26,7 @@
+ end
+  
+ def output_values
+-  status = `sudo passenger-status`
++  status = `passenger-status`
+   unless $?.success?
+     $stderr.puts "failed executing passenger-status"
+     exit 1
diff --git a/munin-plugins-contrib-php.patch b/munin-plugins-contrib-php.patch
new file mode 100644 (file)
index 0000000..cb88226
--- /dev/null
@@ -0,0 +1,11 @@
+--- munin-plugins-muninexchange-20081128/plugins/php/php_eaccelerator~ 2008-11-29 13:19:37.000000000 +0100
++++ munin-plugins-muninexchange-20081128/plugins/php/php_eaccelerator  2008-11-30 00:47:00.000000000 +0100
+@@ -32,7 +32,7 @@
+ url   = ENV['url'] || 'http://127.0.0.1/control.php'
+ if ARGV[0]=="config"
+-  print "EAccelerator Monitoring\n"
++  print "graph_info EAccelerator Monitoring\n"
+   print "graph_title PHP Eaccelerator\n"
+   print "graph_category Apache\n"
+   print "Memoryusagepercentage.label Memory Usage %\n"  
diff --git a/munin-plugins-contrib-postfix.patch b/munin-plugins-contrib-postfix.patch
new file mode 100644 (file)
index 0000000..3e9633b
--- /dev/null
@@ -0,0 +1,88 @@
+--- munin-plugins-muninexchange-20081128/plugins/mail/dkimproxy_mails  2008-11-29 13:19:37.000000000 +0100
++++ munin/plugins/mail/dkimproxy_mails 2008-11-29 13:19:43.000000000 +0100
+@@ -47,7 +47,7 @@
+ if [ "$1" = "config" ]; then
+         echo 'graph_title DKIM Proxy mails'
+         echo 'graph_order dkimnone dkimpass dkiminvalid dkimfail'
+-        echo 'graph_category mail'
++        echo 'graph_category postfix'
+         echo 'graph_vlabel Count'
+         echo 'graph_args --base 1000 -l 0'
+ #       echo 'graph_total total'
+--- munin-plugins-muninexchange-20081128/plugins/mail/postfix_filtered 2008-11-29 13:19:37.000000000 +0100
++++ munin/plugins/mail/postfix_filtered        2008-11-29 13:19:43.000000000 +0100
+@@ -60,7 +60,7 @@
+               else
+                       echo 'graph_order allowed rbl policy helo client sender recipient relay'
+       fi
+-      echo 'graph_category mail'
++      echo 'graph_category postfix'
+       echo 'graph_vlabel Mails per second'
+       echo 'graph_args --base 1000 -l 0'
+--- munin-plugins-muninexchange-20081128/plugins/mail/postfix_mailfiltered     2008-11-29 13:19:37.000000000 +0100
++++ munin/plugins/mail/postfix_mailfiltered    2008-11-29 13:19:43.000000000 +0100
+@@ -30,7 +30,7 @@
+ if [ "$1" = "config" ]; then
+       echo 'graph_title Postfix daily filtering'
+       echo 'graph_order relay rbl helo client sender recipient'
+-      echo 'graph_category mail'
++      echo 'graph_category postfix'
+       echo 'graph_vlabel Count'
+       echo 'graph_args --base 1000 -l 0'
+       echo 'graph_total total'
+--- munin-plugins-muninexchange-20081128/plugins/mail/postfix-policyd  2008-11-29 13:19:37.000000000 +0100
++++ munin/plugins/mail/postfix-policyd 2008-11-29 13:19:43.000000000 +0100
+@@ -25,7 +25,7 @@
+ if [ "$1" = "config" ]; then
+         echo 'graph_title Postfix-Policyd daily filtering'
+         echo 'graph_order delayed passed whitelisted'
+-        echo 'graph_category mail'
++        echo 'graph_category postfix'
+         echo 'graph_vlabel Count'
+         echo 'graph_scale no'
+--- munin-plugins-muninexchange-20081128/plugins/mail/postfix_stats    2008-11-29 13:19:37.000000000 +0100
++++ munin/plugins/mail/postfix_stats   2008-11-29 13:19:43.000000000 +0100
+@@ -19,7 +19,7 @@
+ system.type COUNTER
+ graph_title Postfix statistics
+ graph_vlabel Postfix statistics
+-graph_category Mail
++graph_category postfix
+ graph_total Total
+ received.label received
+ delivered.label delivered
+--- munin-plugins-muninexchange-20081128/plugins/mail/postgrey 2008-11-29 13:19:37.000000000 +0100
++++ munin/plugins/mail/postgrey        2008-11-29 13:19:43.000000000 +0100
+@@ -30,7 +30,7 @@
+ if [ "$1" = "config" ]; then
+       echo 'graph_title Postgrey daily filtering'
+       echo 'graph_order delayed passed whitelisted'
+-      echo 'graph_category mail'
++      echo 'graph_category postfix'
+       echo 'graph_vlabel Count'
+       echo 'graph_scale no'
+--- munin-plugins-muninexchange-20110326/plugins/mail/postfix_filtered_awk~    2011-03-26 15:54:42.725320884 +0100
++++ munin-plugins-muninexchange-20110326/plugins/mail/postfix_filtered_awk     2011-03-26 15:57:20.174320884 +0100
+@@ -50,7 +50,7 @@
+ if [ "$1" = "config" ]; then
+       echo 'graph_title Postfix message filtering'
+-      echo 'graph_category mail'
++      echo 'graph_category postfix'
+       echo 'graph_vlabel Mails per second'
+ #     echo 'graph_args --base 1000 --logarithmic'
+       echo 'graph_args --base 1000 -l 0'
+--- munin-plugins-muninexchange-20110326/plugins/mail/postgrey-new~    2011-03-26 15:54:42.787320884 +0100
++++ munin-plugins-muninexchange-20110326/plugins/mail/postgrey-new     2011-03-26 15:58:43.796320879 +0100
+@@ -59,7 +59,7 @@
+ if(defined $ARGV[0] and $ARGV[0] eq "config") {
+       print "graph_title Postgrey Actions\n";
+       print "graph_order greylisted retry_early passed passed_w\n";
+-      print "graph_category mail\n";
++      print "graph_category postfix\n";
+       print "graph_vlabel Count\n";
+       print "graph_scale no\n";
+       
diff --git a/munin-plugins-contrib-samba.patch b/munin-plugins-contrib-samba.patch
new file mode 100644 (file)
index 0000000..626628d
--- /dev/null
@@ -0,0 +1,7 @@
+--- munin-plugins-muninexchange-20081128/plugins/samba/samba_users~    2008-11-30 01:58:28.000000000 +0100
++++ munin-plugins-muninexchange-20081128/plugins/samba/samba_users     2008-12-02 00:28:40.000000000 +0100
+@@ -36,3 +36,4 @@
+ echo -n "samba_users.value "
+ smbstatus -b 2> /dev/null | grep -c -v -e "^Samba" -e "^---" -e "^PID" -e ^$
++exit 0
diff --git a/munin-plugins-contrib.spec b/munin-plugins-contrib.spec
new file mode 100644 (file)
index 0000000..718edbc
--- /dev/null
@@ -0,0 +1,294 @@
+%include       /usr/lib/rpm/macros.perl
+Summary:       3rd-party Munin plugins
+Summary(pl.UTF-8):     Nieoficjalne wtyczki munina
+Name:          munin-plugins-contrib
+Version:       20151014
+Release:       0.1
+License:       GPL
+Group:         Daemons
+Source0:       https://github.com/munin-monitoring/contrib/tarball/master/%{name}.tar.gz
+# Source0-md5: 6b38950e7b41c8c75fe4b0803ffe1261
+Patch0:                %{name}-postfix.patch
+Patch1:                %{name}-other.patch
+Patch2:                %{name}-php.patch
+Patch3:                %{name}-samba.patch
+Patch4:                %{name}-apache.patch
+Patch5:                %{name}-passenger.patch
+Patch6:                xen.patch
+URL:           http://exchange.munin-monitoring.org/
+BuildRequires: dos2unix
+BuildRequires: perl-devel
+BuildRequires: rpm-perlprov
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.268
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define                _noautoreq_perl         DateTime::Format::ISO8601 Sys::Virt Sys::Virt::.* VMware::.* File::Tail::Multi nvidia::ml WWW::Mechanize::TreeBuilder Sun::Solaris::Kstat
+
+%description
+This package contains 3rd-party plugins for Munin from contrib repository
+located at https://github.com/munin-monitoring/contrib/.
+
+%description -l pl.UTF-8
+Ten pakiet zawera nieoficjalne wtyczki dla Munina z repozytorium contrib,
+znajdującym się na https://github.com/munin-monitoring/contrib/.
+
+%define        contrib_package()\
+%package %1\
+Summary:       3rd-party Munin plugin - %1\
+Summary(pl.UTF-8):     Nieoficjalna wtyczka dla munina - %1\
+Group:         Daemons\
+Requires:      munin-node\
+\
+%description %1\
+This package contains 3rd-party plugins for Munin from contrib repository\
+located at https://github.com/munin-monitoring/contrib/.\
+\
+%description %1 -l pl.UTF-8\
+Ten pakiet zawera nieoficjalne wtyczki dla Munina z repozytorium contrib,\
+znajdującym się na https://github.com/munin-monitoring/contrib/.\
+\
+%files %1 -f %1.list\
+%defattr(755,root,root,755)\
+%{nil}
+
+%prep
+%setup -q -n munin-monitoring-contrib-b02fe4e
+
+find -type f -print0 | xargs -0 dos2unix
+
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+
+grep -r bin/env -l plugins/ | xargs sed -i -e '1{
+       s,#!.*bin/env ruby,#!%{__ruby},
+       s,#!.*bin/env python[^ ]*,#!%{__python},
+       s,#!.*bin/env perl,#!%{__perl},
+}'
+
+find plugins/ -type f | xargs sed -i -e '1{
+       s,#!.*/usr/local/bin/,#!/usr/bin/,
+       s,#!.*/opt/csw/bin/ruby,#!%{__ruby},
+       s,#!.*/usr/bin/bash,#!/bin/bash,
+       s,#!.*/sbin/sh,#!/bin/sh,
+}'
+
+# cleanup backups after patching
+find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
+
+%{__rm} -r plugins/asterisk/asterisk_*_fax_*
+%{__rm} -r plugins/mail/dovecot
+
+for f in plugins/apache/apache_byprojects/byprojects_* ; do
+       %{__mv} $f plugins/apache/apache_byprojects/apache_$(basename $f)
+done
+for f in plugins/nginx/nginx_byprojects/byprojects_* ; do
+       %{__mv} $f plugins/nginx/nginx_byprojects/nginx_$(basename $f)
+done
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_datadir}/munin/plugins/
+
+for i in plugins/*; do
+       [ -d $i ] || continue
+       j=$(basename $i)
+       >$j.list
+       find $i/* -type f | while read f ; do
+               if file $f | grep -qs script ; then
+                       ff=$(basename $f)
+                       echo "%{_datadir}/munin/plugins/$ff" >>$j.list
+                       install -p $f $RPM_BUILD_ROOT%{_datadir}/munin/plugins/
+               fi
+       done
+done
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%contrib_package amr
+%contrib_package amule
+%contrib_package apache
+%contrib_package apt
+%contrib_package arangodb
+%contrib_package aris
+%contrib_package asterisk
+%contrib_package audit
+%contrib_package backup
+%contrib_package backuppc
+%contrib_package bacula
+%contrib_package beboxsync
+%contrib_package bind9
+%contrib_package bitcoin
+%contrib_package boinc
+%contrib_package cacti
+%contrib_package celery
+%contrib_package ceph
+%contrib_package chassis
+%contrib_package chat
+%contrib_package cherokee
+%contrib_package condor
+%contrib_package cpan
+%contrib_package currentcost
+%contrib_package cyrus
+%contrib_package db2
+%contrib_package disk
+%contrib_package djabberd
+%contrib_package dovecot
+%contrib_package drbd
+%contrib_package drupal
+%contrib_package dspam
+%contrib_package dvb
+%contrib_package dxtv
+%contrib_package ejabberd
+%contrib_package fax
+%contrib_package firebird
+%contrib_package forums
+%contrib_package ftp
+%contrib_package funkytown
+%contrib_package games
+%contrib_package gearman
+%contrib_package geowebcache
+%contrib_package glance
+%contrib_package glassfish
+%contrib_package google
+%contrib_package gpu
+%contrib_package gunicorn
+%contrib_package hadoop
+%contrib_package haproxy
+%contrib_package harddisks
+%contrib_package healthcheck
+%contrib_package heimdal
+%contrib_package hhvm
+%contrib_package hp
+%contrib_package http
+%contrib_package ipvs
+%contrib_package java
+%contrib_package jchkmail_counters_
+%contrib_package jenkins
+%contrib_package joomla
+%contrib_package kamailio
+%contrib_package keystone
+%contrib_package licensing
+%contrib_package lighttpd
+%contrib_package logins
+%contrib_package lustre
+%contrib_package lxc
+%contrib_package mail
+%contrib_package memcached
+%contrib_package memcached_ext
+%contrib_package minecraft
+%contrib_package moblock
+%contrib_package modem
+%contrib_package mod_jk
+%contrib_package mogilefs
+%contrib_package mongodb
+%contrib_package monit
+%contrib_package moodle
+%contrib_package mpd
+%contrib_package mssql
+%contrib_package munin
+%contrib_package mysql
+%contrib_package mythtv
+%contrib_package nagios
+%contrib_package network
+%contrib_package newznab
+%contrib_package nfs-freebsd
+%contrib_package nginx
+%contrib_package noaaport
+%contrib_package nova
+%contrib_package nscd
+%contrib_package nutcracker
+%contrib_package openfire
+%contrib_package openntpd
+%contrib_package openvpn
+%contrib_package openvz
+%contrib_package oracle
+%contrib_package ossec
+%contrib_package other
+%contrib_package passenger
+%contrib_package percona
+%contrib_package php
+%contrib_package postfix
+%contrib_package postgresql
+%contrib_package power5
+%contrib_package powermta
+%contrib_package printer
+%contrib_package processes
+%contrib_package prosody
+%contrib_package puppet
+%contrib_package qpid
+%contrib_package qpsmtpd
+%contrib_package rabbitmq
+%contrib_package rackspace
+%contrib_package radiator
+%contrib_package raspberry-pi
+%contrib_package reddit_karma
+%contrib_package redis
+%contrib_package relayd
+%contrib_package requesttracker
+%contrib_package riak
+%contrib_package rsync
+%contrib_package rtorrent
+%contrib_package s3
+%contrib_package sabnzbd
+%contrib_package samba
+%contrib_package san
+%contrib_package scalix
+%contrib_package security
+%contrib_package senderscore
+%contrib_package sensors
+%contrib_package services
+%contrib_package sge
+%contrib_package sickbeard
+%contrib_package slony
+%contrib_package smstools
+%contrib_package snmp
+%contrib_package solr
+%contrib_package sourceds
+%contrib_package sphinx
+%contrib_package spotweb
+%contrib_package squeezebox
+%contrib_package squid
+%contrib_package ssl
+%contrib_package streaming
+%contrib_package swift
+%contrib_package syslog
+%contrib_package system
+%contrib_package tarsnap
+%contrib_package teamspeak
+%contrib_package thin
+%contrib_package time
+%contrib_package tomcat
+%contrib_package trafic_ro
+%contrib_package tv
+%contrib_package ubuntu
+%contrib_package ultramonkey
+%contrib_package unicorn
+%contrib_package ups
+%contrib_package uwsgi
+%contrib_package varnish
+%contrib_package varnish4
+%contrib_package vdr
+%contrib_package virtualization
+%contrib_package voip
+%contrib_package voldemort
+%contrib_package weather
+%contrib_package websphere
+%contrib_package wiki
+%contrib_package wowza
+%contrib_package wuala
+%contrib_package xastir
+%contrib_package xbnbt
+%contrib_package yacy
+%contrib_package zeo
+%contrib_package zfs
+%contrib_package zimbra
+%contrib_package znc
+%contrib_package zope
diff --git a/xen.patch b/xen.patch
new file mode 100644 (file)
index 0000000..7da5e47
--- /dev/null
+++ b/xen.patch
@@ -0,0 +1,172 @@
+--- munin.orig/plugins/virtualization/xen      2013-08-23 21:31:56.610001695 +0200
++++ munin/plugins/virtualization/xen   2013-08-23 21:36:22.120001621 +0200
+@@ -18,11 +18,11 @@
+ statefile="/var/lib/munin/plugin-state/munin-plugin-xen.state"
+ if [ "$1" = "autoconf" ]; then
+-        if which xm > /dev/null ; then
++        if which xl > /dev/null ; then
+                 echo yes
+                 exit 0
+         fi
+-        echo "no (xm not found)"
++        echo "no (xl not found)"
+         exit 1
+ fi
+@@ -39,7 +39,7 @@
+         echo 'graph_category xen'
+         echo 'graph_info This graph shows how many percent of the CPU time was used by each domain'
+-      xm list | grep -v "^Name .* Time(s)$" | \
++      xl list | grep -v "^Name\s.*\sTime(s)$" | \
+         while read name domid mem cpu state time console; do
+                 name=`echo $name | sed -e"s/[-.]/_/g"`
+               TEST=`less $statefile | grep "^${name}$" | wc -l`
+@@ -66,7 +66,7 @@
+         exit 0
+ fi
+-xm list | grep -v "^Name .* Time(s)$" | \
++xl list | grep -v "^Name\s.*\sTime(s)$" | \
+ while read name domid mem cpu state time console; do
+         name=`echo $name | sed -e "s/[-.]/_/g"`
+       # only seconds
+--- munin.orig/plugins/virtualization/xen_cpu_v2       2013-08-23 21:31:56.613334934 +0200
++++ munin/plugins/virtualization/xen_cpu_v2    2013-08-23 21:40:07.360001590 +0200
+@@ -25,10 +25,10 @@
+ use POSIX;
+ # Define where to find xm tools
+-my $XM = '/usr/sbin/xm';
++my $XM = '/usr/sbin/xl';
+ my $XMTOP = '/usr/sbin/xentop';
+ my $curtime = time();
+-my $basename = `/usr/bin/basename $0`; chop ($basename);
++my $basename = `/bin/basename $0`; chop ($basename);
+ my $TEMPFILE = "/tmp/$basename";
+ my $debug = 0;
+--- munin.orig/plugins/virtualization/xen_memory       2013-08-23 21:31:56.613334934 +0200
++++ munin/plugins/virtualization/xen_memory    2013-08-23 21:41:06.290001570 +0200
+@@ -12,14 +12,14 @@
+ #     autoconf  (optional - used by munin-config)
+ #
+-XM='/usr/sbin/xm'
++XM='/usr/sbin/xl'
+ if [ "$1" = "autoconf" ]; then
+         if [ -e $XM ]; then
+                 echo yes
+                 exit 0
+         fi
+-        echo "no (xm not found)"
++        echo "no (xl not found)"
+         exit 1
+ fi
+--- munin.orig/plugins/virtualization/xen_traffic_     2013-08-23 21:31:56.616668173 +0200
++++ munin/plugins/virtualization/xen_traffic_  2013-08-23 23:17:57.023334928 +0200
+@@ -11,10 +11,10 @@
+ NAME=$( echo $DOMAIN | sed -e's/-/_/g' ) 
+ if [ "$1" = "autoconf" ]; then
+-    if which xm > /dev/null ; then
++    if which xl > /dev/null ; then
+         echo yes
+     else
+-        echo "no (xm not found)"
++        echo "no (xl not found)"
+         exit 1
+     fi
+     if [ -r /proc/net/dev ]; then
+@@ -27,7 +27,7 @@
+ fi
+ if [ "$1" = "suggest" ]; then
+-    xm list | awk '{print $1}' | egrep -v "^(Name|Domain-0)"
++    xl list | awk '{print $1}' | egrep -v "^(Name|Domain-0)"
+     exit 0
+ fi
+@@ -47,7 +47,7 @@
+     exit 0
+ fi
+-dev=$( xm network-list $DOMAIN | egrep "^[0-9]+" | sed 's@^.*vif/\([0-9]*\)/\([0-9]*\).*$@vif\1.\2@')
++dev=$( xl network-list $DOMAIN | egrep "^[0-9]+" | sed 's@^.*vif/\([0-9]*\)/\([0-9]*\).*$@vif\1.\2@')
+ awk -v interface="$dev" \
+     'BEGIN { gsub(/\./, "\\.", interface) } \
+--- munin.orig/plugins/virtualization/xen_traffic_all  2013-08-23 21:31:56.616668173 +0200
++++ munin/plugins/virtualization/xen_traffic_all       2013-08-23 21:45:30.156668240 +0200
+@@ -10,10 +10,10 @@
+ #%# capabilities=autoconf
+ if [ "$1" = "autoconf" ]; then
+-    if which xm > /dev/null ; then
++    if which xl > /dev/null ; then
+         echo yes
+     else
+-        echo "no (xm not found)"
++        echo "no (xl not found)"
+         exit 1
+     fi
+     if [ -r /proc/net/dev ]; then
+@@ -30,7 +30,7 @@
+     echo 'graph_vlabel bits received (-) / sent (+) per ${graph_period}'
+     echo 'graph_args --base 1024 -l 0'
+     echo 'graph_category xen'
+-    DOMAINS=$(xm list | awk '{print $1}' | egrep -v "^(Name|Domain-0)")
++    DOMAINS=$(xl list | awk '{print $1}' | egrep -v "^(Name|Domain-0|\(null)")
+     for dom in $DOMAINS; do
+         name=$( echo $dom | tr .- __ )
+         #echo $name"UP.label $name"
+@@ -48,11 +48,11 @@
+     exit 0
+ fi
+-DOMAINS=$(xm list | awk '{print $1}' | egrep -v "^(Name|Domain-0)")
++DOMAINS=$(xl list | awk '{print $1}' | egrep -v "^(Name|Domain-0|\(null)")
+ for dom in $DOMAINS; do
+-              dev=$( xm list $dom --long | awk '/vifname / { print $2 }' | sed 's/)//' )
++              dev=$( xl list $dom --long | awk '/vifname / { print $2 }' | sed 's/)//' )
+               if [ "$dev" == "" ]; then
+-          dev=$( xm network-list $dom |\
++          dev=$( xl network-list $dom |\
+               egrep "^[0-9]+" | sed 's@^.*vif/\([0-9]*\)/\([0-9]*\).*$@vif\1.\2@')
+               fi
+     name=$( echo $dom | tr .- __ ) 
+--- munin.orig/plugins/virtualization/xen_vbd  2013-08-23 21:31:56.620001488 +0200
++++ munin/plugins/virtualization/xen_vbd       2013-08-23 23:19:52.040001471 +0200
+@@ -13,7 +13,7 @@
+ #%# capabilities=autoconf
+ # Location of xm tools
+-$XM = '/usr/sbin/xm';
++$XM = '/usr/sbin/xl';
+ $XMTOP = '/usr/sbin/xentop';
+ # ah, parameters coming in 
+@@ -48,6 +48,7 @@
+                 
+                 @domains = `$XM list`;
+                 shift(@domains); # we don't need the header line
++                shift(@domains); # we don't need the header line
+                 
+                 foreach $domain ( @domains )
+                 {
+@@ -90,9 +90,9 @@
+ @stats = split (/\n/, pop(@chunks));
+ shift(@stats);
+-shift(@stats);
+-shift(@stats);
+-shift(@stats);
++#shift(@stats);
++#shift(@stats);
++#shift(@stats);
+ foreach $domain (@stats)
+ {