]> TLD Linux GIT Repositories - packages/munin.git/blobdiff - munin-Makefile.patch
- logtool seems no longer needed (not found anywhere in sources)
[packages/munin.git] / munin-Makefile.patch
index 5fd99671429723e1a7a49b5df3d9fa52ad2a50d9..58b3f386fae3a1a77e7e9ce3f421a6381e556a0c 100644 (file)
@@ -1,7 +1,6 @@
-diff -urNp munin-2.0.25.orig/Makefile munin-2.0.25/Makefile
---- munin-2.0.25.orig/Makefile 2014-11-24 21:46:24.000000000 +0000
-+++ munin-2.0.25/Makefile      2015-09-08 10:02:24.392593251 +0000
-@@ -81,6 +81,7 @@ install-master-prime: $(INFILES_MASTER)
+--- munin-2.0.65/Makefile.orig 2020-10-28 22:36:02.000000000 +0100
++++ munin-2.0.65/Makefile      2020-11-11 13:51:56.079267472 +0100
+@@ -107,6 +107,7 @@
        mkdir -p $(CONFDIR)/munin-conf.d
        mkdir -p $(LIBDIR)
        mkdir -p $(BINDIR)
@@ -9,7 +8,7 @@ diff -urNp munin-2.0.25.orig/Makefile munin-2.0.25/Makefile
        mkdir -p $(PERLLIB)
        mkdir -p $(PERLLIB)/Munin/Master
        mkdir -p $(HTMLDIR)
-@@ -112,8 +113,8 @@ install-master-prime: $(INFILES_MASTER)
+@@ -138,8 +139,8 @@
        test -f $(HTMLDIR)/.htaccess || $(INSTALL) -m 0644 build/master/www/munin-htaccess $(HTMLDIR)/.htaccess
        test -f "$(CONFDIR)/munin.conf"  || $(INSTALL) -m 0644 build/master/munin.conf $(CONFDIR)/
  
@@ -20,9 +19,8 @@ diff -urNp munin-2.0.25.orig/Makefile munin-2.0.25/Makefile
        $(INSTALL) -m 0755 build/master/_bin/munin-update $(LIBDIR)/
        $(INSTALL) -m 0755 build/master/_bin/munin-html $(LIBDIR)/
        $(INSTALL) -m 0755 build/master/_bin/munin-graph $(LIBDIR)/
-diff -urNp munin-2.0.25.orig/Makefile.config munin-2.0.25/Makefile.config
---- munin-2.0.25.orig/Makefile.config  2014-11-24 21:46:24.000000000 +0000
-+++ munin-2.0.25/Makefile.config       2015-09-08 10:02:24.393593251 +0000
+--- munin-2.0.65/Makefile.config.orig  2020-10-28 22:36:02.000000000 +0100
++++ munin-2.0.65/Makefile.config       2020-11-11 14:00:57.830267472 +0100
 @@ -17,10 +17,10 @@
  #
  # the base of the Munin installation.
@@ -36,7 +34,7 @@ diff -urNp munin-2.0.25.orig/Makefile.config munin-2.0.25/Makefile.config
  
  # Server only - where to put munin-cron
  BINDIR     = $(PREFIX)/bin
-@@ -32,31 +32,31 @@ SBINDIR    = $(PREFIX)/sbin
+@@ -32,31 +32,31 @@
  DOCDIR     = $(PREFIX)/doc
  
  # Where to put man pages
@@ -77,16 +75,16 @@ diff -urNp munin-2.0.25.orig/Makefile.config munin-2.0.25/Makefile.config
  
  # Location of PID files and other statefiles. On the server, must be
  # writable by the user "munin".
-@@ -95,7 +95,7 @@ GOODSH     := $(shell PATH=`getconf PATH
+@@ -95,7 +95,7 @@
  BASH       := /bin/bash
  
  # Server only - Where to install the perl libraries
--PERLSITELIB := $(shell $(PERL) -V:sitelib | cut -d"'" -f2)
-+PERLSITELIB := $(shell $(PERL) -V:vendorlib | cut -d"'" -f2)
- PERLLIB    = $(DESTDIR)$(PERLSITELIB)
+-PERLLIB    = $(DESTDIR)$(shell $(PERL) -V:sitelib | cut -d"'" -f2)
++PERLLIB    = $(DESTDIR)$(shell $(PERL) -V:vendorlib | cut -d"'" -f2)
  
  # Client only - Install plugins for this architecture
-@@ -106,7 +106,7 @@ OSTYPE     := $(shell uname | LANG=C tr
+ # the LANG=C makes tr work as expected, not regarding any locale it
+@@ -105,7 +105,7 @@
  
  # How to figure out the hostname. (Only used in default configuration
  # files)
@@ -95,26 +93,47 @@ diff -urNp munin-2.0.25.orig/Makefile.config munin-2.0.25/Makefile.config
  
  # What is the safest way to create a tempfile.
  # Default is to figure it out by testing various methods.
-@@ -129,9 +129,9 @@ CGIUSER := nobody
- # Which command to use to check if the USER and GROUP to run Munin as, exists.
- # These will work on most modern OSes:
- #
--GETENT     := $(shell which getent || which true 2>/dev/null)
--CHECKUSER  := $(shell $(GETENT) passwd $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistent. Create the user and retry; exit 2"))
--CHECKGROUP := $(shell $(GETENT) group $(GROUP) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistent. Create the group and retry; exit 2"))
-+GETENT     := /bin/true
-+CHECKUSER  := /bin/true
-+CHECKGROUP := /bin/true
- # For OSX, comment out the previous two lines and comment in these
- #
-@@ -153,9 +153,9 @@ CHECKGROUP := $(shell $(GETENT) group $(
- #CHECKUSER  := $(shell id $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistent. Create the user and retry; exit 2"))
- #CHECKGROUP := $(shell grep ^$(GROUP): /etc/group >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistent. Create the group and retry; exit 2"))
+@@ -125,38 +125,14 @@
+ # Default user to run the cgi as
+ CGIUSER := nobody
+-# Which command to use to check if the USER and GROUP to run Munin as, exists.
+-ifneq ($(shell which getent),)
+-    # "getent" works on most modern OS
+-    CHECKUSER_COMMAND := getent passwd $(USER)
+-    CHECKGROUP_COMMAND := getent group $(GROUP)
+-else
+-    ifeq ($(OSTYPE),darwin)
+-        # This should work for OSX 10.5 (Leopard) or later
+-        CHECKUSER_COMMAND := dscl . -read /Users/$(USER)
+-        CHECKGROUP_COMMAND := dscl . -read /Groups/$(GROUP)
+-    else
+-        ifeq ($(OSTYPE),cygwin)
+-            CHECKUSER_COMMAND := id $(USER)
+-            CHECKGROUP_COMMAND := grep ^$(GROUP): /etc/group
+-        else
+-            ifeq ($(OSTYPE),hp-ux)
+-                CHECKUSER_COMMAND := pwget -n $(USER)
+-                CHECKGROUP_COMMAND := grget -n $(GROUP)
+-            else
+-                $(warning Missing test for user existence on this platform. Skipping this check and hoping for the best ...)
+-                CHECKUSER_COMMAND := true
+-                CHECKGROUP_COMMAND := true
+-            endif
+-        endif
+-    endif
+-endif
+-CHECKUSER  := $(shell $(CHECKUSER_COMMAND) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistent. Create the user and retry; exit 2"))
+-CHECKGROUP := $(shell $(CHECKGROUP_COMMAND) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistent. Create the group and retry; exit 2"))
+-
 -CHOWN      := chown
 -CHMOD      := chmod
 -CHGRP      := chgrp
++CHECKUSER_COMMAND := /bin/true
++CHECKGROUP_COMMAND := /bin/true
++CHECKUSER  := /bin/true
++CHECKGROUP := /bin/true
++
 +CHOWN      := /bin/true
 +CHMOD      := /bin/true
 +CHGRP      := /bin/true