]> TLD Linux GIT Repositories - packages/munin.git/blobdiff - munin-Makefile.patch
- logtool seems no longer needed (not found anywhere in sources)
[packages/munin.git] / munin-Makefile.patch
index e808657cd6b8bae5642f20d54f223a1dfea21d7a..58b3f386fae3a1a77e7e9ce3f421a6381e556a0c 100644 (file)
@@ -1,6 +1,6 @@
---- munin-1.4.0/Makefile~      2009-11-27 12:17:18.000000000 +0100
-+++ munin-1.4.0/Makefile       2009-11-30 14:33:15.977700738 +0100
-@@ -77,6 +77,7 @@
+--- munin-2.0.65/Makefile.orig 2020-10-28 22:36:02.000000000 +0100
++++ munin-2.0.65/Makefile      2020-11-11 13:51:56.079267472 +0100
+@@ -107,6 +107,7 @@
        mkdir -p $(CONFDIR)/munin-conf.d
        mkdir -p $(LIBDIR)
        mkdir -p $(BINDIR)
@@ -8,7 +8,7 @@
        mkdir -p $(PERLLIB)
        mkdir -p $(PERLLIB)/Munin/Master
        mkdir -p $(HTMLDIR)
-@@ -99,8 +100,8 @@
+@@ -138,8 +139,8 @@
        test -f $(HTMLDIR)/.htaccess || $(INSTALL) -m 0644 build/master/www/munin-htaccess $(HTMLDIR)/.htaccess
        test -f "$(CONFDIR)/munin.conf"  || $(INSTALL) -m 0644 build/master/munin.conf $(CONFDIR)/
  
 +      $(INSTALL) -m 0755 build/master/_bin/munin-cron $(SBINDIR)/
 +      $(INSTALL) -m 0755 build/master/_bin/munin-check $(LIBDIR)/
        $(INSTALL) -m 0755 build/master/_bin/munin-update $(LIBDIR)/
-       $(INSTALL) -m 0755 build/master/_bin/munin-graph $(LIBDIR)/
        $(INSTALL) -m 0755 build/master/_bin/munin-html $(LIBDIR)/
---- munin-1.4.0/Makefile.config~       2009-11-27 12:17:18.000000000 +0100
-+++ munin-1.4.0/Makefile.config        2009-11-30 14:32:28.827763277 +0100
+       $(INSTALL) -m 0755 build/master/_bin/munin-graph $(LIBDIR)/
+--- munin-2.0.65/Makefile.config.orig  2020-10-28 22:36:02.000000000 +0100
++++ munin-2.0.65/Makefile.config       2020-11-11 14:00:57.830267472 +0100
 @@ -17,10 +17,10 @@
  #
  # the base of the Munin installation.
  
  # Location of PID files and other statefiles. On the server, must be
  # writable by the user "munin".
-@@ -98,7 +98,7 @@
+@@ -95,7 +95,7 @@
  BASH       := /bin/bash
  
  # Server only - Where to install the perl libraries
--PERLSITELIB := $(shell $(PERL) -V:sitelib | cut -d"'" -f2)
-+PERLSITELIB := $(shell $(PERL) -V:vendorlib | cut -d"'" -f2)
- PERLLIB    = $(DESTDIR)$(PERLSITELIB)
+-PERLLIB    = $(DESTDIR)$(shell $(PERL) -V:sitelib | cut -d"'" -f2)
++PERLLIB    = $(DESTDIR)$(shell $(PERL) -V:vendorlib | cut -d"'" -f2)
  
  # Client only - Install plugins for this architecture
-@@ -106,7 +106,7 @@
+ # the LANG=C makes tr work as expected, not regarding any locale it
+@@ -105,7 +105,7 @@
  
  # How to figure out the hostname. (Only used in default configuration
  # files)
  
  # What is the safest way to create a tempfile.
  # Default is to figure it out by testing various methods.
-@@ -126,9 +126,9 @@
- # Which command to use to check if the USER and GROUP to run Munin as, exists.
- # These will work on most modern OSes:
- #
--GETENT     := $(shell which getent || which true 2>/dev/null)
--CHECKUSER  := $(shell $(GETENT) passwd $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistent. Create the user and retry; exit 2"))
--CHECKGROUP := $(shell $(GETENT) group $(GROUP) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistent. Create the group and retry; exit 2"))
-+GETENT     := /bin/true
-+CHECKUSER  := /bin/true
-+CHECKGROUP := /bin/true
- # For OSX, comment out the previous two lines and comment in these
- #
-@@ -146,9 +146,9 @@
- #CHECKUSER  := $(shell pwget -n $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistent. Create the user and retry; exit 2"))
- #CHECKGROUP := $(shell grget -n $(GROUP) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistent. Create the group and retry; exit 2"))
+@@ -125,38 +125,14 @@
+ # Default user to run the cgi as
+ CGIUSER := nobody
+-# Which command to use to check if the USER and GROUP to run Munin as, exists.
+-ifneq ($(shell which getent),)
+-    # "getent" works on most modern OS
+-    CHECKUSER_COMMAND := getent passwd $(USER)
+-    CHECKGROUP_COMMAND := getent group $(GROUP)
+-else
+-    ifeq ($(OSTYPE),darwin)
+-        # This should work for OSX 10.5 (Leopard) or later
+-        CHECKUSER_COMMAND := dscl . -read /Users/$(USER)
+-        CHECKGROUP_COMMAND := dscl . -read /Groups/$(GROUP)
+-    else
+-        ifeq ($(OSTYPE),cygwin)
+-            CHECKUSER_COMMAND := id $(USER)
+-            CHECKGROUP_COMMAND := grep ^$(GROUP): /etc/group
+-        else
+-            ifeq ($(OSTYPE),hp-ux)
+-                CHECKUSER_COMMAND := pwget -n $(USER)
+-                CHECKGROUP_COMMAND := grget -n $(GROUP)
+-            else
+-                $(warning Missing test for user existence on this platform. Skipping this check and hoping for the best ...)
+-                CHECKUSER_COMMAND := true
+-                CHECKGROUP_COMMAND := true
+-            endif
+-        endif
+-    endif
+-endif
+-CHECKUSER  := $(shell $(CHECKUSER_COMMAND) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistent. Create the user and retry; exit 2"))
+-CHECKGROUP := $(shell $(CHECKGROUP_COMMAND) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistent. Create the group and retry; exit 2"))
+-
 -CHOWN      := chown
 -CHMOD      := chmod
 -CHGRP      := chgrp
++CHECKUSER_COMMAND := /bin/true
++CHECKGROUP_COMMAND := /bin/true
++CHECKUSER  := /bin/true
++CHECKGROUP := /bin/true
++
 +CHOWN      := /bin/true
 +CHMOD      := /bin/true
 +CHGRP      := /bin/true