]> TLD Linux GIT Repositories - packages/munin.git/blobdiff - munin.spec
- logtool seems no longer needed (not found anywhere in sources)
[packages/munin.git] / munin.spec
index 428636493a7742fb4b2a79d4c262c882e61148ed..2eb35d637253a01450fc3802da7a01a0c0ac31f2 100644 (file)
@@ -1,16 +1,15 @@
 # Condtional build:
 %bcond_with    sybase          # add Sybase support to munin-node
 
-%include       /usr/lib/rpm/macros.perl
 Summary:       Munin - the Linpro RRD data agent
 Summary(pl.UTF-8):     Munin - agent danych RRD Linpro
 Name:          munin
-Version:       2.0.25
-Release:       1
+Version:       2.0.75
+Release:       2
 License:       GPL
 Group:         Applications/WWW
-Source0:       http://downloads.sourceforge.net/munin/%{name}-%{version}.tar.gz
-# Source0-md5: b418a667ce42665557329a7ac3bd1b93
+Source0:       https://github.com/munin-monitoring/munin/archive/%{version}.tar.gz
+# Source0-md5: e793d7d139df7cd7730089186a3afc28
 Source1:       %{name}-node.init
 Source2:       %{name}.cron
 Source3:       %{name}-apache.conf
@@ -20,20 +19,23 @@ Source6:    %{name}-lighttpd.conf
 Source8:       %{name}-httpd.conf
 Source11:      %{name}-asyncd.init
 Source12:      %{name}-asyncd.sysconfig
+Source13:      plugins.conf
 Patch0:                %{name}-Makefile.patch
 Patch1:                %{name}-plugins.patch
 Patch2:                %{name}-templatedir.patch
 Patch3:                %{name}-separate-configs.patch
 Patch4:                %{name}-timeout.patch
+Patch5:                shebang.patch
 URL:           http://munin.sourceforge.net/
 BuildRequires: perl-Encode
+BuildRequires: perl-Module-Build
 BuildRequires: perl-Net-SNMP
 BuildRequires: perl-devel
 BuildRequires: rpm-perlprov
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.671
 BuildRequires: which
-Requires(triggerpostun):       sed >= 4.0
+Requires(postun):      sed >= 4.0
 Requires:      %{name}-common = %{version}-%{release}
 Requires:      fonts-TTF-DejaVu
 Requires:      perl-Date-Manip
@@ -70,6 +72,19 @@ Munin, znany poprzednio jako serwer RRD Linpro, odpytuje wiele węzłów
 i przetwarza dane przy użyciu RRDtoola, a następnie prezentuje je na
 stronach WWW.
 
+%package async
+Summary:       Munin asynchronous proxy client/server
+Summary(pl.UTF-8):     Klient/serwer asynchronicznego proxy dla Munina
+Group:         Daemons
+Requires(post,preun):  /sbin/chkconfig
+Requires:      %{name}-node = %{version}-%{release}
+
+%description async
+Asynchronous proxy client/server for Munin node.
+
+%description async -l pl.UTF-8
+Klient/serwer asynchronicznego proxy dla węzła Munina.
+
 %package common
 Summary:       Munin - the Linpro RRD data agent - common files
 Summary(pl.UTF-8):     Munin - agent danych RRD Linpro - wspólne pliki
@@ -98,8 +113,6 @@ Group:               Daemons
 Requires(post,preun):  /sbin/chkconfig
 Requires:      %{name}-common = %{version}-%{release}
 Requires:      logtail
-Requires:      logtool
-#Requires:     perl-Config-General
 Requires:      perl-Net-Netmask
 Requires:      perl-Net-SNMP
 Requires:      perl-Net-Server
@@ -125,6 +138,7 @@ Munin.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %build
 %{__make} -j1 build \
@@ -158,7 +172,7 @@ cp -p %{SOURCE8} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
 
 
-cp -p dists/tarball/plugins.conf $RPM_BUILD_ROOT%{_sysconfdir}
+cp -p %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}
 ln -sf %{_sysconfdir}/plugins.conf $RPM_BUILD_ROOT%{_sysconfdir}/plugin-conf.d/munin-node
 
 for f in cgi-graph cgi-html graph html limits update ; do
@@ -213,25 +227,34 @@ for f in cgi-graph cgi-html graph html limits update ; do
        chown munin:http /var/log/munin/munin-$f.log
 done
 
+%post async
+if [ "$1" = "1" ] ; then
+       /sbin/chkconfig --add munin-asyncd
+fi
+%service munin-asyncd try-restart "Munin Asyncd"
+
+%preun async
+if [ "$1" = "0" ] ; then
+       %service munin-asyncd stop
+       /sbin/chkconfig --del munin-asyncd
+fi
+
 %post node
 if [ "$1" = "1" ] ; then
        /sbin/chkconfig --add munin-node
        %{_sbindir}/munin-node-configure --shell | sh
 fi
-%service munin-node restart "Munin Node agent"
-%service munin-asyncd try-restart "Munin Asyncd agent"
+%service munin-node restart "Munin Node"
 
 %preun node
 if [ "$1" = "0" ] ; then
-       %service munin-asyncd stop
        %service munin-node stop
        /sbin/chkconfig --del munin-node
-       /sbin/chkconfig --del munin-asyncd
 fi
 
 %pre common
 %groupadd -g 158 munin
-%useradd -o -u 158 -s /bin/false -g munin -c "Munin Node agent" -d /var/lib/munin munin
+%useradd -o -u 158 -s /bin/false -g munin -c "Munin Node" -d /var/lib/munin munin
 
 %postun common
 if [ "$1" = "0" ]; then
@@ -302,6 +325,13 @@ fi
 %{perl_vendorlib}/Munin/Common
 %{_mandir}/man3/Munin::Common*
 
+%files async
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/munin-asyncd
+%attr(754,root,root) /etc/rc.d/init.d/munin-asyncd
+%attr(755,root,root) %{_sbindir}/munin-asyncd
+%attr(755,root,root) %{_datadir}/munin/munin-async
+
 %files node
 %defattr(644,root,root,755)
 %dir %{_sysconfdir}
@@ -311,19 +341,15 @@ fi
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/plugins.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/plugin-conf.d/munin-node
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/munin-node
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/munin-asyncd
-%attr(754,root,root) /etc/rc.d/init.d/munin-asyncd
 %attr(754,root,root) /etc/rc.d/init.d/munin-node
+%attr(755,root,root) %{_bindir}/munin-get
 %attr(755,root,root) %{_bindir}/munindoc
-%attr(755,root,root) %{_sbindir}/munin-asyncd
 %attr(755,root,root) %{_sbindir}/munin-node
 %attr(755,root,root) %{_sbindir}/munin-node-configure
 %attr(755,root,root) %{_sbindir}/munin-run
-%attr(755,root,root) %{_sbindir}/munin-sched
 %{perl_vendorlib}/Munin/Node
 %{perl_vendorlib}/Munin/Plugin
 %{perl_vendorlib}/Munin/Plugin.pm
-%attr(755,root,root) %{_datadir}/munin/munin-async
 %dir %{_datadir}/munin/plugins
 %attr(755,root,root) %{_datadir}/munin/plugins/*
 %if !%{with sybase}
@@ -331,9 +357,9 @@ fi
 %endif
 %dir %attr(770,munin,munin) /var/lib/munin/plugin-state
 %dir %attr(770,munin,munin) /var/spool/munin
+%{_mandir}/man1/munin-get*
 %{_mandir}/man1/munin-node*
 %{_mandir}/man1/munin-run*
-%{_mandir}/man1/munin-sched*
 %{_mandir}/man1/munindoc*
 %{_mandir}/man3/Munin::Node*
 %{_mandir}/man3/Munin::Plugin*