]> TLD Linux GIT Repositories - packages/munin.git/blobdiff - munin.spec
- logtool seems no longer needed (not found anywhere in sources)
[packages/munin.git] / munin.spec
index 91e9c58391ecdc44b0916868e84a8a5d7d3fcf8d..2eb35d637253a01450fc3802da7a01a0c0ac31f2 100644 (file)
@@ -1,16 +1,15 @@
 # Condtional build:
 %bcond_with    sybase          # add Sybase support to munin-node
 
-%include       /usr/lib/rpm/macros.perl
 Summary:       Munin - the Linpro RRD data agent
 Summary(pl.UTF-8):     Munin - agent danych RRD Linpro
 Name:          munin
-Version:       2.0.42
-Release:       1
+Version:       2.0.75
+Release:       2
 License:       GPL
 Group:         Applications/WWW
 Source0:       https://github.com/munin-monitoring/munin/archive/%{version}.tar.gz
-# Source0-md5: 802394c56aa714a97b8535c8d6388b17
+# Source0-md5: e793d7d139df7cd7730089186a3afc28
 Source1:       %{name}-node.init
 Source2:       %{name}.cron
 Source3:       %{name}-apache.conf
@@ -20,20 +19,23 @@ Source6:    %{name}-lighttpd.conf
 Source8:       %{name}-httpd.conf
 Source11:      %{name}-asyncd.init
 Source12:      %{name}-asyncd.sysconfig
+Source13:      plugins.conf
 Patch0:                %{name}-Makefile.patch
 Patch1:                %{name}-plugins.patch
 Patch2:                %{name}-templatedir.patch
 Patch3:                %{name}-separate-configs.patch
 Patch4:                %{name}-timeout.patch
+Patch5:                shebang.patch
 URL:           http://munin.sourceforge.net/
 BuildRequires: perl-Encode
+BuildRequires: perl-Module-Build
 BuildRequires: perl-Net-SNMP
 BuildRequires: perl-devel
 BuildRequires: rpm-perlprov
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.671
 BuildRequires: which
-Requires(triggerpostun):       sed >= 4.0
+Requires(postun):      sed >= 4.0
 Requires:      %{name}-common = %{version}-%{release}
 Requires:      fonts-TTF-DejaVu
 Requires:      perl-Date-Manip
@@ -111,8 +113,6 @@ Group:              Daemons
 Requires(post,preun):  /sbin/chkconfig
 Requires:      %{name}-common = %{version}-%{release}
 Requires:      logtail
-Requires:      logtool
-#Requires:     perl-Config-General
 Requires:      perl-Net-Netmask
 Requires:      perl-Net-SNMP
 Requires:      perl-Net-Server
@@ -138,6 +138,7 @@ Munin.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %build
 %{__make} -j1 build \
@@ -171,7 +172,7 @@ cp -p %{SOURCE8} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
 
 
-cp -p dists/tarball/plugins.conf $RPM_BUILD_ROOT%{_sysconfdir}
+cp -p %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}
 ln -sf %{_sysconfdir}/plugins.conf $RPM_BUILD_ROOT%{_sysconfdir}/plugin-conf.d/munin-node
 
 for f in cgi-graph cgi-html graph html limits update ; do
@@ -341,11 +342,11 @@ fi
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/plugin-conf.d/munin-node
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/munin-node
 %attr(754,root,root) /etc/rc.d/init.d/munin-node
+%attr(755,root,root) %{_bindir}/munin-get
 %attr(755,root,root) %{_bindir}/munindoc
 %attr(755,root,root) %{_sbindir}/munin-node
 %attr(755,root,root) %{_sbindir}/munin-node-configure
 %attr(755,root,root) %{_sbindir}/munin-run
-%attr(755,root,root) %{_sbindir}/munin-sched
 %{perl_vendorlib}/Munin/Node
 %{perl_vendorlib}/Munin/Plugin
 %{perl_vendorlib}/Munin/Plugin.pm
@@ -356,9 +357,9 @@ fi
 %endif
 %dir %attr(770,munin,munin) /var/lib/munin/plugin-state
 %dir %attr(770,munin,munin) /var/spool/munin
+%{_mandir}/man1/munin-get*
 %{_mandir}/man1/munin-node*
 %{_mandir}/man1/munin-run*
-%{_mandir}/man1/munin-sched*
 %{_mandir}/man1/munindoc*
 %{_mandir}/man3/Munin::Node*
 %{_mandir}/man3/Munin::Plugin*