]> TLD Linux GIT Repositories - packages/munin.git/blobdiff - munin.spec
- make it work with current munin version
[packages/munin.git] / munin.spec
index 738c64ba77d28e0e17a7758ca7e1eaa990563b39..8fe90b5357a0225056bbf047450bcd0966bfce47 100644 (file)
@@ -9,22 +9,19 @@
 Summary:       Munin - the Linpro RRD data agent
 Summary(pl.UTF-8):     Munin - agent danych RRD Linpro
 Name:          munin
-Version:       2.0.19
-Release:       3
+Version:       2.0.25
+Release:       1
 License:       GPL
 Group:         Applications/WWW
 Source0:       http://downloads.sourceforge.net/munin/%{name}-%{version}.tar.gz
-# Source0-md5: ab27d477052c0f5da4ed81edb7f95f1b
+# Source0-md5: b418a667ce42665557329a7ac3bd1b93
 Source1:       %{name}-node.init
 Source2:       %{name}.cron
 Source3:       %{name}-apache.conf
 Source4:       %{name}.logrotate
 Source5:       %{name}-node.logrotate
 Source6:       %{name}-lighttpd.conf
-Source7:       %{name}.tmpfiles
 Source8:       %{name}-httpd.conf
-Source9:       %{name}-node.service
-Source10:      %{name}-asyncd.service
 Source11:      %{name}-asyncd.init
 Patch0:                %{name}-Makefile.patch
 Patch1:                %{name}-plugins.patch
@@ -113,7 +110,6 @@ Requires:   perl-libwww
 Requires:      procps >= 2.0.7
 Requires:      rc-scripts >= 0.4.0.15
 Requires:      sysstat
-Requires:      systemd-units >= 38
 Suggests:      perl-DBD-Pg
 Conflicts:     logrotate < 3.7-4
 
@@ -142,9 +138,7 @@ Munin.
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,cron.d,logrotate.d},%{_bindir},%{_sbindir}} \
        $RPM_BUILD_ROOT/var/log/archive/munin \
-       $RPM_BUILD_ROOT%{_webapps}/%{_webapp} \
-       $RPM_BUILD_ROOT%{systemdtmpfilesdir} \
-       $RPM_BUILD_ROOT%{systemdunitdir}
+       $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
 
 %{__make} -j1 install \
        JCVALID=no \
@@ -164,11 +158,6 @@ cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
 cp -p %{SOURCE8} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
 
-cp -p %{SOURCE7} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
-
-cp -p %{SOURCE9} $RPM_BUILD_ROOT%{systemdunitdir}/munin-node.service
-cp -p %{SOURCE10} $RPM_BUILD_ROOT%{systemdunitdir}/munin-asyncd.service
-
 cp -p dists/tarball/plugins.conf $RPM_BUILD_ROOT%{_sysconfdir}
 ln -sf %{_sysconfdir}/plugins.conf $RPM_BUILD_ROOT%{_sysconfdir}/plugin-conf.d/munin-node
 
@@ -231,8 +220,6 @@ if [ "$1" = "1" ] ; then
 fi
 %service munin-node restart "Munin Node agent"
 %service munin-asyncd try-restart "Munin Asyncd agent"
-%systemd_post munin-node.service
-%systemd_service_restart munin-asyncd.service
 
 %preun node
 if [ "$1" = "0" ] ; then
@@ -241,13 +228,6 @@ if [ "$1" = "0" ] ; then
        /sbin/chkconfig --del munin-node
        /sbin/chkconfig --del munin-asyncd
 fi
-%systemd_preun munin-node.service munin-asyncd.service
-
-%postun node
-%systemd_reload
-
-%triggerpostun node -- munin-node < 2.0.17-1
-%systemd_trigger munin-node.service
 
 %pre common
 %groupadd -g 158 munin
@@ -314,7 +294,6 @@ fi
 %defattr(644,root,root,755)
 %doc README ChangeLog logo* Checklist
 %dir %{_datadir}/munin
-%{systemdtmpfilesdir}/%{name}.conf
 %attr(770,munin,http) %dir /var/log/munin
 %attr(750,munin,http) %dir /var/log/archive/munin
 %attr(771,munin,munin) %dir /var/lib/munin
@@ -334,8 +313,6 @@ fi
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/munin-node
 %attr(754,root,root) /etc/rc.d/init.d/munin-asyncd
 %attr(754,root,root) /etc/rc.d/init.d/munin-node
-%{systemdunitdir}/munin-asyncd.service
-%{systemdunitdir}/munin-node.service
 %attr(755,root,root) %{_bindir}/munindoc
 %attr(755,root,root) %{_sbindir}/munin-asyncd
 %attr(755,root,root) %{_sbindir}/munin-node