]> TLD Linux GIT Repositories - packages/mysql.git/blobdiff - mysql-system-xxhash.patch
- fix bcond comment (breaks build)
[packages/mysql.git] / mysql-system-xxhash.patch
index 9ca55141367f81d0bca745b2ecf963683a411080..62c1cc64f436fcc4f1069a04f877c244e466ef15 100644 (file)
@@ -1,6 +1,26 @@
---- mysql-8.0.30/plugin/group_replication/libmysqlgcs/src/bindings/xcom/gcs_message_stage_split.cc.orig        2022-07-06 23:36:34.000000000 +0200
-+++ mysql-8.0.30/plugin/group_replication/libmysqlgcs/src/bindings/xcom/gcs_message_stage_split.cc     2022-10-09 14:33:34.598098038 +0200
-@@ -126,7 +126,7 @@ Gcs_sender_id calculate_sender_id(const
+diff -urNpa mysql-8.4.0.orig/plugin/group_replication/libmysqlgcs/CMakeLists.txt mysql-8.4.0/plugin/group_replication/libmysqlgcs/CMakeLists.txt
+--- mysql-8.4.0.orig/plugin/group_replication/libmysqlgcs/CMakeLists.txt       2024-05-09 18:15:12.545961950 +0200
++++ mysql-8.4.0/plugin/group_replication/libmysqlgcs/CMakeLists.txt    2024-05-09 18:15:56.994571858 +0200
+@@ -138,7 +138,6 @@ SET(GCS_SOURCES
+   src/bindings/xcom/gcs_xcom_statistics_interface.cc
+   src/bindings/xcom/gcs_xcom_proxy.cc
+   src/bindings/xcom/gcs_xcom_communication_protocol_changer.cc
+-  ${BUNDLED_LZ4_PATH}/xxhash.c # required by gcs_message_stage_split
+   src/bindings/xcom/gcs_message_stage_split.cc
+   src/bindings/xcom/gcs_xcom_synode.cc
+   src/bindings/xcom/gcs_xcom_expels_in_progress.cc
+@@ -236,6 +235,7 @@ ADD_LIBRARY(mysqlgcs STATIC ${XCOM_SOURC
+ # Dependency on mysys from gcs_logging_system.cc
+ # but pick up symbols from the server:
+ # TARGET_LINK_LIBRARIES(mysqlgcs mysys)
++TARGET_LINK_LIBRARIES(mysqlgcs xxhash)
+ IF(LINUX AND WITH_TIRPC STREQUAL "bundled")
+   ADD_DEPENDENCIES(mysqlgcs tirpc_ext)
+diff -urNpa mysql-8.4.0.orig/plugin/group_replication/libmysqlgcs/src/bindings/xcom/gcs_message_stage_split.cc mysql-8.4.0/plugin/group_replication/libmysqlgcs/src/bindings/xcom/gcs_message_stage_split.cc
+--- mysql-8.4.0.orig/plugin/group_replication/libmysqlgcs/src/bindings/xcom/gcs_message_stage_split.cc 2024-05-09 18:15:12.549962005 +0200
++++ mysql-8.4.0/plugin/group_replication/libmysqlgcs/src/bindings/xcom/gcs_message_stage_split.cc      2024-05-09 18:15:57.910584352 +0200
+@@ -127,7 +127,7 @@ Gcs_sender_id calculate_sender_id(const
    std::string info(node.get_member_id().get_member_id());
    info.append(node.get_member_uuid().actual_value);
  
@@ -9,9 +29,10 @@
  }
  
  bool Gcs_message_stage_split_v2::update_members_information(
---- mysql-8.0.30/plugin/group_replication/libmysqlgcs/src/bindings/xcom/gcs_xxhash.h.orig      2022-07-06 23:36:34.000000000 +0200
-+++ mysql-8.0.30/plugin/group_replication/libmysqlgcs/src/bindings/xcom/gcs_xxhash.h   2022-10-09 08:41:35.109178797 +0200
-@@ -25,10 +25,6 @@
+diff -urNpa mysql-8.4.0.orig/plugin/group_replication/libmysqlgcs/src/bindings/xcom/gcs_xxhash.h mysql-8.4.0/plugin/group_replication/libmysqlgcs/src/bindings/xcom/gcs_xxhash.h
+--- mysql-8.4.0.orig/plugin/group_replication/libmysqlgcs/src/bindings/xcom/gcs_xxhash.h       2024-05-09 18:15:12.549962005 +0200
++++ mysql-8.4.0/plugin/group_replication/libmysqlgcs/src/bindings/xcom/gcs_xxhash.h    2024-05-09 18:15:57.910584352 +0200
+@@ -26,10 +26,6 @@
    Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301  USA
  */
  
 +#include <xxhash.h>
  
  #endif  // GCS_XXHASH_H_INCLUDED
---- mysql-8.0.30/plugin/group_replication/libmysqlgcs/CMakeLists.txt.orig      2022-07-06 23:36:34.000000000 +0200
-+++ mysql-8.0.30/plugin/group_replication/libmysqlgcs/CMakeLists.txt   2022-10-09 08:42:55.768741827 +0200
-@@ -140,7 +140,6 @@ SET(GCS_SOURCES
-   src/bindings/xcom/gcs_xcom_statistics_interface.cc
-   src/bindings/xcom/gcs_xcom_proxy.cc
-   src/bindings/xcom/gcs_xcom_communication_protocol_changer.cc
--  ${BUNDLED_LZ4_PATH}/xxhash.c # required by gcs_message_stage_split
-   src/bindings/xcom/gcs_message_stage_split.cc
-   src/bindings/xcom/gcs_xcom_synode.cc
-   src/bindings/xcom/gcs_xcom_expels_in_progress.cc)
-@@ -219,6 +218,7 @@ ADD_LIBRARY(mysqlgcs STATIC ${XCOM_SOURC
- # Dependency on mysys from gcs_logging_system.cc
- # but pick up symbols from the server:
- # TARGET_LINK_LIBRARIES(mysqlgcs mysys)
-+TARGET_LINK_LIBRARIES(mysqlgcs xxhash)
- IF(CMAKE_VERSION VERSION_GREATER "3.19" AND NOT APPLE_XCODE)
-   # New in version 3.19:
---- mysql-8.0.30/sql/CMakeLists.txt.orig       2022-07-06 23:36:34.000000000 +0200
-+++ mysql-8.0.30/sql/CMakeLists.txt    2022-10-09 08:53:20.935355008 +0200
-@@ -755,7 +755,6 @@ SET(SQL_SOURCE
+diff -urNpa mysql-8.4.0.orig/sql/CMakeLists.txt mysql-8.4.0/sql/CMakeLists.txt
+--- mysql-8.4.0.orig/sql/CMakeLists.txt        2024-05-09 18:15:03.917843242 +0200
++++ mysql-8.4.0/sql/CMakeLists.txt     2024-05-09 18:16:12.978789893 +0200
+@@ -762,7 +762,6 @@ SET(SQL_SOURCE
    ${CONF_SOURCES}
    ${SQL_SHARED_SOURCES}
    ${SQL_HEADERS}
@@ -51,7 +55,7 @@
    ../libmysql/errmsg.cc
    ../sql-common/client.cc
    ../sql-common/client_plugin.cc
-@@ -813,11 +812,6 @@ IF(WIN32)
+@@ -828,11 +827,6 @@ IF(WIN32)
        )
  ENDIF()
  
  # Workaround for Apple Clang bug on ARM.
  # When linking mysqld (and executables using server_unittest_library)
  # we get linker warnings about
-@@ -842,13 +836,6 @@ IF(APPLE_ARM)
-     )
+@@ -858,14 +852,6 @@ IF(APPLE_ARM)
  ENDIF()
  
--ADD_COMPILE_FLAGS(
+ ADD_COMPILE_FLAGS(
 -  ${BUNDLED_LZ4_PATH}/xxhash.c
 -  iterators/hash_join_iterator.cc
+-  iterators/composite_iterators.cc
 -  rpl_write_set_handler.cc
 -  COMPILE_FLAGS -I${CMAKE_SOURCE_DIR}/extra/lz4 -I${BUNDLED_LZ4_PATH}
 -  )
 -
- # Fixes "C1128: number of sections exceeded object file format limit" in MSVC
- IF(WIN32)
-   ADD_COMPILE_FLAGS(
-@@ -924,7 +911,7 @@ ADD_DEPENDENCIES(sql_main GenBootstrapPr
- ADD_DEPENDENCIES(sql_main GenSysSchema)
+-ADD_COMPILE_FLAGS(
+   iterators/composite_iterators.cc
+   iterators/hash_join_buffer.cc
+   COMPILE_FLAGS
+@@ -966,7 +952,7 @@ MYSQL_ADD_PLUGIN(mysql_native_password
  TARGET_LINK_LIBRARIES(sql_main ${MYSQLD_STATIC_PLUGIN_LIBS}
    mysql_server_component_services mysys strings vio
--  binlogevents_static ${LIBWRAP} ${LIBDL} ${SSL_LIBRARIES})
-+  binlogevents_static xxhash ${LIBWRAP} ${LIBDL} ${SSL_LIBRARIES})
+-  mysql_binlog_event ${LIBWRAP} ${LIBDL} OpenSSL::SSL OpenSSL::Crypto
++  mysql_binlog_event xxhash ${LIBWRAP} ${LIBDL} OpenSSL::SSL OpenSSL::Crypto
+   extra::rapidjson extra::boost)
  
  # sql/immutable_string.h uses
- # google::protobuf::io::CodedOutputStream::WriteVarint64ToArray
---- mysql-8.0.30/sql/iterators/hash_join_iterator.cc.orig      2022-07-06 23:36:34.000000000 +0200
-+++ mysql-8.0.30/sql/iterators/hash_join_iterator.cc   2022-10-09 17:45:57.618897459 +0200
-@@ -32,7 +32,7 @@
- #include "field_types.h"
- #include "my_alloc.h"
- #include "my_bit.h"
+diff -urNpa mysql-8.4.0.orig/sql/iterators/composite_iterators.cc mysql-8.4.0/sql/iterators/composite_iterators.cc
+--- mysql-8.4.0.orig/sql/iterators/composite_iterators.cc      2024-05-09 18:15:03.989844233 +0200
++++ mysql-8.4.0/sql/iterators/composite_iterators.cc   2024-05-09 18:15:57.910584352 +0200
+@@ -44,7 +44,7 @@
+ #include "my_dbug.h"
+ #include "my_inttypes.h"
+ #include "my_sys.h"
 -#include "my_xxhash.h"
 +#include <xxhash.h>
+ #include "mysql_com.h"
+ #include "mysqld_error.h"
+ #include "prealloced_array.h"
+@@ -2928,7 +2928,7 @@ bool SpillState::compute_chunk_file_sets
+   const ulonglong primary_hash =
+       static_cast<ulonglong>(m_materialized_table->hash_field->val_int());
+   const uint64_t chunk_hash =
+-      MY_XXH64(&primary_hash, sizeof(primary_hash), m_hash_seed);
++      XXH64(&primary_hash, sizeof(primary_hash), m_hash_seed);
  
+   const size_t chunk_index = hash_to_chunk_index(chunk_hash);
+   m_offending_row.m_chunk_offset = chunk_offset(chunk_index);
+@@ -3005,7 +3005,7 @@ bool SpillState::spread_hash_map_to_HF_c
+         const ulonglong primary_hash =
+             static_cast<ulonglong>(m_materialized_table->hash_field->val_int());
+         const uint64_t chunk_hash =
+-            MY_XXH64(&primary_hash, sizeof(primary_hash), m_hash_seed);
++            XXH64(&primary_hash, sizeof(primary_hash), m_hash_seed);
+         const size_t chunk_index = hash_to_chunk_index(chunk_hash);
+         const size_t set_index = chunk_index_to_set(chunk_index);
+         const size_t offset = chunk_offset(chunk_index);
+@@ -3070,7 +3070,7 @@ bool SpillState::append_hash_map_to_HF()
+       const ulonglong primary_hash =
+           static_cast<ulonglong>(m_materialized_table->hash_field->val_int());
+       const uint64_t chunk_hash =
+-          MY_XXH64(&primary_hash, sizeof(primary_hash), m_hash_seed);
++          XXH64(&primary_hash, sizeof(primary_hash), m_hash_seed);
+       const size_t chunk_index = hash_to_chunk_index(chunk_hash);
+       const size_t set_index = chunk_index_to_set(chunk_index);
+       const size_t offset = chunk_offset(chunk_index);
+@@ -3164,7 +3164,7 @@ bool SpillState::save_operand_to_IF_chun
+       m_materialized_table->hash_field->store(
+           static_cast<longlong>(primary_hash), true);
+       const uint64_t chunk_hash =
+-          MY_XXH64(&primary_hash, sizeof(primary_hash), m_hash_seed);
++          XXH64(&primary_hash, sizeof(primary_hash), m_hash_seed);
+       const size_t chunk_index = hash_to_chunk_index(chunk_hash);
+       const size_t set_index = chunk_index_to_set(chunk_index);
+       const size_t offset = chunk_offset(chunk_index);
+@@ -3219,7 +3219,7 @@ bool SpillState::write_HF(THD *thd, size
+     const ulonglong primary_hash =
+         static_cast<ulonglong>(m_materialized_table->hash_field->val_int());
+     const uint64_t chunk_hash =
+-        MY_XXH64(&primary_hash, sizeof(primary_hash), m_hash_seed);
++        XXH64(&primary_hash, sizeof(primary_hash), m_hash_seed);
+     const size_t chunk_index = hash_to_chunk_index(chunk_hash);
+     const size_t set_index = chunk_index_to_set(chunk_index);
+     assert(chunk_offset(chunk_index) == chunk_idx);
+@@ -3452,7 +3452,7 @@ int SpillState::read_next_row(const Oper
+             const ulonglong primary_hash = static_cast<ulonglong>(
+                 m_materialized_table->hash_field->val_int());
+             const uint64_t chunk_hash =
+-                MY_XXH64(&primary_hash, sizeof(primary_hash), m_hash_seed);
++                XXH64(&primary_hash, sizeof(primary_hash), m_hash_seed);
+             const size_t chunk_index = hash_to_chunk_index(chunk_hash);
+             const size_t set_index = chunk_index_to_set(chunk_index);
+             assert(chunk_offset(chunk_index) == m_current_chunk_idx);
+@@ -3485,7 +3485,7 @@ int SpillState::read_next_row(const Oper
+             const ulonglong primary_hash = static_cast<ulonglong>(
+                 m_materialized_table->hash_field->val_int());
+             const uint64_t chunk_hash =
+-                MY_XXH64(&primary_hash, sizeof(primary_hash), m_hash_seed);
++                XXH64(&primary_hash, sizeof(primary_hash), m_hash_seed);
+             const size_t chunk_index = hash_to_chunk_index(chunk_hash);
+             assert(chunk_index_to_set(chunk_index) == set_idx);
+             assert(chunk_offset(chunk_index) == m_current_chunk_idx);
+@@ -3574,7 +3574,7 @@ int SpillState::read_next_row_secondary_
+           const ulonglong primary_hash = static_cast<ulonglong>(
+               m_materialized_table->hash_field->val_int());
+           const uint64_t chunk_hash =
+-              MY_XXH64(&primary_hash, sizeof(primary_hash), m_hash_seed);
++              XXH64(&primary_hash, sizeof(primary_hash), m_hash_seed);
+           const size_t chunk_index = hash_to_chunk_index(chunk_hash);
+           assert(chunk_index_to_set(chunk_index) == set_idx);
+           assert(chunk_offset(chunk_index) == m_current_chunk_idx);
+diff -urNpa mysql-8.4.0.orig/sql/iterators/hash_join_iterator.cc mysql-8.4.0/sql/iterators/hash_join_iterator.cc
+--- mysql-8.4.0.orig/sql/iterators/hash_join_iterator.cc       2024-05-09 18:15:03.989844233 +0200
++++ mysql-8.4.0/sql/iterators/hash_join_iterator.cc    2024-05-09 18:15:57.910584352 +0200
+@@ -38,7 +38,7 @@
+ #include "my_dbug.h"
  #include "my_inttypes.h"
  #include "my_sys.h"
-@@ -307,7 +307,7 @@ static bool WriteRowToChunk(
+-#include "my_xxhash.h"
++#include <xxhash.h>
+ #include "mysql/components/services/bits/psi_bits.h"
+ #include "mysqld_error.h"
+ #include "sql/item.h"
+@@ -378,7 +378,7 @@ static bool WriteRowToChunk(
    const uint64_t join_key_hash =
        join_key_and_row_buffer->length() == 0
            ? kZeroKeyLengthHash
                       join_key_and_row_buffer->length(), xxhash_seed);
  
    assert((chunks->size() & (chunks->size() - 1)) == 0);
---- mysql-8.0.30/sql/rpl_write_set_handler.cc.orig     2022-07-06 23:36:34.000000000 +0200
-+++ mysql-8.0.30/sql/rpl_write_set_handler.cc  2022-10-09 20:07:41.099496817 +0200
+diff -urNpa mysql-8.4.0.orig/sql/rpl_write_set_handler.cc mysql-8.4.0/sql/rpl_write_set_handler.cc
+--- mysql-8.4.0.orig/sql/rpl_write_set_handler.cc      2024-05-09 18:15:03.945843627 +0200
++++ mysql-8.4.0/sql/rpl_write_set_handler.cc   2024-05-09 18:15:57.910584352 +0200
 @@ -37,7 +37,7 @@
  #include "my_dbug.h"
  #include "my_inttypes.h"
  #include "my_murmur3.h"  // murmur3_32
 -#include "my_xxhash.h"   // IWYU pragma: keep
 +#include <xxhash.h>
+ #include "mysql/strings/m_ctype.h"
  #include "mysql_com.h"
  #include "sql-common/json_binary.h"
- #include "sql-common/json_dom.h"
-@@ -75,7 +75,7 @@ uint64 calc_hash(ulong algorithm, type T
-   if (algorithm == HASH_ALGORITHM_MURMUR32)
-     return (murmur3_32((const uchar *)T, len, 0));
-   else
--    return (MY_XXH64((const uchar *)T, len, 0));
-+    return (XXH64((const uchar *)T, len, 0));
- }
+@@ -682,7 +682,7 @@ static bool generate_hash_pke(const std:
+ ) {
+   DBUG_TRACE;
  
- #ifndef NDEBUG
---- mysql-8.0.30/unittest/gunit/hash_join-t.cc.orig    2022-07-06 23:36:34.000000000 +0200
-+++ mysql-8.0.30/unittest/gunit/hash_join-t.cc 2022-10-09 20:36:43.693389709 +0200
-@@ -28,7 +28,7 @@
- #include "include/my_murmur3.h"
- #include "my_alloc.h"
+-  uint64 hash = MY_XXH64(pke.c_str(), pke.size(), 0);
++  uint64 hash = XXH64(pke.c_str(), pke.size(), 0);
+   if (thd->get_transaction()->get_transaction_write_set_ctx()->add_write_set(
+           hash))
+     return true;
+diff -urNpa mysql-8.4.0.orig/unittest/gunit/hash_join-t.cc mysql-8.4.0/unittest/gunit/hash_join-t.cc
+--- mysql-8.4.0.orig/unittest/gunit/hash_join-t.cc     2024-05-09 18:15:15.950008783 +0200
++++ mysql-8.4.0/unittest/gunit/hash_join-t.cc  2024-05-09 18:15:57.910584352 +0200
+@@ -38,7 +38,7 @@
+ #include "my_config.h"
+ #include "my_inttypes.h"
+ #include "my_murmur3.h"
 -#include "my_xxhash.h"
 +#include <xxhash.h>
- #include "sql/item_cmpfunc.h"
- #include "sql/iterators/hash_join_buffer.h"
- #include "sql/iterators/hash_join_iterator.h"
-@@ -204,7 +204,7 @@ static void BM_XXHash64ShortData(size_t
+ #include "mysql/components/services/bits/psi_bits.h"
+ #include "prealloced_array.h"
+ #include "sql/field.h"
+@@ -227,7 +227,7 @@ static void BM_XXHash64ShortData(size_t
  
    size_t sum = 0;
    for (size_t i = 0; i < num_iterations; ++i) {
    }
    StopBenchmarkTiming();
  
-@@ -223,7 +223,7 @@ static void BM_XXHash64LongData(size_t n
+@@ -246,7 +246,7 @@ static void BM_XXHash64LongData(size_t n
  
    size_t sum = 0;
    for (size_t i = 0; i < num_iterations; ++i) {
    }
    StopBenchmarkTiming();
  
---- mysql-8.0.30/unittest/gunit/innodb/ut0rnd-t.cc.orig        2022-07-06 23:36:34.000000000 +0200
-+++ mysql-8.0.30/unittest/gunit/innodb/ut0rnd-t.cc     2022-10-09 20:46:00.157041753 +0200
-@@ -33,7 +33,7 @@
+diff -urNpa mysql-8.4.0.orig/unittest/gunit/innodb/ut0rnd-t.cc mysql-8.4.0/unittest/gunit/innodb/ut0rnd-t.cc
+--- mysql-8.4.0.orig/unittest/gunit/innodb/ut0rnd-t.cc 2024-05-09 18:15:15.998009443 +0200
++++ mysql-8.4.0/unittest/gunit/innodb/ut0rnd-t.cc      2024-05-09 18:15:57.910584352 +0200
+@@ -34,7 +34,7 @@
  #include "storage/innobase/include/ut0crc32.h"
  #include "storage/innobase/include/ut0rnd.h"