]> TLD Linux GIT Repositories - packages/mysql.git/blobdiff - mysql.spec
- fixed upstream
[packages/mysql.git] / mysql.spec
index 521fa82fa0e3bb6d5431dc5906b008041d774525..1bc74b8fb7edd4f53966307544fcd7f7d9d55249 100644 (file)
@@ -23,8 +23,8 @@
 %bcond_with    tests           # FIXME: don't run correctly
 %bcond_with    ndb             # NDB is now a separate product, this here is broken, so disable it
 
-%define                rel     3
-%define                percona_rel     64.1
+%define                rel     0.1
+%define                percona_rel     65.0
 %include       /usr/lib/rpm/macros.perl
 Summary:       MySQL: a very fast and reliable SQL database engine
 Summary(de.UTF-8):     MySQL: ist eine SQL-Datenbank
@@ -35,16 +35,16 @@ Summary(ru.UTF-8):  MySQL - быстрый SQL-сервер
 Summary(uk.UTF-8):     MySQL - швидкий SQL-сервер
 Summary(zh_CN.UTF-8):  MySQL数据库服务器
 Name:          mysql
-Version:       5.6.16
+Version:       5.6.17
 Release:       %{percona_rel}.%{rel}
 License:       GPL + MySQL FLOSS Exception
 Group:         Applications/Databases
 # Source0Download: http://dev.mysql.com/downloads/mysql/5.5.html#downloads
 # Source0:     http://vesta.informatik.rwth-aachen.de/mysql/Downloads/MySQL-5.5/%{name}-%{version}.tar.gz
 Source0:       http://www.percona.com/downloads/Percona-Server-5.6/LATEST/source/tarball/percona-server-%{version}-%{percona_rel}.tar.gz
-# Source0-md5: ba75fbcc530dc74ebb978cf450c011b3
-Source100:     http://www.sphinxsearch.com/files/sphinx-2.1.6-release.tar.gz
-# Source100-md5:       f416c743c0e0f4e337b4549928d8494f
+# Source0-md5: 064e0c9275ec87fd7a16a32c28a9963b
+Source100:     http://www.sphinxsearch.com/files/sphinx-2.1.8-release.tar.gz
+# Source100-md5:       ef21091bb30a82f175be5bf9142490b7
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 Source3:       %{name}.logrotate
@@ -73,20 +73,15 @@ Patch18:    %{name}-sphinx.patch
 Patch19:       %{name}-chain-certs.patch
 # from fedora
 Patch20:       %{name}-dubious-exports.patch
-Patch21:       bison3.patch
-Patch22:       bug-66589.patch
-Patch23:       bug-44278.patch
-Patch24:       %{name}-cmake.patch
-Patch25:       %{name}-readline.patch
+Patch21:       bug-66589.patch
+Patch22:       bug-44278.patch
+Patch23:       %{name}-cmake.patch
+Patch24:       %{name}-readline.patch
 URL:           http://www.mysql.com/products/community/
 BuildRequires: bison >= 1.875
 BuildRequires: cmake >= 2.6
 BuildRequires: readline-devel >= 6.2
-%if "%{pld_release}" == "ac"
-BuildRequires: libstdc++4-devel >= 5:4.0
-%else
 BuildRequires: libstdc++-devel >= 5:4.0
-%endif
 BuildRequires: automake
 %{?with_tcpd:BuildRequires:    libwrap-devel}
 BuildRequires: ncurses-devel >= 4.2
@@ -520,7 +515,6 @@ mv sphinx-*/mysqlse storage/sphinx
 %patch22 -p1
 %patch23 -p1
 %patch24 -p1
-%patch25 -p1
 
 # to get these files rebuild
 [ -f sql/sql_yacc.cc ] && rm sql/sql_yacc.cc
@@ -536,13 +530,6 @@ cd build
 # (it defaults to first cluster but user may change it to whatever
 # cluster it wants)
 
-%if "%{pld_release}" == "ac"
-# add suffix, but allow ccache, etc in ~/.rpmmacros
-%{expand:%%define      __cc    %(echo '%__cc' | sed -e 's,-gcc,-gcc4,')}
-%{expand:%%define      __cxx   %(echo '%__cxx' | sed -e 's,-g++,-g++4,')}
-%{expand:%%define      __cpp   %(echo '%__cpp' | sed -e 's,-gcc,-gcc4,')}
-%endif
-
 %cmake \
        -DCMAKE_BUILD_TYPE=%{!?debug:RelWithDebInfo}%{?debug:Debug} \
        -DCMAKE_C_FLAGS_RELEASE="%{rpmcflags} -DNDEBUG -fno-omit-frame-pointer -fno-strict-aliasing" \
@@ -566,11 +553,7 @@ cd build
        -DWITH_PERFSCHEMA_STORAGE_ENGINE=1 \
        -DWITH_PIC=ON \
        -DWITH_EDITLINE=system \
-%if "%{pld_release}" == "ac"
-       -DWITH_SSL=%{?with_ssl:bundled}%{!?with_ssl:no} \
-%else
        -DWITH_SSL=%{?with_ssl:system}%{!?with_ssl:no} \
-%endif
        -DWITH_UNIT_TESTS=%{?with_tests:ON}%{!?with_tests:OFF} \
        -DWITH_ZLIB=system \
        ..