]> TLD Linux GIT Repositories - packages/mysql.git/blobdiff - mysql.spec
- updated to 5.6.29-76.2
[packages/mysql.git] / mysql.spec
index a79616da84186ee5cdbe86967e77f8f5bd54f50b..5fc80051d4b4deec42d4b2d41894f102312a8ab0 100644 (file)
@@ -23,8 +23,8 @@
 %bcond_with    tests           # FIXME: don't run correctly
 %bcond_with    ndb             # NDB is now a separate product, this here is broken, so disable it
 
-%define                rel     0.1
-%define                percona_rel     65.0
+%define                rel     1
+%define                percona_rel     76.2
 %include       /usr/lib/rpm/macros.perl
 Summary:       MySQL: a very fast and reliable SQL database engine
 Summary(de.UTF-8):     MySQL: ist eine SQL-Datenbank
@@ -35,16 +35,14 @@ Summary(ru.UTF-8):  MySQL - быстрый SQL-сервер
 Summary(uk.UTF-8):     MySQL - швидкий SQL-сервер
 Summary(zh_CN.UTF-8):  MySQL数据库服务器
 Name:          mysql
-Version:       5.6.17
+Version:       5.6.29
 Release:       %{percona_rel}.%{rel}
 License:       GPL + MySQL FLOSS Exception
 Group:         Applications/Databases
-# Source0Download: http://dev.mysql.com/downloads/mysql/5.5.html#downloads
-# Source0:     http://vesta.informatik.rwth-aachen.de/mysql/Downloads/MySQL-5.5/%{name}-%{version}.tar.gz
 Source0:       http://www.percona.com/downloads/Percona-Server-5.6/LATEST/source/tarball/percona-server-%{version}-%{percona_rel}.tar.gz
-# Source0-md5: 064e0c9275ec87fd7a16a32c28a9963b
-Source100:     http://www.sphinxsearch.com/files/sphinx-2.1.8-release.tar.gz
-# Source100-md5:       ef21091bb30a82f175be5bf9142490b7
+# Source0-md5: 8a0e3327e5b850852af6b9ca614d6bd7
+Source100:     http://www.sphinxsearch.com/files/sphinx-2.2.10-release.tar.gz
+# Source100-md5:       dda52b24d8348fc09e26d8a649a231d2
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 Source3:       %{name}.logrotate
@@ -75,8 +73,6 @@ Patch19:      %{name}-chain-certs.patch
 Patch20:       %{name}-dubious-exports.patch
 Patch21:       bug-66589.patch
 Patch22:       bug-44278.patch
-Patch23:       %{name}-cmake.patch
-Patch24:       %{name}-readline.patch
 URL:           http://www.mysql.com/products/community/
 BuildRequires: bison >= 1.875
 BuildRequires: cmake >= 2.6
@@ -513,8 +509,6 @@ mv sphinx-*/mysqlse storage/sphinx
 %patch20 -p1
 %patch21 -p1
 %patch22 -p1
-%patch23 -p1
-%patch24 -p1
 
 # to get these files rebuild
 [ -f sql/sql_yacc.cc ] && rm sql/sql_yacc.cc
@@ -534,7 +528,7 @@ cd build
        -DCMAKE_BUILD_TYPE=%{!?debug:RelWithDebInfo}%{?debug:Debug} \
        -DCMAKE_C_FLAGS_RELEASE="%{rpmcflags} -DNDEBUG -fno-omit-frame-pointer -fno-strict-aliasing" \
        -DCMAKE_CXX_FLAGS_RELEASE="%{rpmcxxflags} -DNDEBUG -fno-omit-frame-pointer -fno-strict-aliasing" \
-       -DCOMPILATION_COMMENT="PLD/Linux Distribution MySQL RPM" \
+       -DCOMPILATION_COMMENT="TLD Linux MySQL RPM" \
        -DCURSES_INCLUDE_PATH=/usr/include/ncurses \
        %{?with_systemtap:-DENABLE_DTRACE=ON} \
        -DFEATURE_SET="community" \
@@ -552,8 +546,10 @@ cd build
        -DWITH_PAM=ON \
        -DWITH_PERFSCHEMA_STORAGE_ENGINE=1 \
        -DWITH_PIC=ON \
-       -DWITH_EDITLINE=system \
+       -DWITH_READLINE=system \
        -DWITH_SSL=%{?with_ssl:system}%{!?with_ssl:no} \
+       -DWITHOUT_TOKUDB=1 \
+       -DWITHOUT_TOKUDB_STORAGE_ENGINE=1 \
        -DWITH_UNIT_TESTS=%{?with_tests:ON}%{!?with_tests:OFF} \
        -DWITH_ZLIB=system \
        ..
@@ -758,7 +754,7 @@ for config in $(awk -F= '!/^#/ && /=/{print $1}' /etc/%{name}/clusters.conf); do
        fi
 
        if [ ! -f "$config_file" ]; then
-                       echo >&2 "Lost myself! Please report this (with above errors, if any) to http://bugs.pld-linux.org/"
+                       echo >&2 "Lost myself! Please report this (with above errors, if any) to TLD Linux mailing lists."
                        exit 1
        fi
        echo "Adding option old-passwords to config: $config_file"
@@ -797,7 +793,7 @@ for config in $(awk -F= '!/^#/ && /=/{print $1}' /etc/%{name}/clusters.conf); do
        fi
 
        if [ ! -f "$config_file" ]; then
-               echo >&2 "ERROR: Can't find real config file for $config! Please report this (with above errors, if any) to http://bugs.pld-linux.org/"
+               echo >&2 "ERROR: Can't find real config file for $config! Please report this (with above errors, if any) to TLD Linux mailing lists."
                continue
        fi
        configs="$configs $config_file"
@@ -836,7 +832,7 @@ for config in $(awk -F= '!/^#/ && /=/{print $1}' /etc/%{name}/clusters.conf); do
        fi
 
        if [ ! -f "$config_file" ]; then
-               echo >&2 "ERROR: Can't find real config file for $config! Please report this (with above errors, if any) to http://bugs.pld-linux.org/"
+               echo >&2 "ERROR: Can't find real config file for $config! Please report this (with above errors, if any) to TLD Linux mailing lists."
                continue
        fi
        configs="$configs $config_file"