]> TLD Linux GIT Repositories - packages/mysql.git/blobdiff - mysql.spec
- fix building with OpenSSL 3.0, no R(triggerpostun) in rpm.org
[packages/mysql.git] / mysql.spec
index cf3d5731f5f9fe878ac8e5dec7f7aa5945818dcf..a73f76b7e3105229b01d3e0be600ffc04af7b7ed 100644 (file)
@@ -36,7 +36,7 @@
 %bcond_with    system_boost    # Use system boost package
 %bcond_with    tests           # FIXME: don't run correctly
 %bcond_with    ndb             # NDB is now a separate product, this here is broken, so disable it
-%bcond_without coredumper      # coredumper support
+%bcond_with    coredumper      # coredumper support
 
 # tokudb is only supported on x86_64
 %ifnarch %{x8664}
@@ -44,8 +44,8 @@
 %undefine      with_tokudb
 %endif
 
-%define                rel     1
-%define                percona_rel     39
+%define                rel     2
+%define                percona_rel     40
 Summary:       MySQL: a very fast and reliable SQL database engine
 Summary(de.UTF-8):     MySQL: ist eine SQL-Datenbank
 Summary(fr.UTF-8):     MySQL: un serveur SQL rapide et fiable
@@ -55,12 +55,12 @@ Summary(ru.UTF-8):  MySQL - быстрый SQL-сервер
 Summary(uk.UTF-8):     MySQL - швидкий SQL-сервер
 Summary(zh_CN.UTF-8):  MySQL数据库服务器
 Name:          mysql
-Version:       5.7.36
+Version:       5.7.37
 Release:       %{percona_rel}.%{rel}
 License:       GPL + MySQL FLOSS Exception
 Group:         Applications/Databases
 Source0:       https://www.percona.com/downloads/Percona-Server-5.7/LATEST/source/tarball/percona-server-%{version}-%{percona_rel}.tar.gz
-# Source0-md5: 54c63c74ee2f6aa9ec149010ccacc2dc
+# Source0-md5: ab5a63fbe6872b719c49f1bbf091c09b
 Source100:     http://www.sphinxsearch.com/files/sphinx-2.2.11-release.tar.gz
 # Source100-md5:       5cac34f3d78a9d612ca4301abfcbd666
 %if %{without system_boost}
@@ -84,11 +84,12 @@ Patch0:             mysql-opt.patch
 Patch1:                mysql-versioning.patch
 Patch2:                mysql-protobuf.patch
 Patch3:                build.patch
-Patch17:       mysql-sphinx.patch
-Patch18:       mysql-5.7-sphinx.patch
-Patch19:       mysql-chain-certs.patch
-Patch20:       mysql-dubious-exports.patch
-Patch24:       mysql-cmake.patch
+Patch4:                mysql-sphinx.patch
+Patch5:                mysql-5.7-sphinx.patch
+Patch6:                mysql-chain-certs.patch
+Patch7:                mysql-dubious-exports.patch
+Patch8:                mysql-cmake.patch
+Patch9:                openssl-3.patch
 URL:           https://www.percona.com/software/mysql-database/percona-server
 BuildRequires: bison >= 1.875
 BuildRequires: cmake >= 2.8.2
@@ -107,7 +108,7 @@ BuildRequires:      pam-devel
 %{?with_autodeps:BuildRequires:        perl-DBI}
 BuildRequires: perl-devel >= 1:5.6.1
 BuildRequires: protobuf-devel
-BuildRequires: python-modules
+BuildRequires: python3-modules
 BuildRequires: rpcsvc-proto
 BuildRequires: rpm-perlprov >= 4.1-13
 BuildRequires: rpmbuild(macros) >= 1.597
@@ -121,7 +122,7 @@ Requires(pre):      /bin/id
 Requires(pre): /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
-Requires(triggerpostun):       sed >= 4.0
+Requires(post):        sed >= 4.0
 Requires:      %{name}-charsets = %{version}-%{release}
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      /usr/bin/setsid
@@ -502,12 +503,13 @@ sed -i -e 's#perconaserverclient#mysqlclient#g' libmysql/libmysql.{ver.in,map} s
 %if %{with sphinx}
 # http://www.sphinxsearch.com/docs/manual-0.9.9.html#sphinxse-mysql51
 %{__mv} sphinx-*/mysqlse storage/sphinx
-%patch17 -p1
-%patch18 -p1
+%patch4 -p1
+%patch5 -p1
 %endif
-%patch19 -p1
-%patch20 -p1
-%patch24 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
+%patch9 -p1
 
 # to get these files rebuild
 [ -f sql/sql_yacc.cc ] && %{__rm} sql/sql_yacc.cc