]> TLD Linux GIT Repositories - packages/mysql.git/blobdiff - mysql.spec
- updated to 5.6.39-83.1
[packages/mysql.git] / mysql.spec
index db4d8a9dd4c66630d4d61a53a925e3f092f4867f..c180dca49ea0636d1476e6680f252ee6e9e18850 100644 (file)
@@ -23,8 +23,8 @@
 %bcond_with    tests           # FIXME: don't run correctly
 %bcond_with    ndb             # NDB is now a separate product, this here is broken, so disable it
 
-%define                rel     2
-%define                percona_rel     73.1
+%define                rel     1
+%define                percona_rel     83.1
 %include       /usr/lib/rpm/macros.perl
 Summary:       MySQL: a very fast and reliable SQL database engine
 Summary(de.UTF-8):     MySQL: ist eine SQL-Datenbank
@@ -35,14 +35,14 @@ Summary(ru.UTF-8):  MySQL - быстрый SQL-сервер
 Summary(uk.UTF-8):     MySQL - швидкий SQL-сервер
 Summary(zh_CN.UTF-8):  MySQL数据库服务器
 Name:          mysql
-Version:       5.6.25
+Version:       5.6.39
 Release:       %{percona_rel}.%{rel}
 License:       GPL + MySQL FLOSS Exception
 Group:         Applications/Databases
 Source0:       http://www.percona.com/downloads/Percona-Server-5.6/LATEST/source/tarball/percona-server-%{version}-%{percona_rel}.tar.gz
-# Source0-md5: 3a60a01f046139e1b2f680d2df4917a6
-Source100:     http://www.sphinxsearch.com/files/sphinx-2.2.9-release.tar.gz
-# Source100-md5:       1fcc3d180c0559bdeb93602ef248caf4
+# Source0-md5: cc16e77d1504fdadb808c500cc8b23d5
+Source100:     http://www.sphinxsearch.com/files/sphinx-2.2.11-release.tar.gz
+# Source100-md5:       5cac34f3d78a9d612ca4301abfcbd666
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 Source3:       %{name}.logrotate
@@ -60,8 +60,11 @@ Patch1:              %{name}-versioning.patch
 Patch2:                %{name}hotcopy-5.0-5.5.patch
 Patch3:                bug-67402.patch
 Patch4:                %{name}-no-default-secure-auth.patch
+Patch5:                %{name}-system-libhsclient.patch
+Patch6:                handlersocket.patch
+
 # from fedora
-Patch6:                %{name}-system-users.patch
+Patch8:                %{name}-system-users.patch
 
 Patch9:                %{name}-build.patch
 Patch11:       %{name}-upgrade.patch
@@ -73,14 +76,13 @@ Patch19:    %{name}-chain-certs.patch
 Patch20:       %{name}-dubious-exports.patch
 Patch21:       bug-66589.patch
 Patch22:       bug-44278.patch
-Patch23:       %{name}-cmake.patch
-Patch24:       %{name}-readline.patch
 URL:           http://www.mysql.com/products/community/
 BuildRequires: bison >= 1.875
 BuildRequires: cmake >= 2.6
 BuildRequires: readline-devel >= 6.2
 BuildRequires: libstdc++-devel >= 5:4.0
 BuildRequires: automake
+BuildRequires: libhsclient-devel
 %{?with_tcpd:BuildRequires:    libwrap-devel}
 BuildRequires: ncurses-devel >= 4.2
 %{?with_ssl:BuildRequires:     openssl-devel >= 0.9.7d}
@@ -500,9 +502,11 @@ mv sphinx-*/mysqlse storage/sphinx
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-
+%patch5 -p1
 %patch6 -p1
 
+%patch8 -p1
+
 %patch9 -p1
 %patch11 -p1
 %patch12 -p1
@@ -526,7 +530,7 @@ cd build
 # (it defaults to first cluster but user may change it to whatever
 # cluster it wants)
 
-%cmake \
+%cmake .. \
        -DCMAKE_BUILD_TYPE=%{!?debug:RelWithDebInfo}%{?debug:Debug} \
        -DCMAKE_C_FLAGS_RELEASE="%{rpmcflags} -DNDEBUG -fno-omit-frame-pointer -fno-strict-aliasing" \
        -DCMAKE_CXX_FLAGS_RELEASE="%{rpmcxxflags} -DNDEBUG -fno-omit-frame-pointer -fno-strict-aliasing" \
@@ -550,9 +554,10 @@ cd build
        -DWITH_PIC=ON \
        -DWITH_READLINE=system \
        -DWITH_SSL=%{?with_ssl:system}%{!?with_ssl:no} \
+       -DWITHOUT_TOKUDB=1 \
+       -DWITHOUT_TOKUDB_STORAGE_ENGINE=1 \
        -DWITH_UNIT_TESTS=%{?with_tests:ON}%{!?with_tests:OFF} \
-       -DWITH_ZLIB=system \
-       ..
+       -DWITH_ZLIB=system
 
 %{__make}
 
@@ -882,12 +887,18 @@ done
 %attr(755,root,root) %{_libdir}/%{name}/plugin/auth_pam_compat.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/auth_socket.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/auth_test_plugin.so
+%attr(755,root,root) %{_libdir}/%{name}/plugin/connection_control.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/dialog.so
+%attr(755,root,root) %{_libdir}/%{name}/plugin/handlersocket.so
+%attr(755,root,root) %{_libdir}/%{name}/plugin/libfnv1a_udf.so
+%attr(755,root,root) %{_libdir}/%{name}/plugin/libfnv_udf.so
+%attr(755,root,root) %{_libdir}/%{name}/plugin/libmurmur_udf.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/mypluglib.so
+%attr(755,root,root) %{_libdir}/%{name}/plugin/mysql_no_login.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/qa_auth_client.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/qa_auth_interface.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/qa_auth_server.so
-%attr(755,root,root) %{_libdir}/%{name}/plugin/scalability_metrics.so
+%attr(755,root,root) %{_libdir}/%{name}/plugin/query_response_time.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/semisync_master.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/semisync_slave.so
 %attr(755,root,root) %{_libdir}/%{name}/plugin/validate_password.so