]> TLD Linux GIT Repositories - packages/mysql.git/blobdiff - mysql.spec
- updated to 5.7.42-46
[packages/mysql.git] / mysql.spec
index 910bdb00f98d8cf995c6e324977419956d618671..f1b667e62fb8332d2598e79c6cd7b4dcb3aff1da 100644 (file)
@@ -31,7 +31,7 @@
 %bcond_without tcpd            # libwrap (tcp_wrappers) support
 %bcond_with    sphinx          # Sphinx storage engine support
 %bcond_with    tokudb          # TokuDB
-%bcond_without rocksdb         # RocksDB
+%bcond_with    rocksdb         # RocksDB
 # mysql needs boost 1.59.0 and doesn't support newer/older boost versions
 %bcond_with    system_boost    # Use system boost package
 %bcond_with    tests           # FIXME: don't run correctly
@@ -45,7 +45,7 @@
 %endif
 
 %define                rel     1
-%define                percona_rel     40
+%define                percona_rel     46
 Summary:       MySQL: a very fast and reliable SQL database engine
 Summary(de.UTF-8):     MySQL: ist eine SQL-Datenbank
 Summary(fr.UTF-8):     MySQL: un serveur SQL rapide et fiable
@@ -55,12 +55,12 @@ Summary(ru.UTF-8):  MySQL - быстрый SQL-сервер
 Summary(uk.UTF-8):     MySQL - швидкий SQL-сервер
 Summary(zh_CN.UTF-8):  MySQL数据库服务器
 Name:          mysql
-Version:       5.7.37
+Version:       5.7.42
 Release:       %{percona_rel}.%{rel}
 License:       GPL + MySQL FLOSS Exception
 Group:         Applications/Databases
 Source0:       https://www.percona.com/downloads/Percona-Server-5.7/LATEST/source/tarball/percona-server-%{version}-%{percona_rel}.tar.gz
-# Source0-md5: ab5a63fbe6872b719c49f1bbf091c09b
+# Source0-md5: 6f937a7fe774edad0213a75e34df19d5
 Source100:     http://www.sphinxsearch.com/files/sphinx-2.2.11-release.tar.gz
 # Source100-md5:       5cac34f3d78a9d612ca4301abfcbd666
 %if %{without system_boost}
@@ -84,11 +84,11 @@ Patch0:             mysql-opt.patch
 Patch1:                mysql-versioning.patch
 Patch2:                mysql-protobuf.patch
 Patch3:                build.patch
-Patch17:       mysql-sphinx.patch
-Patch18:       mysql-5.7-sphinx.patch
-Patch19:       mysql-chain-certs.patch
-Patch20:       mysql-dubious-exports.patch
-Patch24:       mysql-cmake.patch
+Patch4:                mysql-sphinx.patch
+Patch5:                mysql-5.7-sphinx.patch
+Patch6:                mysql-chain-certs.patch
+Patch7:                mysql-dubious-exports.patch
+Patch8:                mysql-cmake.patch
 URL:           https://www.percona.com/software/mysql-database/percona-server
 BuildRequires: bison >= 1.875
 BuildRequires: cmake >= 2.8.2
@@ -107,7 +107,7 @@ BuildRequires:      pam-devel
 %{?with_autodeps:BuildRequires:        perl-DBI}
 BuildRequires: perl-devel >= 1:5.6.1
 BuildRequires: protobuf-devel
-BuildRequires: python-modules
+BuildRequires: python3-modules
 BuildRequires: rpcsvc-proto
 BuildRequires: rpm-perlprov >= 4.1-13
 BuildRequires: rpmbuild(macros) >= 1.597
@@ -121,7 +121,7 @@ Requires(pre):      /bin/id
 Requires(pre): /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
-Requires(triggerpostun):       sed >= 4.0
+Requires(post):        sed >= 4.0
 Requires:      %{name}-charsets = %{version}-%{release}
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      /usr/bin/setsid
@@ -502,12 +502,12 @@ sed -i -e 's#perconaserverclient#mysqlclient#g' libmysql/libmysql.{ver.in,map} s
 %if %{with sphinx}
 # http://www.sphinxsearch.com/docs/manual-0.9.9.html#sphinxse-mysql51
 %{__mv} sphinx-*/mysqlse storage/sphinx
-%patch17 -p1
-%patch18 -p1
+%patch4 -p1
+%patch5 -p1
 %endif
-%patch19 -p1
-%patch20 -p1
-%patch24 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
 
 # to get these files rebuild
 [ -f sql/sql_yacc.cc ] && %{__rm} sql/sql_yacc.cc
@@ -701,7 +701,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %pre
 %groupadd -g 89 mysql
-%useradd -u 89 -d %{_mysqlhome} -s /bin/sh -g mysql -c "MySQL Server" mysql
+%useradd -u 89 -d %{_mysqlhome} -s /bin/false -g mysql -c "MySQL Server" mysql
 
 %post
 /sbin/ldconfig