]> TLD Linux GIT Repositories - packages/mysql.git/commitdiff
- updated to 5.6.25-73.1, sphinx to 2.2.9
authorMarcin Krol <hawk@tld-linux.org>
Sat, 25 Jul 2015 14:35:57 +0000 (14:35 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Sat, 25 Jul 2015 14:43:26 +0000 (14:43 +0000)
- readline build is available and default one since Percona
  5.6.24-72.2, no patching needed

mysql-cmake.patch [deleted file]
mysql-readline.patch [deleted file]
mysql-system-users.patch
mysql.spec

diff --git a/mysql-cmake.patch b/mysql-cmake.patch
deleted file mode 100644 (file)
index 7b7ae1c..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
---- Percona-Server-5.6.15-rel63.0/cmake/readline.cmake.orig    2013-12-18 10:52:13.000000000 +0100
-+++ Percona-Server-5.6.15-rel63.0/cmake/readline.cmake 2014-02-09 06:17:56.079619159 +0100
-@@ -131,23 +131,23 @@
- MACRO (FIND_SYSTEM_EDITLINE)
-   FIND_PATH(FOUND_EDITLINE_READLINE
--    NAMES editline/readline.h
-+    NAMES readline/readline.h
-   )
-   IF(FOUND_EDITLINE_READLINE)
--    SET(EDITLINE_INCLUDE_DIR "${FOUND_EDITLINE_READLINE}/editline")
-+    SET(EDITLINE_INCLUDE_DIR "${FOUND_EDITLINE_READLINE}/readline")
-   ELSE()
-     # Different path on FreeBSD
-     FIND_PATH(FOUND_EDIT_READLINE_READLINE
-       NAMES edit/readline/readline.h
-     )
-     IF(FOUND_EDIT_READLINE_READLINE)
--      SET(EDITLINE_INCLUDE_DIR "${FOUND_EDIT_READLINE_READLINE}/edit/readline")
-+      SET(EDITLINE_INCLUDE_DIR "${FOUND_EDIT_READLINE_READLINE}/readline")
-     ENDIF()
-   ENDIF()
-   FIND_LIBRARY(EDITLINE_LIBRARY
-     NAMES
--    edit
-+    readline
-   )
-   MARK_AS_ADVANCED(EDITLINE_INCLUDE_DIR EDITLINE_LIBRARY)
-@@ -160,7 +160,7 @@
-     SET(CMAKE_REQUIRED_LIBRARIES ${EDITLINE_LIBRARY})
-     CHECK_CXX_SOURCE_COMPILES("
-     #include <stdio.h>
--    #include <readline.h>
-+    #include <readline/history.h>
-     int main(int argc, char **argv)
-     {
-        HIST_ENTRY entry;
-@@ -170,14 +170,13 @@
-     CHECK_CXX_SOURCE_COMPILES("
-     #include <stdio.h>
--    #include <readline.h>
-+    #include <readline/readline.h>
-     int main(int argc, char **argv)
-     {
--      typedef int MYFunction(const char*, int);
--      MYFunction* myf= rl_completion_entry_function;
--      int res= (myf)(NULL, 0);
--      completion_matches(0,0);
--      return res;
-+      rl_compentry_func_t *myf= rl_completion_entry_function;
-+      char *res= (myf)(NULL, 0);
-+      rl_completion_matches(0,0);
-+      return res ? 0 : 1;
-     }"
-     EDITLINE_HAVE_COMPLETION)
diff --git a/mysql-readline.patch b/mysql-readline.patch
deleted file mode 100644 (file)
index ed12c3a..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
---- Percona-Server-5.6.15-rel63.0/client/mysql.cc.orig 2014-02-09 06:23:16.085128298 +0100
-+++ Percona-Server-5.6.15-rel63.0/client/mysql.cc      2014-02-09 06:38:54.561791068 +0100
-@@ -103,7 +103,9 @@
- #include <conio.h>
- #else
- #include <readline.h>
-+#include <history.h>
- #define HAVE_READLINE
-+#define USE_NEW_READLINE_INTERFACE
- #define USE_POPEN
- #endif
-   //int vidattr(long unsigned int attrs);     // Was missing in sun curses
-@@ -1107,7 +1109,7 @@
- } HIST_ENTRY; 
- #endif
--extern "C" int add_history(const char *command); /* From readline directory */
-+extern "C" void add_history(const char *command); /* From readline directory */
- extern "C" int read_history(const char *command);
- extern "C" int write_history(const char *command);
- extern "C" HIST_ENTRY *history_get(int num);
index d33b5e844592dda0915a4643d24f4499407445ff..560597a902b0f9c4c663cf5df0044ecf4f7b3851 100644 (file)
@@ -1,34 +1,30 @@
---- mysql-5.5.8/scripts/mysql_system_tables_data.sql.org       2010-12-16 00:09:23.662631925 +0100
-+++ mysql-5.5.8/scripts/mysql_system_tables_data.sql   2010-12-16 00:10:17.763454969 +0100
-@@ -27,23 +27,17 @@
- SET @get_hostname= @@hostname;
- SELECT REPLACE((SELECT REPLACE(@get_hostname,'_','\_')),'%','\%') INTO @current_hostname;
--
---- Fill "db" table with default grants for anyone to
---- access database 'test' and 'test_%' if "db" table didn't exist
--CREATE TEMPORARY TABLE tmp_db LIKE db;
--INSERT INTO tmp_db VALUES ('%','test','','Y','Y','Y','Y','Y','Y','N','Y','Y','Y','Y','Y','Y','Y','Y','N','N','Y','Y');
--INSERT INTO tmp_db VALUES ('%','test\_%','','Y','Y','Y','Y','Y','Y','N','Y','Y','Y','Y','Y','Y','Y','Y','N','N','Y','Y');
--INSERT INTO db SELECT * FROM tmp_db WHERE @had_db_table=0;
--DROP TABLE tmp_db;
--
--
+--- percona-server-5.6.25-73.1/scripts/mysql_system_tables_data.sql    2015-07-24 16:36:44.949657351 +0000
++++ percona-server-5.6.25-73.1/scripts/mysql_system_tables_data.sql    2015-07-24 17:28:29.695854307 +0000
+@@ -39,17 +39,21 @@
  -- Fill "user" table with default users allowing root access
  -- from local machine if "user" table didn't exist before
  CREATE TEMPORARY TABLE tmp_user LIKE user;
--INSERT INTO tmp_user VALUES ('localhost','root','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','','N');
--REPLACE INTO tmp_user SELECT @current_hostname,'root','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','','N' FROM dual WHERE @current_hostname != 'localhost';
--REPLACE INTO tmp_user VALUES ('127.0.0.1','root','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','','N');
--REPLACE INTO tmp_user VALUES ('::1','root','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','','N');
-+INSERT INTO tmp_user VALUES ('localhost','mysql','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','','N');
-+REPLACE INTO tmp_user SELECT @current_hostname,'mysql','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','','N' FROM dual WHERE @current_hostname != 'localhost';
-+REPLACE INTO tmp_user VALUES ('127.0.0.1','mysql','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','','N');
-+REPLACE INTO tmp_user VALUES ('::1','mysql','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'','','N');
-+INSERT INTO tmp_user VALUES ('localhost','mysql_sysadmin','','N','N','N','N','N','N','Y','Y','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','','','','',0,0,0,0,'','','N');
-+REPLACE INTO tmp_user SELECT @current_hostname,'mysql_sysadmin','','N','N','N','N','N','N','Y','Y','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','','','','',0,0,0,0,'','','N' FROM dual WHERE @current_hostname != 'localhost';
-+REPLACE INTO tmp_user VALUES ('127.0.0.1','mysql_sysadmin','','N','N','N','N','N','N','Y','Y','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','','','','',0,0,0,0,'','','N');
-+REPLACE INTO tmp_user VALUES ('::1','mysql_sysadmin','','N','N','N','N','N','N','Y','Y','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','N','','','','',0,0,0,0,'','','N');
+-INSERT INTO tmp_user VALUES ('localhost','root','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'mysql_native_password','','N');
+-REPLACE INTO tmp_user SELECT @current_hostname,'root','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'mysql_native_password','','N' FROM dual WHERE @current_hostname != 'localhost';
+-REPLACE INTO tmp_user VALUES ('127.0.0.1','root','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'mysql_native_password','','N');
+-REPLACE INTO tmp_user VALUES ('::1','root','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'mysql_native_password','','N');
++INSERT INTO tmp_user VALUES ('localhost','mysql','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'mysql_native_password','','N');
++REPLACE INTO tmp_user SELECT @current_hostname,'mysql','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'mysql_native_password','','N' FROM dual WHERE @current_hostname != 'localhost';
++REPLACE INTO tmp_user VALUES ('127.0.0.1','mysql','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'mysql_native_password','','N');
++REPLACE INTO tmp_user VALUES ('::1','mysql','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'mysql_native_password','','N');
++INSERT INTO tmp_user VALUES ('localhost','mysql_sysadmin','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'mysql_native_password','','N');
++REPLACE INTO tmp_user SELECT @current_hostname,'mysql_sysadmin','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'mysql_native_password','','N' FROM dual WHERE @current_hostname != 'localhost';
++REPLACE INTO tmp_user VALUES ('127.0.0.1','mysql_sysadmin','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'mysql_native_password','','N');
++REPLACE INTO tmp_user VALUES ('::1','mysql_sysadmin','','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','','','','',0,0,0,0,'mysql_native_password','','N');
  INSERT INTO tmp_user (host,user) VALUES ('localhost','');
  INSERT INTO tmp_user (host,user) SELECT @current_hostname,'' FROM dual WHERE @current_hostname != 'localhost';
  INSERT INTO user SELECT * FROM tmp_user WHERE @had_user_table=0;
+ DROP TABLE tmp_user;
+ CREATE TEMPORARY TABLE tmp_proxies_priv LIKE proxies_priv;
+-INSERT INTO tmp_proxies_priv VALUES ('localhost', 'root', '', '', TRUE, '', now());
+-REPLACE INTO tmp_proxies_priv SELECT @current_hostname, 'root', '', '', TRUE, '', now() FROM DUAL WHERE LOWER (@current_hostname) != 'localhost';
++INSERT INTO tmp_proxies_priv VALUES ('localhost', 'mysql', '', '', TRUE, '', now());
++REPLACE INTO tmp_proxies_priv SELECT @current_hostname, 'mysql', '', '', TRUE, '', now() FROM DUAL WHERE LOWER (@current_hostname) != 'localhost';
+ INSERT INTO  proxies_priv SELECT * FROM tmp_proxies_priv WHERE @had_proxies_priv_table=0;
+ DROP TABLE tmp_proxies_priv;
index 66f09aaf83ec5eb70dbaadb0423b98458ddc6044..db4d8a9dd4c66630d4d61a53a925e3f092f4867f 100644 (file)
@@ -23,8 +23,8 @@
 %bcond_with    tests           # FIXME: don't run correctly
 %bcond_with    ndb             # NDB is now a separate product, this here is broken, so disable it
 
-%define                rel     1
-%define                percona_rel     71.0
+%define                rel     2
+%define                percona_rel     73.1
 %include       /usr/lib/rpm/macros.perl
 Summary:       MySQL: a very fast and reliable SQL database engine
 Summary(de.UTF-8):     MySQL: ist eine SQL-Datenbank
@@ -35,16 +35,14 @@ Summary(ru.UTF-8):  MySQL - быстрый SQL-сервер
 Summary(uk.UTF-8):     MySQL - швидкий SQL-сервер
 Summary(zh_CN.UTF-8):  MySQL数据库服务器
 Name:          mysql
-Version:       5.6.22
+Version:       5.6.25
 Release:       %{percona_rel}.%{rel}
 License:       GPL + MySQL FLOSS Exception
 Group:         Applications/Databases
-# Source0Download: http://dev.mysql.com/downloads/mysql/5.5.html#downloads
-# Source0:     http://vesta.informatik.rwth-aachen.de/mysql/Downloads/MySQL-5.5/%{name}-%{version}.tar.gz
 Source0:       http://www.percona.com/downloads/Percona-Server-5.6/LATEST/source/tarball/percona-server-%{version}-%{percona_rel}.tar.gz
-# Source0-md5: 374a67fa9c2f4e76f4194076c3379c98
-Source100:     http://www.sphinxsearch.com/files/sphinx-2.2.7-release.tar.gz
-# Source100-md5:       ac74f013665f473d7ea22623f4b72468
+# Source0-md5: 3a60a01f046139e1b2f680d2df4917a6
+Source100:     http://www.sphinxsearch.com/files/sphinx-2.2.9-release.tar.gz
+# Source100-md5:       1fcc3d180c0559bdeb93602ef248caf4
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 Source3:       %{name}.logrotate
@@ -513,8 +511,6 @@ mv sphinx-*/mysqlse storage/sphinx
 %patch20 -p1
 %patch21 -p1
 %patch22 -p1
-%patch23 -p1
-%patch24 -p1
 
 # to get these files rebuild
 [ -f sql/sql_yacc.cc ] && rm sql/sql_yacc.cc
@@ -552,7 +548,7 @@ cd build
        -DWITH_PAM=ON \
        -DWITH_PERFSCHEMA_STORAGE_ENGINE=1 \
        -DWITH_PIC=ON \
-       -DWITH_EDITLINE=system \
+       -DWITH_READLINE=system \
        -DWITH_SSL=%{?with_ssl:system}%{!?with_ssl:no} \
        -DWITH_UNIT_TESTS=%{?with_tests:ON}%{!?with_tests:OFF} \
        -DWITH_ZLIB=system \