]> TLD Linux GIT Repositories - packages/php-dirs.git/blobdiff - php-dirs.spec
- merged 1.10 from PLD
[packages/php-dirs.git] / php-dirs.spec
index ce8883181d496030aa097b2b8f07a74c05ae60e9..f5730f181e89541bbf5ec7b5d25818dbe6f7e1fc 100644 (file)
@@ -1,11 +1,11 @@
 # TODO
-# - move tmpwatch S: to php-session package (as session files file storage no
+# - move tmpwatch R: to php-session package (as session files file storage no
 #   longer can cleanup itself due dir perms)
 # - https://fedorahosted.org/tmpwatch/ticket/7 is implemented in tmpwatch-2.9.16, see 3467603 todo
 Summary:       Common dirs for PHP
 Summary(pl.UTF-8):     Wspólne katalogi dla PHP
 Name:          php-dirs
-Version:       1.7
+Version:       1.10
 Release:       1
 License:       GPL
 Group:         Base
@@ -15,7 +15,7 @@ BuildRequires:        rpmbuild(macros) >= 1.644
 Requires(postun):      /usr/sbin/groupdel
 Requires(pre): /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
-Suggests:      tmpwatch
+Requires:      tmpwatch
 Conflicts:     php-pear < 4:1.4-2
 Provides:      group(http)
 BuildArch:     noarch
@@ -38,7 +38,15 @@ install -d $RPM_BUILD_ROOT{/etc/cron.d,/var/{cache,log,run}/php,/var/log/archive
        $RPM_BUILD_ROOT%{_libexecdir} $RPM_BUILD_ROOT%{php_data_dir}
 
 install -p %{SOURCE0} $RPM_BUILD_ROOT%{_libexecdir}
-cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/php-session
+sed -e 's,@libexecdir@,%{_libexecdir},' %{SOURCE1} >$RPM_BUILD_ROOT/etc/cron.d/php-session
+
+while read dir; do
+       install -d $RPM_BUILD_ROOT$dir
+done <<EOF
+%{php_data_dir}/tests
+%{php_data_dir}/Symfony/Bridge
+%{php_data_dir}/Symfony/Component
+EOF
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -55,6 +63,7 @@ fi
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/php-session
 %attr(755,root,root) %{_libexecdir}/php-session.sh
+
 %dir %{_docdir}/phpdoc
 %dir %{_includedir}/php
 %dir %{php_data_dir}