]> TLD Linux GIT Repositories - packages/php-dirs.git/commitdiff
- merged 1.7 from PLD
authorMarcin Krol <hawk@tld-linux.org>
Mon, 13 Nov 2017 12:46:33 +0000 (12:46 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Mon, 13 Nov 2017 12:46:33 +0000 (12:46 +0000)
crontab [new file with mode: 0644]
php-dirs.spec

diff --git a/crontab b/crontab
new file mode 100644 (file)
index 0000000..c5d1969
--- /dev/null
+++ b/crontab
@@ -0,0 +1,3 @@
+MAILTO=root
+
+01 * * * * root /usr/lib/php-session.sh
index c054ef644eca13e2a8558593bd3a1ac742dc517d..149ce494c9a1fb90f52ca33ccae2c7dcb14b03f8 100644 (file)
@@ -1,37 +1,52 @@
 # TODO
 # - move tmpwatch S: to php-session package (as session files file storage no
 #   longer can cleanup itself due dir perms)
-Summary:       Common dirs for different PHP versions
-Summary(pl.UTF-8):     Wspólne katalogi dla różnych wersji PHP
+# - https://fedorahosted.org/tmpwatch/ticket/7 is implemented in tmpwatch-2.9.16, see 3467603 todo
+Summary:       Common dirs for PHP
+Summary(pl.UTF-8):     Wspólne katalogi dla PHP
 Name:          php-dirs
-Version:       1.5
-Release:       2
+Version:       1.7
+Release:       1
 License:       GPL
 Group:         Base
 Source0:       php-session.sh
+Source1:       crontab
 BuildRequires: rpmbuild(macros) >= 1.644
 Requires(postun):      /usr/sbin/groupdel
 Requires(pre): /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
 Suggests:      tmpwatch
+Conflicts:     php-pear < 4:1.4-2
 Provides:      group(http)
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _libexecdir     %{_prefix}/lib
+
 %description
-Common directories for PHP version 4 and version 5.
+Common directories for PHP.
 
 %description -l pl.UTF-8
-Wspólne katalogi dla PHP w wersji 4 oraz 5.
+Wspólne katalogi dla PHP.
 
 %prep
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{php_data_dir}/tests,/etc/cron.hourly,/var/{cache,log,run}/php,/var/log/archive/php} \
-       $RPM_BUILD_ROOT%{_docdir}/phpdoc
+install -d $RPM_BUILD_ROOT{/etc/cron.d,/var/{cache,log,run}/php,/var/log/archive/php} \
+       $RPM_BUILD_ROOT%{_docdir}/phpdoc \
+       $RPM_BUILD_ROOT%{_libexecdir}
+
+install -p %{SOURCE0} $RPM_BUILD_ROOT%{_libexecdir}
+cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.d/php-session
 
-install -p %{SOURCE0} $RPM_BUILD_ROOT/etc/cron.hourly
+while read dir; do
+       install -d $RPM_BUILD_ROOT$dir
+done <<EOF
+%{php_data_dir}/tests
+%{php_data_dir}/Symfony/Bridge
+%{php_data_dir}/Symfony/Component
+EOF
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -46,15 +61,18 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_sysconfdir}/cron.hourly/php-session.sh
-%dir %{php_data_dir}
-%dir %{php_data_dir}/tests
+%config(noreplace) %verify(not md5 mtime size) /etc/cron.d/php-session
+%attr(755,root,root) %{_libexecdir}/php-session.sh
+%{php_data_dir}
+
 %dir %{_docdir}/phpdoc
 %attr(775,root,http) %dir %verify(not group mode) /var/log/php
 %attr(770,root,root) %dir %verify(not group mode) /var/log/archive/php
+
 # no +r, so only predictable names can be used. currently php-soap wsdl cache is there
 %attr(730,root,http) %dir %verify(not group mode) /var/cache/php
-# http needs only x for directory (otherwise it knows session file
-# names and can read it contents)
+
+# http needs only +x for directory
+# (otherwise it knows session file names and can read it contents)
 # keep o+x for fcgi.sock (lighttpd)
 %attr(731,root,http) %dir %verify(not group mode) /var/run/php