]> TLD Linux GIT Repositories - packages/php.git/blobdiff - fix-test-run.patch
- updated to 5.4.45
[packages/php.git] / fix-test-run.patch
index aa13506a39cd6f3e8cf92ee9a6c7673cd454518b..33d072c0d32bbb74b3d543f3d0127aada7cdd39b 100644 (file)
@@ -1,37 +1,43 @@
---- php-5.3.2/configure.in~    2010-03-16 12:16:56.000000000 +0200
-+++ php-5.3.2/configure.in     2010-03-16 16:13:24.926435546 +0200
-@@ -1224,6 +1224,11 @@
- PHP_SUBST(PHP_CLI_OBJS)
- PHP_SUBST(PHP_GLOBAL_OBJS)
+--- php-5.4.0alpha2/configure.in~      2011-08-07 12:43:31.000000000 +0300
++++ php-5.4.0alpha2/configure.in       2011-08-07 12:44:11.495394662 +0300
+@@ -1271,6 +1271,11 @@
+   ;;
+ esac
  
 +# shift so that pcre, spl, ... are loaded first
 +PHP_MODULES=$(echo "$PHP_MODULES" | sed -e 's,\(.*\)\(\$(phplibdir)/xml.la \),\2\1,')
 +PHP_MODULES=$(echo "$PHP_MODULES" | sed -e 's,\(.*\)\(\$(phplibdir)/spl.la \),\2\1,')
 +PHP_MODULES=$(echo "$PHP_MODULES" | sed -e 's,\(.*\)\(\$(phplibdir)/pcre.la \),\2\1,')
 +
- PHP_SUBST(PHP_MODULES)
- PHP_SUBST(PHP_ZEND_EX)
+ PHP_SUBST_OLD(PHP_INSTALLED_SAPIS)
  
---- php-5.3.8/Makefile.global~ 2011-10-14 08:58:00.288329595 +0300
-+++ php-5.3.8/Makefile.global  2011-10-14 08:50:16.670234576 +0300
-@@ -77,8 +77,15 @@
+ PHP_SUBST(PHP_EXECUTABLE)
+--- php-5.3.4/Makefile.global~ 2010-12-12 23:08:32.000000000 +0200
++++ php-5.3.4/Makefile.global  2010-12-12 23:09:31.246644108 +0200
+@@ -77,7 +77,8 @@
                done; \
        fi
  
 -PHP_TEST_SETTINGS = -d 'open_basedir=' -d 'output_buffering=0' -d 'memory_limit=-1'
 +PHP_TEST_SETTINGS = -d 'open_basedir=' -d 'output_buffering=0' -d 'memory_limit=-1' -d 'safe_mode=0'
-+PHP_TEST_SHARED_SYSTEM_EXTENSIONS =
++PHP_TEST_SHARED_SYSTEM_EXTENSIONS = pcre
  PHP_TEST_SHARED_EXTENSIONS =  ` \
+       if test "x$(PHP_MODULES)" != "x"; then \
+               for i in $(PHP_MODULES)""; do \
+@@ -88,6 +89,12 @@
+               for i in $(PHP_ZEND_EX)""; do \
+                       . $$i; $(top_srcdir)/build/shtool echo -n -- " -d $(ZEND_EXT_TYPE)=$(top_builddir)/modules/$$dlname"; \
+               done; \
++      fi; \
 +      if test "x$(PHP_TEST_SHARED_SYSTEM_EXTENSIONS)" != "x"; then \
 +              for i in $(PHP_TEST_SHARED_SYSTEM_EXTENSIONS)""; do \
 +                      dlname=$$i.$(SHLIB_DL_SUFFIX_NAME); \
 +                      $(top_srcdir)/build/shtool echo -n -- " -d extension=$(EXTENSION_DIR)/$$dlname"; \
 +              done; \
-+      fi; \
-       if test "x$(PHP_MODULES)" != "x"; then \
-               for i in $(PHP_MODULES)""; do \
-                       . $$i; $(top_srcdir)/build/shtool echo -n -- " -d extension=$$dlname"; \
-@@ -107,7 +114,10 @@
+       fi`
+ PHP_DEPRECATED_DIRECTIVES_REGEX = '^(define_syslog_variables|register_(globals|long_arrays)?|safe_mode|magic_quotes_(gpc|runtime|sybase)?|(zend_)?extension(_debug)?(_ts)?)[\t\ ]*='
+@@ -114,7 +114,10 @@
                TEST_PHP_EXECUTABLE=$(PHP_EXECUTABLE) \
                TEST_PHP_SRCDIR=$(top_srcdir) \
                CC="$(CC)" \
                rm $(top_builddir)/tmp-php.ini; \
        else \
                echo "ERROR: Cannot run tests without CLI sapi."; \
+--- php-5.3.2/Makefile.global  2010-03-16 16:31:36.972576955 +0200
++++ php-5.3.2/Makefile.global  2010-03-16 16:31:36.972576955 +0200
+@@ -296,7 +296,7 @@
+       fi
+ PHP_TEST_SETTINGS = -d 'open_basedir=' -d 'output_buffering=0' -d 'memory_limit=-1' -d 'safe_mode=0'
+-PHP_TEST_SHARED_SYSTEM_EXTENSIONS = pcre
++PHP_TEST_SHARED_SYSTEM_EXTENSIONS =
+ PHP_TEST_SHARED_EXTENSIONS =  ` \
+       if test "x$(PHP_MODULES)" != "x"; then \
+               for i in $(PHP_MODULES)""; do \