]> TLD Linux GIT Repositories - packages/php.git/blobdiff - fix-test-run.patch
- Up to 8.3.7
[packages/php.git] / fix-test-run.patch
index 01742c44c830c5f49304b852f40087aeb68ee22e..7601cc1d321311654a16bd348a426987c7a59e4d 100644 (file)
@@ -1,18 +1,18 @@
 --- php-5.4.0alpha2/configure.ac~      2011-08-07 12:43:31.000000000 +0300
 +++ php-5.4.0alpha2/configure.ac       2011-08-07 12:44:11.495394662 +0300
 @@ -1271,6 +1271,9 @@
-   ;;
- esac
+   AC_DEFINE_UNQUOTED(PHP_BUILD_ARCH,"$PHP_BUILD_ARCH",[build architecture])
+ fi
  
 +# shift so that extensions like xml are loaded first
 +PHP_MODULES=$(echo "$PHP_MODULES" | sed -e 's,\(.*\)\(\$(phplibdir)/xml.la \),\2\1,')
 +
  PHP_SUBST_OLD(PHP_INSTALLED_SAPIS)
  
- PHP_SUBST(PHP_EXECUTABLE)
---- php-5.5.11/build/Makefile.global   2014-04-27 15:05:38.963814051 +0300
-+++ php-5.5.11/build/Makefile.global   2014-04-27 15:09:54.438443707 +0300
-@@ -81,8 +81,15 @@
+ PHP_SUBST(PHP_FASTCGI_OBJS)
+--- php-8.1.10/build/Makefile.global.orig      2022-09-25 19:52:15.520810107 +0200
++++ php-8.1.10/build/Makefile.global   2022-09-25 19:54:52.676625388 +0200
+@@ -81,8 +81,15 @@ install-headers:
                done; \
        fi
  
@@ -28,8 +28,8 @@
 +      fi; \
        if test "x$(PHP_MODULES)" != "x"; then \
                for i in $(PHP_MODULES)""; do \
-                       . $$i; $(top_srcdir)/build/shtool echo -n -- " -d extension=$$dlname"; \
-@@ -111,7 +118,9 @@
+                       . $$i; \
+@@ -114,7 +121,9 @@ test: all
                TEST_PHP_EXECUTABLE=$(PHP_EXECUTABLE) \
                TEST_PHP_SRCDIR=$(top_srcdir) \
                CC="$(CC)" \