]> TLD Linux GIT Repositories - packages/php.git/blobdiff - fix-test-run.patch
- updated to 7.2.1, partial PLD merge
[packages/php.git] / fix-test-run.patch
index aa13506a39cd6f3e8cf92ee9a6c7673cd454518b..bd3c3d7df0a98473f9eede0135cb1a9744eb7830 100644 (file)
@@ -1,20 +1,20 @@
---- php-5.3.2/configure.in~    2010-03-16 12:16:56.000000000 +0200
-+++ php-5.3.2/configure.in     2010-03-16 16:13:24.926435546 +0200
-@@ -1224,6 +1224,11 @@
- PHP_SUBST(PHP_CLI_OBJS)
- PHP_SUBST(PHP_GLOBAL_OBJS)
+--- php-5.4.0alpha2/configure.ac~      2011-08-07 12:43:31.000000000 +0300
++++ php-5.4.0alpha2/configure.ac       2011-08-07 12:44:11.495394662 +0300
+@@ -1271,6 +1271,11 @@
+   ;;
+ esac
  
 +# shift so that pcre, spl, ... are loaded first
 +PHP_MODULES=$(echo "$PHP_MODULES" | sed -e 's,\(.*\)\(\$(phplibdir)/xml.la \),\2\1,')
 +PHP_MODULES=$(echo "$PHP_MODULES" | sed -e 's,\(.*\)\(\$(phplibdir)/spl.la \),\2\1,')
 +PHP_MODULES=$(echo "$PHP_MODULES" | sed -e 's,\(.*\)\(\$(phplibdir)/pcre.la \),\2\1,')
 +
- PHP_SUBST(PHP_MODULES)
- PHP_SUBST(PHP_ZEND_EX)
+ PHP_SUBST_OLD(PHP_INSTALLED_SAPIS)
  
---- php-5.3.8/Makefile.global~ 2011-10-14 08:58:00.288329595 +0300
-+++ php-5.3.8/Makefile.global  2011-10-14 08:50:16.670234576 +0300
-@@ -77,8 +77,15 @@
+ PHP_SUBST(PHP_EXECUTABLE)
+--- php-5.5.11/Makefile.global 2014-04-27 15:05:38.963814051 +0300
++++ php-5.5.11/Makefile.global 2014-04-27 15:09:54.438443707 +0300
+@@ -81,8 +81,15 @@
                done; \
        fi
  
@@ -31,7 +31,7 @@
        if test "x$(PHP_MODULES)" != "x"; then \
                for i in $(PHP_MODULES)""; do \
                        . $$i; $(top_srcdir)/build/shtool echo -n -- " -d extension=$$dlname"; \
-@@ -107,7 +114,10 @@
+@@ -111,7 +118,10 @@
                TEST_PHP_EXECUTABLE=$(PHP_EXECUTABLE) \
                TEST_PHP_SRCDIR=$(top_srcdir) \
                CC="$(CC)" \
@@ -40,6 +40,6 @@
 +                      -d extension_dir=$(top_builddir)/modules/ -d 'extension=$(EXTENSION_DIR)/pcre.$(SHLIB_DL_SUFFIX_NAME)' \
 +                      $(PHP_TEST_SETTINGS) $(top_srcdir)/run-tests.php -n -c $(top_builddir)/tmp-php.ini \
 +                      -d extension_dir=$(top_builddir)/modules/ $(PHP_TEST_SHARED_EXTENSIONS) $(RUN_TESTS_SETTINGS) $(TESTS); \
+               TEST_RESULT_EXIT_CODE=$$?; \
                rm $(top_builddir)/tmp-php.ini; \
-       else \
-               echo "ERROR: Cannot run tests without CLI sapi."; \
+               exit $$TEST_RESULT_EXIT_CODE; \