]> TLD Linux GIT Repositories - packages/php.git/blobdiff - fpm-conf-split.patch
- updated to 5.6.40
[packages/php.git] / fpm-conf-split.patch
index 2466c518b59e0b48cdc60f333017b27b07679780..083fbf05e6698f23a9f0310b76b7b933a1e56a40 100644 (file)
@@ -1,5 +1,6 @@
---- php-5.6.4/sapi/fpm/php-fpm.conf.in~        2015-01-01 17:18:30.000000000 +0200
-+++ php-5.6.4/sapi/fpm/php-fpm.conf.in 2015-01-01 17:20:31.203799290 +0200
+diff -urNpa php-5.6.35.orig/sapi/fpm/php-fpm.conf.in php-5.6.35/sapi/fpm/php-fpm.conf.in
+--- php-5.6.35.orig/sapi/fpm/php-fpm.conf.in   2018-03-28 21:28:58.000000000 +0000
++++ php-5.6.35/sapi/fpm/php-fpm.conf.in        2018-04-12 10:03:34.184687949 +0000
 @@ -6,14 +6,6 @@
  ; prefix (@prefix@). This prefix can be dynamically changed by using the
  ; '-p' argument from the command line.
@@ -15,7 +16,7 @@
  ;;;;;;;;;;;;;;;;;;
  ; Global Options ;
  ;;;;;;;;;;;;;;;;;;
-@@ -123,415 +115,3 @@
+@@ -123,421 +115,3 @@
  ; ports and different management options.  The name of the pool will be
  ; used in logs and stats. There is no limitation on the number of pools which
  ; FPM can handle. Your system will tell you anyway :)
 -; Default Value: no set
 -; process.priority = -19
 -
+-; Set the process dumpable flag (PR_SET_DUMPABLE prctl) even if the process user
+-; or group is differrent than the master process user. It allows to create process
+-; core dump and ptrace the process for the pool user.
+-; Default Value: no
+-; process.dumpable = yes
+-
 -; Choose how the process manager will control the number of child processes.
 -; Possible Values:
 -;   static  - a fixed number (pm.max_children) of child processes;
 -;php_admin_value[error_log] = /var/log/fpm-php.www.log
 -;php_admin_flag[log_errors] = on
 -;php_admin_value[memory_limit] = 32M
---- /dev/null  2007-02-13 18:29:53.000000000 +0200
-+++ php-5.6.4/sapi/fpm/php-fpm.conf-d.in       2015-01-01 17:19:55.621958470 +0200
-@@ -0,0 +1,406 @@
+diff -urNpa php-5.6.35.orig/sapi/fpm/php-fpm.conf-d.in php-5.6.35/sapi/fpm/php-fpm.conf-d.in
+--- php-5.6.35.orig/sapi/fpm/php-fpm.conf-d.in 1970-01-01 00:00:00.000000000 +0000
++++ php-5.6.35/sapi/fpm/php-fpm.conf-d.in      2018-04-12 10:04:12.417687518 +0000
+@@ -0,0 +1,417 @@
 +; Start a new pool named 'www'.
 +; the variable $pool can we used in any directive and will be replaced by the
 +; pool name ('www' here)
 +;listen.owner = @php_fpm_user@
 +;listen.group = @php_fpm_group@
 +;listen.mode = 0660
++; When POSIX Access Control Lists are supported you can set them using
++; these options, value is a comma separated list of user/group names.
++; When set, listen.owner and listen.group are ignored
++;listen.acl_users =
++;listen.acl_groups =
 + 
 +; List of addresses (IPv4/IPv6) of FastCGI clients which are allowed to connect.
 +; Equivalent to the FCGI_WEB_SERVER_ADDRS environment variable in the original
 +; Default Value: no set
 +; process.priority = -19
 +
++; Set the process dumpable flag (PR_SET_DUMPABLE prctl) even if the process user
++; or group is differrent than the master process user. It allows to create process
++; core dump and ptrace the process for the pool user.
++; Default Value: no
++; process.dumpable = yes
++
 +; Choose how the process manager will control the number of child processes.
 +; Possible Values:
 +;   static  - a fixed number (pm.max_children) of child processes;
 +;php_admin_value[error_log] = /var/log/fpm-php.www.log
 +;php_admin_flag[log_errors] = on
 +;php_admin_value[memory_limit] = 32M
---- php-5.5.7/sapi/fpm/config.m4~      2013-12-16 17:57:03.000000000 +0200
-+++ php-5.5.7/sapi/fpm/config.m4       2013-12-16 18:00:34.936527309 +0200
-@@ -609,7 +609,7 @@
+diff -urNpa php-5.6.35.orig/sapi/fpm/config.m4 php-5.6.35/sapi/fpm/config.m4
+--- php-5.6.35.orig/sapi/fpm/config.m4 2018-03-28 21:28:58.000000000 +0000
++++ php-5.6.35/sapi/fpm/config.m4      2018-04-12 10:02:48.432688464 +0000
+@@ -667,7 +667,7 @@ if test "$PHP_FPM" != "no"; then
  
    PHP_ADD_BUILD_DIR(sapi/fpm/fpm)
    PHP_ADD_BUILD_DIR(sapi/fpm/fpm/events)
    PHP_ADD_MAKEFILE_FRAGMENT([$abs_srcdir/sapi/fpm/Makefile.frag])
  
    SAPI_FPM_PATH=sapi/fpm/php-fpm
---- php-5.6.2/sapi/fpm/Makefile.frag~  2014-10-15 15:59:32.000000000 +0300
-+++ php-5.6.2/sapi/fpm/Makefile.frag   2014-10-27 08:12:57.402883790 +0200
-@@ -11,8 +11,9 @@
+diff -urNpa php-5.6.35.orig/sapi/fpm/Makefile.frag php-5.6.35/sapi/fpm/Makefile.frag
+--- php-5.6.35.orig/sapi/fpm/Makefile.frag     2018-03-28 21:28:58.000000000 +0000
++++ php-5.6.35/sapi/fpm/Makefile.frag  2018-04-12 10:02:48.432688464 +0000
+@@ -11,8 +11,9 @@ install-fpm: $(SAPI_FPM_PATH)
        @$(INSTALL) -m 0755 $(SAPI_FPM_PATH) $(INSTALL_ROOT)$(sbindir)/$(program_prefix)php-fpm$(program_suffix)$(EXEEXT)
  
        @echo "Installing PHP FPM config:        $(INSTALL_ROOT)$(sysconfdir)/" && \