]> TLD Linux GIT Repositories - packages/php.git/blobdiff - php-fpm-config.patch
- Up to 8.1.5
[packages/php.git] / php-fpm-config.patch
index 19aa0a50b5defb4818101ef903307fba5ed45d2f..11b9933f6a1c64a7c0badea7904723838f35c91f 100644 (file)
@@ -1,20 +1,6 @@
---- php-5.3.17/sapi/fpm/php-fpm.conf.in        2012-10-12 12:35:47.601602945 +0300
-+++ php-5.3.18/sapi/fpm/php-fpm.conf.in        2012-11-28 15:31:00.486871136 +0200
-@@ -1,3 +1,4 @@
-+; vim:ft=dosini
- ;;;;;;;;;;;;;;;;;;;;;
- ; FPM Configuration ;
- ;;;;;;;;;;;;;;;;;;;;;
-@@ -12,7 +13,7 @@
- ; Relative path can also be used. They will be prefixed by:
- ;  - the global prefix if it's been set (-p arguement)
- ;  - @prefix@ otherwise
--;include=etc/fpm.d/*.conf
-+;include=/etc/php/fpm.d/*.conf
- ;;;;;;;;;;;;;;;;;;
- ; Global Options ;
-@@ -22,14 +23,14 @@
+--- php-7.1.0beta3/sapi/fpm/php-fpm.conf.in~   2016-08-19 09:48:00.000000000 +0300
++++ php-7.1.0beta3/sapi/fpm/php-fpm.conf.in    2016-08-31 13:59:19.139523160 +0300
+@@ -14,14 +14,14 @@
  ; Pid file
  ; Note: the default prefix is @EXPANDED_LOCALSTATEDIR@
  ; Default Value: none
@@ -23,7 +9,7 @@
  
  ; Error log file
  ; If it's set to "syslog", log is sent to syslogd instead of being written
- ; in a local file.
+ ; into a local file.
  ; Note: the default prefix is @EXPANDED_LOCALSTATEDIR@
  ; Default Value: log/php-fpm.log
 -;error_log = log/php-fpm.log
  
  ; syslog_facility is used to specify what type of program is logging the
  ; message. This lets syslogd specify that messages from different facilities
-@@ -148,7 +149,7 @@
- ;                            specific port;
+--- php-5.6.5/sapi/fpm/www.conf.in~    2015-02-04 19:26:16.000000000 +0200
++++ php-5.6.5/sapi/fpm/www.conf.in     2015-02-04 19:27:25.275218535 +0200
+@@ -32,7 +32,7 @@
+ ;                            (IPv6 and IPv4-mapped) on a specific port;
  ;   '/path/to/unix/socket' - to listen on a unix socket.
  ; Note: This value is mandatory.
 -listen = 127.0.0.1:9000
 +listen = /var/run/php/@processname@.sock
  
- ; Set listen(2) backlog. A value of '-1' means unlimited.
- ; Default Value: 128 (-1 on FreeBSD and OpenBSD)
-@@ -161,7 +162,7 @@
+ ; Set listen(2) backlog.
+ ; Default Value: 511 (-1 on FreeBSD and OpenBSD)
+@@ -46,9 +46,9 @@
+ ; and group can be specified either by name or by their numeric IDs.
+ ; Default Values: user and group are set as the running user
+ ;                 mode is set to 0660
+-;listen.owner = @php_fpm_user@
+-;listen.group = @php_fpm_group@
+-;listen.mode = 0660
++listen.owner = root
++listen.group = @php_fpm_group@
++listen.mode = 0660
+ ; When POSIX Access Control Lists are supported you can set them using
+ ; these options, value is a comma separated list of user/group names.
+ ; When set, listen.owner and listen.group are ignored
+@@ -53,7 +53,7 @@
  ; must be separated by a comma. If this value is left blank, connections will be
  ; accepted from any ip address.
  ; Default Value: any
 -;listen.allowed_clients = 127.0.0.1
 +listen.allowed_clients = 127.0.0.1
  
- ; Choose how the process manager will control the number of child processes.
- ; Possible Values:
-@@ -208,12 +209,12 @@
- ; The desired minimum number of idle server processes.
- ; Note: Used only when pm is set to 'dynamic'
- ; Note: Mandatory when pm is set to 'dynamic'
--pm.min_spare_servers = 1
-+pm.min_spare_servers = 2
- ; The desired maximum number of idle server processes.
- ; Note: Used only when pm is set to 'dynamic'
- ; Note: Mandatory when pm is set to 'dynamic'
--pm.max_spare_servers = 3
-+pm.max_spare_servers = 5
- ; The number of seconds after which an idle process will be killed.
- ; Note: Used only when pm is set to 'ondemand'
-@@ -323,7 +324,7 @@
- ;       anything, but it may not be a good idea to use the .php extension or it
- ;       may conflict with a real PHP file.
- ; Default Value: not set 
--;pm.status_path = /status
-+;pm.status_path = /fpm-status
-  
- ; The ping URI to call the monitoring page of FPM. If this value is not set, no
- ; URI will be recognized as a ping page. This could be used to test from outside
-@@ -449,7 +450,7 @@
- ; Note: on highloaded environement, this can cause some delay in the page
- ; process time (several ms).
- ; Default Value: no
--;catch_workers_output = yes
-+catch_workers_output = yes
- ; Limits the extensions of the main script FPM will allow to parse. This can
- ; prevent configuration mistakes on the web server side. You should only limit
-@@ -463,7 +464,7 @@
+ ; Specify the nice(2) priority to apply to the pool processes (only if set)
+ ; The value can vary from -19 (highest priority) to 20 (lower priority)
+@@ -372,7 +372,7 @@
  ; the current environment.
  ; Default Value: clean env
  ;env[HOSTNAME] = $HOSTNAME
  
                        ths = document.getElementsByTagName("th");
                        for (var i=0; i<ths.length; i++) {
---- php-5.3.9/sapi/fpm/Makefile.frag~  2012-01-11 21:49:42.000000000 +0200
-+++ php-5.3.9/sapi/fpm/Makefile.frag   2012-01-12 02:20:25.553355153 +0200
-@@ -21,7 +21,7 @@
-       @echo "Installing PHP FPM config:        $(INSTALL_ROOT)$(sysconfdir)/" && \
-       $(mkinstalldirs) $(INSTALL_ROOT)$(sysconfdir) || :
--      @$(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf.default || :
-+      @$(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf || :
+--- php-7.1.3/sapi/fpm/Makefile.frag~  2017-03-14 15:17:50.000000000 +0200
++++ php-7.1.3/sapi/fpm/Makefile.frag   2017-03-28 09:44:28.799989897 +0300
+@@ -14,9 +14,9 @@
+               echo "Installing PHP FPM defconfig:     skipping"; \
+       else \
+               echo "Installing PHP FPM defconfig:     $(INSTALL_ROOT)$(sysconfdir)/" && \
+-              $(mkinstalldirs) $(INSTALL_ROOT)$(sysconfdir)/php-fpm.d; \
+-              $(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf.default; \
+-              $(INSTALL_DATA) sapi/fpm/www.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.d/www.conf.default; \
++              $(mkinstalldirs) $(INSTALL_ROOT)$(sysconfdir)/fpm.d; \
++              $(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf; \
++              $(INSTALL_DATA) sapi/fpm/www.conf $(INSTALL_ROOT)$(sysconfdir)/fpm.d/www.conf; \
+       fi
  
        @echo "Installing PHP FPM man page:      $(INSTALL_ROOT)$(mandir)/man8/"
-       @$(mkinstalldirs) $(INSTALL_ROOT)$(mandir)/man8