]> TLD Linux GIT Repositories - packages/php.git/blobdiff - php-fpm-config.patch
- updated to 8.3.6
[packages/php.git] / php-fpm-config.patch
index 353c0120b281c020a29c627695532285e2c33369..84c0fa27cbc145927497f3b5f404cbfe0a6e700a 100644 (file)
@@ -1,15 +1,6 @@
---- php-5.4.7/sapi/fpm/php-fpm.conf.in 2012-10-05 22:16:44.895998479 +0300
-+++ php-5.3.17/sapi/fpm/php-fpm.conf.in        2012-10-12 12:35:47.601602945 +0300
-@@ -12,7 +12,7 @@
- ; Relative path can also be used. They will be prefixed by:
- ;  - the global prefix if it's been set (-p arguement)
- ;  - @prefix@ otherwise
--;include=etc/fpm.d/*.conf
-+;include=/etc/php/fpm.d/*.conf
- ;;;;;;;;;;;;;;;;;;
- ; Global Options ;
-@@ -22,14 +22,14 @@
+--- php-7.1.0beta3/sapi/fpm/php-fpm.conf.in~   2016-08-19 09:48:00.000000000 +0300
++++ php-7.1.0beta3/sapi/fpm/php-fpm.conf.in    2016-08-31 13:59:19.139523160 +0300
+@@ -14,14 +14,14 @@
  ; Pid file
  ; Note: the default prefix is @EXPANDED_LOCALSTATEDIR@
  ; Default Value: none
@@ -18,7 +9,7 @@
  
  ; Error log file
  ; If it's set to "syslog", log is sent to syslogd instead of being written
- ; in a local file.
+ ; into a local file.
  ; Note: the default prefix is @EXPANDED_LOCALSTATEDIR@
  ; Default Value: log/php-fpm.log
 -;error_log = log/php-fpm.log
  
  ; syslog_facility is used to specify what type of program is logging the
  ; message. This lets syslogd specify that messages from different facilities
-@@ -93,7 +93,7 @@
- ;                            specific port;
+--- php-8.2.0RC2/sapi/fpm/www.conf.in~ 2022-09-29 01:22:09.000000000 +0300
++++ php-8.2.0RC2/sapi/fpm/www.conf.in  2022-09-29 01:23:24.680196092 +0300
+@@ -33,7 +33,7 @@
+ ;                            (IPv6 and IPv4-mapped) on a specific port;
  ;   '/path/to/unix/socket' - to listen on a unix socket.
  ; Note: This value is mandatory.
 -listen = 127.0.0.1:9000
 +listen = /var/run/php/@processname@.sock
  
- ; Set listen(2) backlog. A value of '-1' means unlimited.
- ; Default Value: 128 (-1 on FreeBSD and OpenBSD)
-@@ -105,7 +105,7 @@
+ ; Set listen(2) backlog.
+ ; Default Value: 511 (-1 on Linux, FreeBSD and OpenBSD)
+@@ -50,9 +50,9 @@ listen = /var/run/php/@processname@.sock
+ ; and group can be specified either by name or by their numeric IDs.
+ ; Default Values: Owner is set to the master process running user. If the group
+ ;                 is not set, the owner's group is used. Mode is set to 0660.
+-;listen.owner = @php_fpm_user@
+-;listen.group = @php_fpm_group@
+-;listen.mode = 0660
++listen.owner = root
++listen.group = @php_fpm_group@
++listen.mode = 0660
+ ; When POSIX Access Control Lists are supported you can set them using
+ ; these options, value is a comma separated list of user/group names.
+@@ -60,7 +60,7 @@
  ; must be separated by a comma. If this value is left blank, connections will be
  ; accepted from any ip address.
  ; Default Value: any
 -;listen.allowed_clients = 127.0.0.1
 +listen.allowed_clients = 127.0.0.1
  
- ; Set permissions for unix socket, if one is used. In Linux, read/write
- ; permissions must be set in order to allow connections from a web server. Many
-@@ -277,7 +277,7 @@
+ ; Set the associated the route table (FIB). FreeBSD only
+ ; Default Value: -1
+@@ -372,7 +372,7 @@
  ; the current environment.
  ; Default Value: clean env
  ;env[HOSTNAME] = $HOSTNAME
  
                        ths = document.getElementsByTagName("th");
                        for (var i=0; i<ths.length; i++) {
---- php-5.4.18/sapi/fpm/Makefile.frag~ 2013-08-14 08:47:24.000000000 +0300
-+++ php-5.4.18/sapi/fpm/Makefile.frag  2013-08-29 10:20:38.161424172 +0300
-@@ -12,7 +12,7 @@
-       @echo "Installing PHP FPM config:        $(INSTALL_ROOT)$(sysconfdir)/" && \
-       $(mkinstalldirs) $(INSTALL_ROOT)$(sysconfdir) || :
--      @$(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf.default || :
-+      @$(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf || :
+--- php-7.1.3/sapi/fpm/Makefile.frag~  2017-03-14 15:17:50.000000000 +0200
++++ php-7.1.3/sapi/fpm/Makefile.frag   2017-03-28 09:44:28.799989897 +0300
+@@ -14,9 +14,9 @@
+               echo "Installing PHP FPM defconfig:     skipping"; \
+       else \
+               echo "Installing PHP FPM defconfig:     $(INSTALL_ROOT)$(sysconfdir)/" && \
+-              $(mkinstalldirs) $(INSTALL_ROOT)$(sysconfdir)/php-fpm.d; \
+-              $(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf.default; \
+-              $(INSTALL_DATA) sapi/fpm/www.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.d/www.conf.default; \
++              $(mkinstalldirs) $(INSTALL_ROOT)$(sysconfdir)/fpm.d; \
++              $(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf; \
++              $(INSTALL_DATA) sapi/fpm/www.conf $(INSTALL_ROOT)$(sysconfdir)/fpm.d/www.conf; \
+       fi
  
        @echo "Installing PHP FPM man page:      $(INSTALL_ROOT)$(mandir)/man8/"
-       @$(mkinstalldirs) $(INSTALL_ROOT)$(mandir)/man8