]> TLD Linux GIT Repositories - packages/php.git/blobdiff - php-fpm-config.patch
- updated to 8.3.6
[packages/php.git] / php-fpm-config.patch
index c4b2d8a088be2c5bf4f914c6035beb259956775b..84c0fa27cbc145927497f3b5f404cbfe0a6e700a 100644 (file)
@@ -1,5 +1,5 @@
---- php-5.6.2/sapi/fpm/php-fpm.conf.in 2014-10-27 08:20:34.963718145 +0200
-+++ php-5.6.2.old/sapi/fpm/php-fpm.conf.in     2014-10-27 08:07:47.762117299 +0200
+--- php-7.1.0beta3/sapi/fpm/php-fpm.conf.in~   2016-08-19 09:48:00.000000000 +0300
++++ php-7.1.0beta3/sapi/fpm/php-fpm.conf.in    2016-08-31 13:59:19.139523160 +0300
 @@ -14,14 +14,14 @@
  ; Pid file
  ; Note: the default prefix is @EXPANDED_LOCALSTATEDIR@
@@ -9,7 +9,7 @@
  
  ; Error log file
  ; If it's set to "syslog", log is sent to syslogd instead of being written
- ; in a local file.
+ ; into a local file.
  ; Note: the default prefix is @EXPANDED_LOCALSTATEDIR@
  ; Default Value: log/php-fpm.log
 -;error_log = log/php-fpm.log
@@ -17,8 +17,8 @@
  
  ; syslog_facility is used to specify what type of program is logging the
  ; message. This lets syslogd specify that messages from different facilities
---- php-5.6.2.old/sapi/fpm/www.conf.in 2014-10-27 08:07:47.762117299 +0200
-+++ php-5.6.2/sapi/fpm/www.conf.in     2014-10-27 08:23:41.232196777 +0200
+--- php-8.2.0RC2/sapi/fpm/www.conf.in~ 2022-09-29 01:22:09.000000000 +0300
++++ php-8.2.0RC2/sapi/fpm/www.conf.in  2022-09-29 01:23:24.680196092 +0300
 @@ -33,7 +33,7 @@
  ;                            (IPv6 and IPv4-mapped) on a specific port;
  ;   '/path/to/unix/socket' - to listen on a unix socket.
 +listen = /var/run/php/@processname@.sock
  
  ; Set listen(2) backlog.
- ; Default Value: 511 (-1 on FreeBSD and OpenBSD)
-@@ -44,9 +44,9 @@
- ; BSD-derived systems allow connections regardless of permissions.
- ; Default Values: user and group are set as the running user
- ;                 mode is set to 0660
+ ; Default Value: 511 (-1 on Linux, FreeBSD and OpenBSD)
+@@ -50,9 +50,9 @@ listen = /var/run/php/@processname@.sock
+ ; and group can be specified either by name or by their numeric IDs.
+ ; Default Values: Owner is set to the master process running user. If the group
+ ;                 is not set, the owner's group is used. Mode is set to 0660.
 -;listen.owner = @php_fpm_user@
 -;listen.group = @php_fpm_group@
 -;listen.mode = 0660
 +listen.owner = root
 +listen.group = @php_fpm_group@
 +listen.mode = 0660
  ; When POSIX Access Control Lists are supported you can set them using
  ; these options, value is a comma separated list of user/group names.
- ; When set, listen.owner and listen.group are ignored
-@@ -59,7 +59,7 @@
+@@ -60,7 +60,7 @@
  ; must be separated by a comma. If this value is left blank, connections will be
  ; accepted from any ip address.
  ; Default Value: any
 -;listen.allowed_clients = 127.0.0.1
 +listen.allowed_clients = 127.0.0.1
  
- ; Specify the nice(2) priority to apply to the pool processes (only if set)
- ; The value can vary from -19 (highest priority) to 20 (lower priority)
-@@ -382,7 +382,7 @@
+ ; Set the associated the route table (FIB). FreeBSD only
+ ; Default Value: -1
+@@ -372,7 +372,7 @@
  ; the current environment.
  ; Default Value: clean env
  ;env[HOSTNAME] = $HOSTNAME
  
                        ths = document.getElementsByTagName("th");
                        for (var i=0; i<ths.length; i++) {
---- php-5.6.2/sapi/fpm/Makefile.frag~  2014-10-27 08:18:59.000000000 +0200
-+++ php-5.6.2/sapi/fpm/Makefile.frag   2014-10-27 08:19:37.524436179 +0200
-@@ -12,8 +12,8 @@
-       @echo "Installing PHP FPM config:        $(INSTALL_ROOT)$(sysconfdir)/" && \
-       $(mkinstalldirs) $(INSTALL_ROOT)$(sysconfdir)/php-fpm.d || :
--      @$(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf.default || :
--      @$(INSTALL_DATA) sapi/fpm/www.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.d/www.conf.default || :
-+      @$(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf || :
-+      @$(INSTALL_DATA) sapi/fpm/www.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.d/www.conf || :
+--- php-7.1.3/sapi/fpm/Makefile.frag~  2017-03-14 15:17:50.000000000 +0200
++++ php-7.1.3/sapi/fpm/Makefile.frag   2017-03-28 09:44:28.799989897 +0300
+@@ -14,9 +14,9 @@
+               echo "Installing PHP FPM defconfig:     skipping"; \
+       else \
+               echo "Installing PHP FPM defconfig:     $(INSTALL_ROOT)$(sysconfdir)/" && \
+-              $(mkinstalldirs) $(INSTALL_ROOT)$(sysconfdir)/php-fpm.d; \
+-              $(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf.default; \
+-              $(INSTALL_DATA) sapi/fpm/www.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.d/www.conf.default; \
++              $(mkinstalldirs) $(INSTALL_ROOT)$(sysconfdir)/fpm.d; \
++              $(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf; \
++              $(INSTALL_DATA) sapi/fpm/www.conf $(INSTALL_ROOT)$(sysconfdir)/fpm.d/www.conf; \
+       fi
  
        @echo "Installing PHP FPM man page:      $(INSTALL_ROOT)$(mandir)/man8/"
-       @$(mkinstalldirs) $(INSTALL_ROOT)$(mandir)/man8