]> TLD Linux GIT Repositories - packages/php.git/blobdiff - php-fpm-config.patch
- updated to 8.3.6
[packages/php.git] / php-fpm-config.patch
index da235fcfda104954b011fe695030848fecf9ceea..84c0fa27cbc145927497f3b5f404cbfe0a6e700a 100644 (file)
  
  ; syslog_facility is used to specify what type of program is logging the
  ; message. This lets syslogd specify that messages from different facilities
---- php-5.6.5/sapi/fpm/www.conf.in~    2015-02-04 19:26:16.000000000 +0200
-+++ php-5.6.5/sapi/fpm/www.conf.in     2015-02-04 19:27:25.275218535 +0200
-@@ -32,7 +32,7 @@
- ;                            specific port;
+--- php-8.2.0RC2/sapi/fpm/www.conf.in~ 2022-09-29 01:22:09.000000000 +0300
++++ php-8.2.0RC2/sapi/fpm/www.conf.in  2022-09-29 01:23:24.680196092 +0300
+@@ -33,7 +33,7 @@
+ ;                            (IPv6 and IPv4-mapped) on a specific port;
  ;   '/path/to/unix/socket' - to listen on a unix socket.
  ; Note: This value is mandatory.
 -listen = 127.0.0.1:9000
 +listen = /var/run/php/@processname@.sock
  
  ; Set listen(2) backlog.
- ; Default Value: 65535 (-1 on FreeBSD and OpenBSD)
-@@ -46,9 +46,9 @@
- ; BSD-derived systems allow connections regardless of permissions. 
- ; Default Values: user and group are set as the running user
- ;                 mode is set to 0660
+ ; Default Value: 511 (-1 on Linux, FreeBSD and OpenBSD)
+@@ -50,9 +50,9 @@ listen = /var/run/php/@processname@.sock
+ ; and group can be specified either by name or by their numeric IDs.
+ ; Default Values: Owner is set to the master process running user. If the group
+ ;                 is not set, the owner's group is used. Mode is set to 0660.
 -;listen.owner = @php_fpm_user@
 -;listen.group = @php_fpm_group@
 -;listen.mode = 0660
 +listen.owner = root
 +listen.group = @php_fpm_group@
 +listen.mode = 0660
  ; When POSIX Access Control Lists are supported you can set them using
  ; these options, value is a comma separated list of user/group names.
- ; When set, listen.owner and listen.group are ignored
-@@ -53,7 +53,7 @@
+@@ -60,7 +60,7 @@
  ; must be separated by a comma. If this value is left blank, connections will be
  ; accepted from any ip address.
  ; Default Value: any
 -;listen.allowed_clients = 127.0.0.1
 +listen.allowed_clients = 127.0.0.1
  
- ; Specify the nice(2) priority to apply to the pool processes (only if set)
- ; The value can vary from -19 (highest priority) to 20 (lower priority)
+ ; Set the associated the route table (FIB). FreeBSD only
+ ; Default Value: -1
 @@ -372,7 +372,7 @@
  ; the current environment.
  ; Default Value: clean env
@@ -70,8 +70,8 @@
  
                        ths = document.getElementsByTagName("th");
                        for (var i=0; i<ths.length; i++) {
---- php7.0-7.0/sapi/fpm/Makefile.frag~ 2015-05-21 17:57:06.000000000 +0300
-+++ php7.0-7.0/sapi/fpm/Makefile.frag  2015-05-23 11:01:51.383332821 +0300
+--- php-7.1.3/sapi/fpm/Makefile.frag~  2017-03-14 15:17:50.000000000 +0200
++++ php-7.1.3/sapi/fpm/Makefile.frag   2017-03-28 09:44:28.799989897 +0300
 @@ -14,9 +14,9 @@
                echo "Installing PHP FPM defconfig:     skipping"; \
        else \
@@ -83,5 +83,5 @@
 +              $(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf; \
 +              $(INSTALL_DATA) sapi/fpm/www.conf $(INSTALL_ROOT)$(sysconfdir)/fpm.d/www.conf; \
        fi
-       
        @echo "Installing PHP FPM man page:      $(INSTALL_ROOT)$(mandir)/man8/"