]> TLD Linux GIT Repositories - packages/php.git/blobdiff - php-fpm-config.patch
- up to 7.0.14
[packages/php.git] / php-fpm-config.patch
index 03a9a7bac3bb3b4dcb937e17d3231fb71fc09dcf..c4b2d8a088be2c5bf4f914c6035beb259956775b 100644 (file)
@@ -1,15 +1,6 @@
---- php-5.4.7/sapi/fpm/php-fpm.conf.in 2012-10-05 22:16:44.895998479 +0300
-+++ php-5.3.17/sapi/fpm/php-fpm.conf.in        2012-10-12 12:35:47.601602945 +0300
-@@ -12,7 +12,7 @@
- ; Relative path can also be used. They will be prefixed by:
- ;  - the global prefix if it's been set (-p arguement)
- ;  - @prefix@ otherwise
--;include=etc/fpm.d/*.conf
-+;include=/etc/php/fpm.d/*.conf
- ;;;;;;;;;;;;;;;;;;
- ; Global Options ;
-@@ -22,14 +22,14 @@
+--- php-5.6.2/sapi/fpm/php-fpm.conf.in 2014-10-27 08:20:34.963718145 +0200
++++ php-5.6.2.old/sapi/fpm/php-fpm.conf.in     2014-10-27 08:07:47.762117299 +0200
+@@ -14,14 +14,14 @@
  ; Pid file
  ; Note: the default prefix is @EXPANDED_LOCALSTATEDIR@
  ; Default Value: none
  
  ; syslog_facility is used to specify what type of program is logging the
  ; message. This lets syslogd specify that messages from different facilities
-@@ -93,7 +93,7 @@
- ;                            specific port;
+--- php-5.6.2.old/sapi/fpm/www.conf.in 2014-10-27 08:07:47.762117299 +0200
++++ php-5.6.2/sapi/fpm/www.conf.in     2014-10-27 08:23:41.232196777 +0200
+@@ -33,7 +33,7 @@
+ ;                            (IPv6 and IPv4-mapped) on a specific port;
  ;   '/path/to/unix/socket' - to listen on a unix socket.
  ; Note: This value is mandatory.
 -listen = 127.0.0.1:9000
 +listen = /var/run/php/@processname@.sock
  
- ; Set listen(2) backlog. A value of '-1' means unlimited.
- ; Default Value: 128 (-1 on FreeBSD and OpenBSD)
-@@ -105,7 +105,7 @@
+ ; Set listen(2) backlog.
+ ; Default Value: 511 (-1 on FreeBSD and OpenBSD)
+@@ -44,9 +44,9 @@
+ ; BSD-derived systems allow connections regardless of permissions.
+ ; Default Values: user and group are set as the running user
+ ;                 mode is set to 0660
+-;listen.owner = @php_fpm_user@
+-;listen.group = @php_fpm_group@
+-;listen.mode = 0660
++listen.owner = root
++listen.group = @php_fpm_group@
++listen.mode = 0660
+ ; When POSIX Access Control Lists are supported you can set them using
+ ; these options, value is a comma separated list of user/group names.
+ ; When set, listen.owner and listen.group are ignored
+@@ -59,7 +59,7 @@
  ; must be separated by a comma. If this value is left blank, connections will be
  ; accepted from any ip address.
  ; Default Value: any
 -;listen.allowed_clients = 127.0.0.1
 +listen.allowed_clients = 127.0.0.1
  
- ; Set permissions for unix socket, if one is used. In Linux, read/write
- ; permissions must be set in order to allow connections from a web server. Many
-@@ -277,7 +277,7 @@
+ ; Specify the nice(2) priority to apply to the pool processes (only if set)
+ ; The value can vary from -19 (highest priority) to 20 (lower priority)
+@@ -382,7 +382,7 @@
  ; the current environment.
  ; Default Value: clean env
  ;env[HOSTNAME] = $HOSTNAME
  ;env[TMP] = /tmp
  ;env[TMPDIR] = /tmp
  ;env[TEMP] = /tmp
+--- php-5.3.9/sapi/fpm/status.html.in~ 2011-10-08 23:43:12.000000000 +0300
++++ php-5.3.9/sapi/fpm/status.html.in  2012-01-12 02:19:09.573191879 +0200
+@@ -96,7 +96,7 @@
+                       var sort_index;
+                       var sort_order;
+-                      doc_url.value = location.protocol + '//' + location.host + "/status?json&full";
++                      doc_url.value = location.protocol + '//' + location.host + "/fpm-status?json&full";
+                       ths = document.getElementsByTagName("th");
+                       for (var i=0; i<ths.length; i++) {
+--- php-5.6.2/sapi/fpm/Makefile.frag~  2014-10-27 08:18:59.000000000 +0200
++++ php-5.6.2/sapi/fpm/Makefile.frag   2014-10-27 08:19:37.524436179 +0200
+@@ -12,8 +12,8 @@
+       @echo "Installing PHP FPM config:        $(INSTALL_ROOT)$(sysconfdir)/" && \
+       $(mkinstalldirs) $(INSTALL_ROOT)$(sysconfdir)/php-fpm.d || :
+-      @$(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf.default || :
+-      @$(INSTALL_DATA) sapi/fpm/www.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.d/www.conf.default || :
++      @$(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf || :
++      @$(INSTALL_DATA) sapi/fpm/www.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.d/www.conf || :
+       @echo "Installing PHP FPM man page:      $(INSTALL_ROOT)$(mandir)/man8/"
+       @$(mkinstalldirs) $(INSTALL_ROOT)$(mandir)/man8