]> TLD Linux GIT Repositories - packages/php.git/blobdiff - php-pear.patch
- updated to 7.3.0, merged some patches from PLD, not tested yet
[packages/php.git] / php-pear.patch
index 86b327aa588bd0f4a86efcd4b24dacec153c672a..2772cd11b7730b001c2764a1b8186514e87eae2f 100644 (file)
@@ -1,6 +1,6 @@
---- php-5.3.1/configure.ac~    2010-02-19 23:26:13.000000000 +0200
-+++ php-5.3.1/configure.ac     2010-02-19 23:27:58.273207305 +0200
-@@ -1102,11 +1102,6 @@
+--- php-7.3.0beta3/configure.ac~       2018-09-05 19:02:49.000000000 +0300
++++ php-7.3.0beta3/configure.ac        2018-09-05 19:04:13.237533903 +0300
+@@ -934,11 +934,6 @@
    with_pear=no
  fi
  
 -fi
 -
  PHP_ARG_WITH(pear, [whether to install PEAR],
- [  --with-pear=DIR         Install PEAR in DIR @<:@PREFIX/lib/php@:>@
+ [  --with-pear=DIR         Install PEAR in DIR [PREFIX/lib/php]
    --without-pear          Do not install PEAR], DEFAULT, yes)
-@@ -1116,11 +1111,11 @@
-   dnl
-   dnl PEAR dependancies
-   dnl
+@@ -1137,19 +1137,6 @@
+   --without-pear          Do not install PEAR], DEFAULT, yes)
+ if test "$PHP_PEAR" != "no"; then
+-
+-  dnl
+-  dnl PEAR dependencies
+-  dnl
 -  if test "$PHP_XML" = "no"; then
 -    pear_error_msg="$pear_error_msg
 -                    PEAR requires XML to be enabled.     Add --enable-xml to the configure line. (or --without-pear)"
 -  fi
 -
-+dnl  if test "$PHP_XML" = "no"; then
-+dnl    pear_error_msg="$pear_error_msg
-+dnl                    PEAR requires XML to be enabled.     Add --enable-xml to the configure line. (or --without-pear)"
-+dnl  fi
-+dnl
- dnl
- dnl  if test "$PHP_XMLRPC" = "no"; then
- dnl    pear_error_msg="$pear_error_msg
+-  if test "$pear_error_msg"; then
+-    AC_MSG_ERROR([$pear_error_msg])
+-  fi
+-
+   install_pear="install-pear"
+   PEAR_INSTALLDIR=$PHP_PEAR
 --- php-5.2.6/sapi/cli/config.m4~      2008-11-16 18:35:31.000000000 +0200
 +++ php-5.2.6/sapi/cli/config.m4       2008-11-20 19:04:12.585061299 +0200
 @@ -4,7 +4,7 @@