]> TLD Linux GIT Repositories - packages/php.git/blobdiff - php.spec
- updated to 5.6.2
[packages/php.git] / php.spec
index dbc89eb675571b5ddba559dce066e305b84730c7..244f8d59cfa53a8bebae053d45cf68bfa74fcfa0 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -135,7 +135,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define                rel     0.1
+%define                rel     1
 %define                orgname php
 %define                ver_suffix 56
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -146,13 +146,13 @@ Summary(pt_BR.UTF-8):     A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 5 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       5.6.0
+Version:       5.6.2
 Release:       %{rel}%{?with_type_hints:.th}
 Epoch:         4
 License:       PHP
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: 642825d75ce2634d9513d5b21dbee521
+# Source0-md5: c976f54d429a0e5214659b0098e44e37
 Source2:       %{orgname}-mod_%{orgname}.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
@@ -582,7 +582,6 @@ Requires:   libtool >= 2:2.2
 %{?with_pcre:Requires: pcre-devel >= 8.10}
 Requires:      shtool
 Provides:      php-devel = %{epoch}:%{version}-%{release}
-Obsoletes:     php-devel
 Obsoletes:     php-pear-devel
 Obsoletes:     php4-devel
 Obsoletes:     php52-devel
@@ -2626,8 +2625,15 @@ cp -p sapi/embed/php_embed.h $RPM_BUILD_ROOT%{_includedir}/php/sapi/embed
 # versioned suffix is always installed
 libtool --mode=install install -p sapi/cli/php $RPM_BUILD_ROOT%{_bindir}/php%{ver_suffix}
 cp -p sapi/cli/php.1 $RPM_BUILD_ROOT%{_mandir}/man1/php%{ver_suffix}.1
+
+%if %{with default_php}
+# man for php
 echo ".so php%{ver_suffix}.1" >$RPM_BUILD_ROOT%{_mandir}/man1/php.1
+# link as /usr/bin/php
 ln -sf php%{ver_suffix} $RPM_BUILD_ROOT%{_bindir}/php
+# php.cli link for backward compatibility
+ln -sf php $RPM_BUILD_ROOT%{_bindir}/php.cli
+%endif
 
 cp -p php.ini $RPM_BUILD_ROOT%{_sysconfdir}/php.ini