]> TLD Linux GIT Repositories - packages/php.git/blobdiff - php.spec
- more obsoletes on devel
[packages/php.git] / php.spec
index e19da42406a699cda5148e30c1a13f281fe932c3..3b337da6f5a095b377ba1f4a4943b74f6cb0b1d8 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -42,7 +42,8 @@
 # Reflection
 #
 # Conditional build:
-%bcond_without default_php     # use this PHP as default PHP in distro
+
+%bcond_with    default_php     # use this PHP as default PHP in distro
 %bcond_with    interbase_inst  # use InterBase install., not Firebird  (BR: proprietary libs)
 %bcond_with    oci8            # with Oracle oci8 extension module     (BR: proprietary libs)
 %bcond_with    instantclient   # build Oracle oci8 extension module against oracle-instantclient package
@@ -139,13 +140,13 @@ Summary(pt_BR.UTF-8):     A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 5 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       5.5.10
+Version:       5.5.16
 Release:       %{rel}%{?with_type_hints:.th}%{?with_oci8:.oci}
 Epoch:         4
 License:       PHP
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{orgname}-%{version}.tar.bz2
-# Source0-md5: d608230c7890b6a0cc5b92e66e866226
+# Source0-md5: 331a87fb27e100a88b3845d34582f769
 Source2:       %{orgname}-mod_%{orgname}.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
@@ -314,7 +315,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                hashver         1.0
 %define                intlver         1.1.0
 %define                jsonver         1.2.1
-%define                opcachever      7.0.3
+%define                opcachever      7.0.4-dev
 %define                pharver         2.0.2
 %define                sqlite3ver      0.7-dev
 %define                zipver          1.11.0
@@ -562,6 +563,8 @@ Obsoletes:  php-devel
 Obsoletes:     php-pear-devel
 Obsoletes:     php4-devel
 Obsoletes:     php52-devel
+Obsoletes:     php53-devel
+Obsoletes:     php54-devel
 
 %description devel
 The php-devel package lets you compile dynamic extensions to PHP.
@@ -2051,7 +2054,7 @@ if test "$ver" != "%{jsonver}"; then
        : Update the jsonver macro and rebuild.
        exit 1
 fi
-ver=$(sed -n '/#define ACCELERATOR_VERSION /{s/.* "//;s/".*$//;p}' ext/opcache/ZendAccelerator.h)
+ver=$(sed -n '/#define PHP_ZENDOPCACHE_VERSION /{s/.* "//;s/".*$//;p}' ext/opcache/ZendAccelerator.h)
 if test "$ver" != "%{opcachever}"; then
        : Error: Upstream Zend Opcachge version is now ${ver}, expecting %{opcachever}.
        : Update the opcachever macro and rebuild.