]> TLD Linux GIT Repositories - packages/php.git/blobdiff - php.spec
- updated to 8.0.8
[packages/php.git] / php.spec
index 3e7d670560598d616ccc679d0de83c2ab28ad2ba..40e4986564842b784f5587427143c42be431cb47 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -1,6 +1,6 @@
 # Conditional build:
 # - General options:
-%bcond_without embed           # disable building Embedded API
+%bcond_with    embed           # disable building Embedded API
 %bcond_with    gcov            # Enable Code coverage reporting
 %bcond_without kerberos5       # without Kerberos5 support
 %bcond_with    systemtap       # systemtap/DTrace support
@@ -33,7 +33,6 @@
 %bcond_without iconv           # without iconv extension module
 %bcond_without imap            # without IMAP extension module
 %bcond_without intl            # without Intl extension module
-%bcond_without json            # without json extension module
 %bcond_without ldap            # without LDAP extension module
 %bcond_without mbstring        # without mbstring extension module
 %bcond_without mhash           # without mhash extension (supported by hash extension)
@@ -64,7 +63,6 @@
 %bcond_without sqlite2         # without SQLite extension module
 %bcond_without sqlite3         # without SQLite3 extension module
 %bcond_without tidy            # without Tidy extension module
-%bcond_without xmlrpc          # without XML-RPC extension module
 %bcond_without xsl             # without xsl extension module
 %bcond_without zip             # without zip extension module
 # extensions options
 %endif
 
 %define                orgname php
-%define                php_suffix 74
+%define                php_suffix 80
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
 Summary(pl.UTF-8):     Język skryptowy PHP
@@ -125,8 +123,8 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 7 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       7.4.1
-Release:       2
+Version:       8.0.8
+Release:       1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
@@ -134,7 +132,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       http://php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: 6282f607a87c91b56ca14c3aacdba969
+# Source0-md5: ff8897b914cb8de9d218bbae877decc7
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
@@ -154,7 +152,6 @@ Patch9:             libtool-tag.patch
 Patch10:       %{orgname}-ini.patch
 Patch11:       embed.patch
 Patch14:       %{orgname}-no_pear_install.patch
-Patch17:       %{orgname}-readline.patch
 Patch18:       %{orgname}-nohttpd.patch
 Patch21:       %{orgname}-dba-link.patch
 Patch22:       %{orgname}-both-apxs.patch
@@ -164,15 +161,12 @@ Patch25:  %{orgname}-stupidapache_version.patch
 Patch27:       %{orgname}-config-dir.patch
 Patch29:       %{orgname}-fcgi-graceful.patch
 Patch31:       %{orgname}-fcgi-error_log-no-newlines.patch
-Patch37:       %{orgname}-mysqli-charsetphpini.patch
-Patch38:       %{orgname}-pdo_mysql-charsetphpini.patch
 Patch39:       %{orgname}-use-prog_sendmail.patch
 Patch41:       %{orgname}-fpm-config.patch
 Patch43:       %{orgname}-silent-session-cleanup.patch
 Patch44:       %{orgname}-include_path.patch
 Patch50:       extension-shared-optional-dep.patch
 Patch53:       fix-test-run.patch
-Patch55:       bug-52078-fileinode.patch
 Patch59:       %{orgname}-systzdata.patch
 Patch66:       php-db.patch
 Patch67:       mysql-lib-ver-mismatch.patch
@@ -244,7 +238,6 @@ BuildRequires:      tar >= 1:1.22
 %{?with_tidy:BuildRequires:    tidy-devel}
 BuildRequires: tokyocabinet-devel
 %{?with_odbc:BuildRequires:    unixODBC-devel}
-%{?with_xmlrpc:BuildRequires:  xmlrpc-epi-devel >= 0.54.1}
 BuildRequires: xz
 BuildRequires: zlib-devel >= 1.2.0.4
 %if %{with apache2}
@@ -255,14 +248,14 @@ BuildRequires:    apr-util-devel >= 1:1.0.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                php_sysconfdir          /etc/%{name}
-%define                php_extensiondir        %{_libdir}/%{name}
+%define                php_extensiondir        %{_libdir}/php/%{name}
 %define                php_datadir             /usr/share/php/%{name}
 %define                _sysconfdir             %{php_sysconfdir}
 
 # must be in sync with source. extra check ensuring that it is so is done in %%build
-%define                php_api_version         20190902
-%define                zend_module_api         20190902
-%define                zend_extension_api      320190902
+%define                php_api_version         20200930
+%define                zend_module_api         20200930
+%define                zend_extension_api      420200930
 %define                php_pdo_api_version     20170320
 
 # Extension versions
@@ -274,7 +267,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                jsonver         %{version}
 %define                pharver         %{version}
 %define                sqlite3ver      %{version}
-%define                zipver          1.15.5
+%define                zipver          1.19.3
 %define                phpdbgver       %{version}
 %define                sodiumver       %{version}
 
@@ -572,7 +565,6 @@ Requires:   libtool >= 2:2.4.6
 Requires:      pcre2-8-devel >= 10.30
 Requires:      shtool
 Provides:      php-devel = %{epoch}:%{version}-%{release}
-Obsoletes:     php-devel
 Obsoletes:     php-pear-devel
 Obsoletes:     php4-devel
 Obsoletes:     php52-devel
@@ -982,24 +974,6 @@ interfejsem do biblioteki ICU, pozwalającym programistom PHP na
 wykonywanie w skryptach porównań zgodnych z UCA oraz formatowania
 daty/czasu/walut.
 
-%package json
-Summary:       PHP C extension for JSON serialization
-Summary(pl.UTF-8):     Rozszerzenie C PHP dla serializacji JSON
-Group:         Libraries
-URL:           http://php.net/manual/en/book.json.php
-Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-Provides:      php(json) = %{jsonver}
-Obsoletes:     php-json < 4:5.3.28-7
-Obsoletes:     php-pecl-json < %{jsonver}
-
-%description json
-php-json is an extremely fast PHP C extension for JSON (JavaScript
-Object Notation) serialisation.
-
-%description json -l pl.UTF-8
-php-json to bardzo szybkie rozszerzenie C PHP dla serializacji JSON
-(JavaScript Object Notation).
-
 %package ldap
 Summary:       LDAP extension module for PHP
 Summary(pl.UTF-8):     Moduł LDAP dla PHP
@@ -1720,23 +1694,6 @@ Moduł PHP umożliwiający analizę plików XML w trybie Pull. Czytnik
 działa jako kursor przechodzący przez strumień dokumentu i
 zatrzymujący się na każdym węźle po drodze.
 
-%package xmlrpc
-Summary:       xmlrpc extension module for PHP
-Summary(pl.UTF-8):     Moduł xmlrpc dla PHP
-Group:         Libraries
-URL:           http://php.net/manual/en/book.xmlrpc.php
-Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-Requires:      %{name}-xml = %{epoch}:%{version}-%{release}
-Provides:      php(xmlrpc)
-Obsoletes:     php-xmlrpc < 4:5.3.28-7
-
-%description xmlrpc
-This is a dynamic shared object (DSO) for PHP that will add XMLRPC
-support.
-
-%description xmlrpc -l pl.UTF-8
-Moduł PHP dodający obsługę XMLRPC.
-
 %package xmlwriter
 Summary:       Fast, non-cached, forward-only means to write XML data
 Summary(pl.UTF-8):     Szybka, nie cachowana metoda zapisu danych w formacie XML
@@ -1821,7 +1778,6 @@ cp -p php.ini-production php.ini
 %patch9 -p1
 %patch10 -p1
 %patch14 -p1
-%patch17 -p1
 %patch18 -p1
 %patch21 -p1
 %patch22 -p1
@@ -1831,8 +1787,6 @@ cp -p php.ini-production php.ini
 %patch27 -p1
 %patch29 -p1
 %patch31 -p1
-%patch37 -p1
-%patch38 -p1
 %patch39 -p1
 %if %{with fpm}
 %patch41 -p1
@@ -1842,14 +1796,11 @@ cp -p php.ini-production php.ini
 %patch50 -p1
 %patch53 -p1
 %undos ext/spl/tests/SplFileInfo_getInode_basic.phpt
-%patch55 -p1
 %patch59 -p1 -b .systzdata
 %patch66 -p1
 %patch67 -p1
 %patch71 -p1
 
-%{__sed} -i -e '/PHP_ADD_LIBRARY_WITH_PATH/s#xmlrpc,#xmlrpc-epi,#' ext/xmlrpc/config.m4
-
 # cleanup backups after patching
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 
@@ -1857,7 +1808,6 @@ find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 %{__rm} -r ext/com_dotnet
 
 # remove all bundled libraries not to link with them accidentally
-%{__rm} -r ext/xmlrpc/libxmlrpc
 %{__rm} ext/date/lib/timezonedb.h
 
 cp -pf Zend/LICENSE{,.Zend}
@@ -2044,8 +1994,7 @@ if [ ! -f _built-conf ]; then
        touch _built-conf
 fi
 export PROG_SENDMAIL="/usr/lib/sendmail"
-export CPPFLAGS="-DDEBUG_FASTCGI -DHAVE_STRNDUP %{rpmcppflags} \
-       -I%{_includedir}/xmlrpc-epi"
+export CPPFLAGS="-DDEBUG_FASTCGI -DHAVE_STRNDUP %{rpmcppflags}"
 
 # This should be detected by configure and set there,
 # but looks like the build system is hosed on 7.3
@@ -2140,7 +2089,6 @@ for sapi in $sapis; do
        --enable-mbregex \
        %{__enable_disable pcntl pcntl shared} \
        %{__enable_disable pdo pdo shared} \
-       %{__enable_disable json json shared} \
        --enable-xmlwriter=shared \
 %if %{with fpm}
        --with-fpm-user=http \
@@ -2209,7 +2157,6 @@ for sapi in $sapis; do
        %{__with_without sqlite3 sqlite3 shared} \
        %{?with_tidy:--with-tidy=shared} \
        %{?with_odbc:--with-unixODBC=shared} \
-       %{__with_without xmlrpc xmlrpc shared,/usr} \
        %{?with_xsl:--with-xsl=shared} \
        --with-zlib=shared \
        %{?with_zip:--with-zip=shared} \
@@ -2233,7 +2180,7 @@ cp -af Makefile.cli Makefile
        MYSQLND_SHARED_LIBADD="-lssl -lcrypto"
 
 %if %{with apache2}
-%{__make} libtool-sapi LIBTOOL_SAPI=sapi/apache2handler/libphp7.la -f Makefile.apxs2
+%{__make} libtool-sapi LIBTOOL_SAPI=sapi/apache2handler/libphp8.la -f Makefile.apxs2
 %endif
 
 %if %{with litespeed}
@@ -2241,7 +2188,7 @@ cp -af Makefile.cli Makefile
 %endif
 
 %if %{with embed}
-%{__make} -f Makefile.embed libphp7.la
+%{__make} -f Makefile.embed libphp8.la
 %endif
 
 %if %{with phpdbg}
@@ -2336,14 +2283,10 @@ install -d \
 cp -pf php_config.h.cli main/php_config.h
 cp -pf Makefile.cli Makefile
 %{__make} install \
-       phpbuilddir=%{_libdir}/%{name}/build \
+       phpbuilddir=%{_libdir}/php/php%{php_suffix}/build \
        INSTALL_ROOT=$RPM_BUILD_ROOT
 
-# version the .phar files
-%{__mv} $RPM_BUILD_ROOT%{_bindir}/phar{,%{php_suffix}}.phar
-%{__mv} $RPM_BUILD_ROOT%{_mandir}/man1/phar{,%{php_suffix}}.1
 # touch for ghost
-%{__rm} $RPM_BUILD_ROOT%{_bindir}/phar
 touch $RPM_BUILD_ROOT%{_bindir}/phar
 touch $RPM_BUILD_ROOT%{_mandir}/man1/phar.1
 
@@ -2353,10 +2296,10 @@ v=$(echo %{version} | cut -d. -f1-2)
 # install Apache2 DSO module
 %if %{with apache2}
 # versioned libphp
-libtool --mode=install install -p sapi/apache2handler/libphp7.la $RPM_BUILD_ROOT%{_libdir}/apache
-%{__mv} $RPM_BUILD_ROOT%{_libdir}/apache/libphp7.la $RPM_BUILD_ROOT%{_libdir}/apache/libphp%{php_suffix}.la
-%{__mv} $RPM_BUILD_ROOT%{_libdir}/apache/libphp7.so $RPM_BUILD_ROOT%{_libdir}/apache/libphp%{php_suffix}.so
-sed -i -e "s|libphp7|libphp%{php_suffix}|g" $RPM_BUILD_ROOT%{_libdir}/apache/libphp%{php_suffix}.la
+libtool --mode=install install -p sapi/apache2handler/libphp8.la $RPM_BUILD_ROOT%{_libdir}/apache
+%{__mv} $RPM_BUILD_ROOT%{_libdir}/apache/libphp8.la $RPM_BUILD_ROOT%{_libdir}/apache/libphp%{php_suffix}.la
+%{__mv} $RPM_BUILD_ROOT%{_libdir}/apache/libphp8.so $RPM_BUILD_ROOT%{_libdir}/apache/libphp%{php_suffix}.so
+sed -i -e "s|libphp8|libphp%{php_suffix}|g" $RPM_BUILD_ROOT%{_libdir}/apache/libphp%{php_suffix}.la
 ln -s libphp%{php_suffix}.so $RPM_BUILD_ROOT%{_libdir}/apache/mod_php.so
 %endif
 
@@ -2420,7 +2363,7 @@ touch $RPM_BUILD_ROOT%{_sbindir}/php-fpm
 # we could use install-headers from Makefile.embed, but that would reinstall all headers
 # install-sapi installs to wrong dir, so just do it all manually
 install -d $RPM_BUILD_ROOT%{_includedir}/php/php%{php_suffix}/sapi/embed
-install -p libs/libphp7.so $RPM_BUILD_ROOT%{_libdir}/libphp%{php_suffix}.so
+install -p libs/libphp8.so $RPM_BUILD_ROOT%{_libdir}/libphp%{php_suffix}.so
 cp -p sapi/embed/php_embed.h $RPM_BUILD_ROOT%{_includedir}/php/php%{php_suffix}/sapi/embed
 %endif
 
@@ -2628,7 +2571,6 @@ fi \
 %extension_scripts iconv
 %extension_scripts imap
 %extension_scripts intl
-%extension_scripts json
 %extension_scripts ldap
 %extension_scripts mbstring
 %extension_scripts mysqli
@@ -2664,7 +2606,6 @@ fi \
 %extension_scripts tokenizer
 %extension_scripts xml
 %extension_scripts xmlreader
-%extension_scripts xmlrpc
 %extension_scripts xmlwriter
 %extension_scripts xsl
 %extension_scripts zip
@@ -2769,7 +2710,7 @@ fi
 %attr(755,root,root) %{_libdir}/libphp_common%{php_suffix}.so
 %{_libdir}/libphp_common%{php_suffix}.la
 %{_includedir}/php/php%{php_suffix}
-%{_libdir}/%{name}/build
+%{_libdir}/php/php%{php_suffix}/build
 %{_mandir}/man1/php-config%{php_suffix}.1*
 %ghost %{_mandir}/man1/php-config.1*
 %{_mandir}/man1/phpize%{php_suffix}.1*
@@ -2926,14 +2867,6 @@ fi
 %attr(755,root,root) %{php_extensiondir}/intl.so
 %endif
 
-%if %{with json}
-%files json
-%defattr(644,root,root,755)
-%doc ext/json/CREDITS
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/??_json.ini
-%attr(755,root,root) %{php_extensiondir}/json.so
-%endif
-
 %if %{with ldap}
 %files ldap
 %defattr(644,root,root,755)
@@ -3086,7 +3019,6 @@ fi
 %attr(755,root,root) %{php_extensiondir}/phar.so
 %attr(755,root,root) %{_bindir}/phar%{php_suffix}.phar
 %{_mandir}/man1/phar%{php_suffix}.1*
-%{_mandir}/man1/phar.phar.1*
 %ghost %{_bindir}/phar
 %ghost %{_mandir}/man1/phar.1*
 %endif
@@ -3231,14 +3163,6 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/??_xmlreader.ini
 %attr(755,root,root) %{php_extensiondir}/xmlreader.so
 
-%if %{with xmlrpc}
-%files xmlrpc
-%defattr(644,root,root,755)
-%doc ext/xmlrpc/CREDITS
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/??_xmlrpc.ini
-%attr(755,root,root) %{php_extensiondir}/xmlrpc.so
-%endif
-
 %files xmlwriter
 %defattr(644,root,root,755)
 %doc ext/xmlwriter/CREDITS