]> TLD Linux GIT Repositories - packages/php.git/blobdiff - php.spec
- updated to 5.4.45
[packages/php.git] / php.spec
index 7654d329bac0e6b489cdd9eff65c2d869769dce2..7b63059dde6c3846d5f5ef007450d22c332926f2 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -39,7 +39,7 @@
 # Reflection
 #
 # Conditional build:
-%bcond_without default_php     # use this PHP as default PHP in distro
+%bcond_with    default_php     # use this PHP as default PHP in distro
 %bcond_with    interbase_inst  # use InterBase install., not Firebird  (BR: proprietary libs)
 %bcond_with    oci8            # with Oracle oci8 extension module     (BR: proprietary libs)
 %bcond_with    instantclient   # build Oracle oci8 extension module against oracle-instantclient package
@@ -76,7 +76,7 @@
 %bcond_without webp            # Without WebP support in GD extension (imagecreatefromwebp)
 %bcond_without wddx            # without WDDX extension module
 %bcond_without xmlrpc          # without XML-RPC extension module
-%bcond_without apache1         # disable building Apache 1.3.x SAPI
+%bcond_with    apache1         # disable building Apache 1.3.x SAPI
 %bcond_without apache2         # disable building Apache 2.x SAPI
 %bcond_with    zts             # Zend Thread Safety
 %bcond_without cgi             # disable CGI/FCGI SAPI
@@ -135,13 +135,13 @@ Summary(pt_BR.UTF-8):     A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 5 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       5.4.17
+Version:       5.4.45
 Release:       %{rel}%{?with_type_hints:.th}%{?with_oci8:.oci}
 Epoch:         4
 License:       PHP
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{orgname}-%{version}.tar.bz2
-# Source0-md5: 1e027e99e2a874310fd518e87e3947af
+# Source0-md5: 185f67f1ca652b18bc0cca9d7edbde7c
 Source2:       %{orgname}-mod_%{orgname}.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
@@ -154,7 +154,7 @@ Source12:   %{orgname}-branch.sh
 Source13:      dep-tests.sh
 Source14:      skip-tests.sh
 Patch0:                %{orgname}-shared.patch
-Patch1:                %{orgname}-pldlogo.patch
+Patch1:                %{orgname}-tld.patch
 Patch2:                %{orgname}-mail.patch
 Patch3:                %{orgname}-link-libs.patch
 Patch4:                %{orgname}-libpq_fs_h_path.patch
@@ -213,6 +213,7 @@ Patch63:    %{orgname}-mysql-nowarning.patch
 #Patch64:      %{orgname}-m4.patch # not needed on 5.4 branch
 Patch65:       system-libzip.patch
 Patch66:       php-db.patch
+Patch67:       php-fileinfo.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -306,7 +307,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # Extension versions
 %define                bz2ver          1.0
 %define                enchantver      1.1.0
-%define                fileinfover     1.0.5
+%define                fileinfover     1.0.5-dev
 %define                hashver         1.0
 %define                intlver         1.1.0
 %define                jsonver         1.2.1
@@ -449,7 +450,7 @@ Summary:    PHP as CLI interpreter
 Summary(pl.UTF-8):     PHP jako interpreter działający z linii poleceń
 Group:         Development/Languages/PHP
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-Obsoletes:     php-program
+Provides:      php-program
 
 %description cli
 PHP as CLI interpreter.
@@ -520,7 +521,6 @@ Provides:   php(hash)
 Provides:      php(libxml)
 Provides:      php(reflection)
 Provides:      php(standard)
-%{!?with_mysqlnd:Obsoletes:    php-mysqlnd}
 %{?with_pcre:%requires_ge_to   pcre pcre-devel}
 Obsoletes:     php-pecl-domxml
 Conflicts:     php4-common < 3:4.4.4-8
@@ -557,6 +557,8 @@ Obsoletes:  php-devel
 Obsoletes:     php-pear-devel
 Obsoletes:     php4-devel
 Obsoletes:     php52-devel
+Obsoletes:     php53-devel
+Obsoletes:     php55-devel
 
 %description devel
 The php-devel package lets you compile dynamic extensions to PHP.
@@ -1905,6 +1907,7 @@ cp -p php.ini-production php.ini
 %patch63 -p1
 %{?with_system_libzip:%patch65 -p1}
 %patch66 -p1
+%patch67 -p1
 
 sed -i -e '/PHP_ADD_LIBRARY_WITH_PATH/s#xmlrpc,#xmlrpc-epi,#' ext/xmlrpc/config.m4