]> TLD Linux GIT Repositories - packages/php.git/blobdiff - php.spec
- updated to 8.3.6
[packages/php.git] / php.spec
index 5f849d2d9c3eeed951161b47943af34e3dc48eca..d345342768d7cc6c937835d1156f659b103b10ca 100644 (file)
--- a/php.spec
+++ b/php.spec
 %endif
 
 %define                orgname php
-%define                php_suffix 81
+%define                php_suffix 83
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
 Summary(pl.UTF-8):     Język skryptowy PHP
@@ -124,7 +124,7 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       8.1.7
+Version:       8.3.6
 Release:       1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
@@ -133,7 +133,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       https://php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: f8be7dfca5c241e780f75f3f3ce83b76
+# Source0-md5: 0b8809e3bbb7f00b90f775d28846197d
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
@@ -216,7 +216,7 @@ BuildRequires:      libxml2-devel >= 1:2.7.6-4
 %{?with_zip:BuildRequires:     libzip-devel >= 1.3.1}
 %{?with_snmp:%{?with_tests:BuildRequires:      mibs-net-snmp}}
 %{?with_mm:BuildRequires:      mm-devel >= 1.3.0}
-%{!?with_mysqli:BuildRequires: mysql-devel >= 4.1.13}
+%{!?with_mysqli:BuildRequires: mysql-devel}
 %{!?with_pdo_mysql:BuildRequires:      mysql-devel}
 %{?with_snmp:BuildRequires:    net-snmp-devel >= 5.3}
 BuildRequires: oniguruma-devel
@@ -257,9 +257,9 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _sysconfdir             %{php_sysconfdir}
 
 # must be in sync with source. extra check ensuring that it is so is done in %%build
-%define                php_api_version         20210902
-%define                zend_module_api         20210902
-%define                zend_extension_api      420210902
+%define                php_api_version         20230831
+%define                zend_module_api         20230831
+%define                zend_extension_api      420230831
 %define                php_pdo_api_version     20170320
 
 # Extension versions
@@ -271,7 +271,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                jsonver         %{version}
 %define                pharver         %{version}
 %define                sqlite3ver      %{version}
-%define                zipver          1.19.5
+%define                zipver          1.22.3
 %define                phpdbgver       %{version}
 %define                sodiumver       %{version}
 
@@ -512,6 +512,7 @@ Provides:   %{name}-standard
 Provides:      php(core) = %{version}
 Provides:      php(date)
 Provides:      php(hash) = %{hashver}
+Provides:      php(json)
 Provides:      php(libxml)
 Provides:      php(pcre)
 Provides:      php(reflection)
@@ -1027,7 +1028,7 @@ URL:              http://php.net/manual/en/book.mysqli.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 %{?with_mysqlnd:Requires:      %{name}-mysqlnd = %{epoch}:%{version}-%{release}}
 Requires:      %{name}-spl = %{epoch}:%{version}-%{release}
-Requires:      mysql-libs >= 4.1.13
+Requires:      mysql-libs
 Provides:      php(mysqli)
 Obsoletes:     php-mysqli < 4:5.3.28-7
 
@@ -1818,7 +1819,7 @@ cp -p php.ini-production php.ini
 #%patch68 -p1 DROP or update to 7.0 APIs
 %patch71 -p1
 
-sed -E -i -e '1s,#!\s*/usr/bin/env\s+(.*),#!%{__bindir}\1,' \
+sed -E -i -e '1s,#!\s*/usr/bin/env\s+(.*),#!%{_bindir}/\1%{php_suffix},' \
       ext/ext_skel.php \
       run-tests.php
 
@@ -2452,7 +2453,7 @@ cp -a tests/* $RPM_BUILD_ROOT%{php_data_dir}/tests/php
 # fix install paths, avoid evil rpaths
 sed -i -e "s|^libdir=.*|libdir='%{_libdir}'|" $RPM_BUILD_ROOT%{_libdir}/libphp_common%{php_suffix}.la
 
-install -p ext/ext_skel.php $RPM_BUILD_ROOT%{_bindir}
+install -p ext/ext_skel.php $RPM_BUILD_ROOT%{_bindir}/ext_skel%{php_suffix}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -2470,7 +2471,7 @@ fi
 %post cli
 update-alternatives \
        --install %{_bindir}/php php %{_bindir}/php%{php_suffix} %{php_suffix} \
-       --slave %{_mandir}/man1/php.1 php.1 %{_mandir}/man1/php%{php_suffix}.1* || :
+       --slave %{_mandir}/man1/php.1.gz php.1.gz %{_mandir}/man1/php%{php_suffix}.1.gz || :
 
 %postun cli
 if [ $1 -eq 0 ]; then
@@ -2483,10 +2484,12 @@ fi
 %post devel
 update-alternatives \
        --install %{_bindir}/phpize phpize %{_bindir}/phpize%{php_suffix} %{php_suffix} \
-       --slave %{_mandir}/man1/php.1 php.1 %{_mandir}/man1/php%{php_suffix}.1* || :
+       --slave %{_mandir}/man1/phpize.1.gz phpize.1.gz %{_mandir}/man1/phpize%{php_suffix}.1.gz || :
 update-alternatives \
        --install %{_bindir}/php-config php-config %{_bindir}/php-config%{php_suffix} %{php_suffix} \
-       --slave %{_mandir}/man1/php.1 php.1 %{_mandir}/man1/php%{php_suffix}.1* || :
+       --slave %{_mandir}/man1/php-config.1.gz php-config.1.gz %{_mandir}/man1/php-config%{php_suffix}.1.gz || :
+update-alternatives \
+       --install %{_bindir}/ext_skel ext_skel %{_bindir}/ext_skel%{php_suffix} %{php_suffix} || :
 
 %postun devel
 if [ $1 -eq 0 ]; then
@@ -2500,7 +2503,9 @@ fi
 %post fpm
 /sbin/chkconfig --add %{name}-fpm
 %service %{name}-fpm restart
-update-alternatives --install %{_sbindir}/php-fpm php-fpm %{_sbindir}/php%{php_suffix}-fpm %{php_suffix} || :
+update-alternatives \
+       --install %{_sbindir}/php-fpm php-fpm %{_sbindir}/php%{php_suffix}-fpm %{php_suffix} \
+       --slave %{_mandir}/man8/php-fpm.8.gz php-fpm.8.gz %{_mandir}/man8/php-fpm%{php_suffix}.8.gz || :
 
 %preun fpm
 if [ "$1" = "0" ]; then
@@ -2655,7 +2660,7 @@ fi \
 %ext_post
 update-alternatives \
        --install %{_bindir}/phar phar %{_bindir}/phar%{php_suffix}.phar %{php_suffix} \
-       --slave %{_mandir}/man1/phar.1 phar.1 %{_mandir}/man1/phar%{php_suffix}.1* || :
+       --slave %{_mandir}/man1/phar.1.gz phar.1.gz %{_mandir}/man1/phar%{php_suffix}.1.gz || :
 
 %postun phar
 %ext_postun
@@ -2742,7 +2747,7 @@ fi
 %files devel
 %defattr(644,root,root,755)
 %doc CODING_STANDARDS.md docs/*.md
-%attr(755,root,root) %{_bindir}/ext_skel.php
+%attr(755,root,root) %{_bindir}/ext_skel%{php_suffix}
 %attr(755,root,root) %{_bindir}/phpize%{php_suffix}
 %attr(755,root,root) %{_bindir}/php-config%{php_suffix}
 %ghost %{_bindir}/phpize