]> TLD Linux GIT Repositories - packages/php.git/blobdiff - php.spec
- updated to 7.2.11
[packages/php.git] / php.spec
index fba965f0f8d859d47a177955767fd464281d9df1..9f75f3105ac1ff5d179f651072a101f354436c40 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -1,4 +1,4 @@
-# NOTES
+# NOTES 
 # - mysqlnd driver doesn't support reconnect: https://bugs.php.net/bug.php?id=52561
 # TODO 7.2:
 # - https://github.com/php/php-src/blob/php-7.2.0/UPGRADING
@@ -146,7 +146,7 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 7 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       7.2.1
+Version:       7.2.11
 Release:       1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
@@ -155,7 +155,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       http://php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: f8682afff613f7e4661c77f122e4dbfd
+# Source0-md5: 28c3d5310a64799fd54c5e49e4982cf9
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
@@ -306,7 +306,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                jsonver         1.6.0
 %define                pharver         2.0.2
 %define                sqlite3ver      %{version}
-%define                zipver          1.15.1
+%define                zipver          1.15.3
 %define                phpdbgver       0.5.0
 %define                sodiumver       %{version}
 
@@ -2587,6 +2587,7 @@ cp -p sapi/embed/php_embed.h $RPM_BUILD_ROOT%{_includedir}/php/php%{php_suffix}/
 %endif
 
 # CLI
+libtool --mode=install install -p sapi/cli/php $RPM_BUILD_ROOT%{_bindir}/php%{php_suffix}
 # touch for ghost
 touch $RPM_BUILD_ROOT%{_bindir}/php
 touch $RPM_BUILD_ROOT%{_mandir}/man1/php.1
@@ -2666,9 +2667,12 @@ update-alternatives \
 
 %postun cli
 if [ $1 -eq 0 ]; then
-       update-alternatives --remove php %{_bindir}/php || :
+       update-alternatives --remove php %{_bindir}/php%{php_suffix} || :
 fi
 
+%post  common -p /sbin/ldconfig
+%postun        common -p /sbin/ldconfig
+
 %post devel
 update-alternatives \
        --install %{_bindir}/phpize phpize %{_bindir}/phpize%{php_suffix} %{php_suffix} \
@@ -2679,8 +2683,8 @@ update-alternatives \
 
 %postun devel
 if [ $1 -eq 0 ]; then
-       update-alternatives --remove phpize %{_bindir}/phpize || :
-       update-alternatives --remove php-config %{_bindir}/php-config || :
+       update-alternatives --remove phpize %{_bindir}/phpize%{php_suffix} || :
+       update-alternatives --remove php-config %{_bindir}/php-config%{php_suffix} || :
 fi
 
 %pre fpm
@@ -2695,7 +2699,7 @@ update-alternatives --install %{_sbindir}/php-fpm php-fpm %{_sbindir}/php%{php_s
 if [ "$1" = "0" ]; then
        %service %{name}-fpm stop
        /sbin/chkconfig --del %{name}-fpm
-       update-alternatives --remove php-fpm %{_sbindir}/php-fpm || :
+       update-alternatives --remove php-fpm %{_sbindir}/php%{php_suffix}-fpm || :
 fi
 
 %postun fpm
@@ -2858,7 +2862,7 @@ update-alternatives \
 %postun phar
 %ext_postun
 if [ $1 -eq 0 ]; then
-       update-alternatives --remove phar %{_bindir}/phar || :
+       update-alternatives --remove phar %{_bindir}/phar%{php_suffix}.phar || :
 fi
 
 %if %{with apache2}