]> TLD Linux GIT Repositories - packages/php.git/blobdiff - php.spec
- updated to 7.3.33
[packages/php.git] / php.spec
index a3cda00526ad983f050ca1aaec6f1a18f0754304..aed6d21f9f50d9a0f5a78480c2c7b6f4bc50b7a1 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -119,7 +119,7 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 7 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       7.3.12
+Version:       7.3.33
 Release:       1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
@@ -128,7 +128,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       http://php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: e52a0dc6e7d94024989d0a3746070487
+# Source0-md5: eeabb2140c04da85c86389197421f890
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
@@ -258,7 +258,7 @@ BuildRequires:      apr-util-devel >= 1:1.0.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                php_sysconfdir          /etc/%{name}
-%define                php_extensiondir        %{_libdir}/%{name}
+%define                php_extensiondir        %{_libdir}/php/%{name}
 %define                php_datadir             /usr/share/php/%{name}
 %define                _sysconfdir             %{php_sysconfdir}
 
@@ -347,21 +347,34 @@ PHP - це мова написання скриптів, що вбудовуют
 використання PHP - заміна для CGI скриптів.
 
 %package -n apache-mod_%{name}
-Summary:       PHP DSO module for Apache 2.x
-Summary(pl.UTF-8):     Moduł DSO (Dynamic Shared Object) PHP dla Apache 2.x
+Summary:       PHP support for Apache 2.x
+Summary(pl.UTF-8):     Wsparcie PHP dla Apache 2.x
 Group:         Development/Languages/PHP
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-Requires:      apache(modules-api) = %{apache_modules_api}
-Requires:      apache-mod_mime
+Requires:      apache-mod_%{name}-core = %{epoch}:%{version}-%{release}
 Provides:      webserver(php) = %{version}
 Obsoletes:     apache-mod_php < 4:5.3.28-7
 Obsoletes:     phpfi
 
 %description -n apache-mod_%{name}
-PHP as DSO module for Apache 2.x.
+PHP support for Apache 2.x.
 
 %description -n apache-mod_%{name} -l pl.UTF-8
-PHP jako moduł DSO (Dynamic Shared Object) dla Apache 2.x.
+Wsparcie PHP dla Apache 2.x.
+
+%package -n apache-mod_%{name}-core
+Summary:       PHP DSO module for Apache 2.x
+Summary(pl.UTF-8):     ModuÅ‚ DSO (Dynamic Shared Object) PHP dla Apache 2.x
+Group:         Development/Languages/PHP
+Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Requires:      apache(modules-api) = %{apache_modules_api}
+Requires:      apache-mod_mime
+
+%description -n apache-mod_%{name}-core
+PHP as DSO module for Apache 2.x.
+
+%description -n apache-mod_%{name}-core -l pl.UTF-8
+PHP jako moduÅ‚ DSO (Dynamic Shared Object) dla Apache 2.x.
 
 %package litespeed
 Summary:       PHP for litespeed HTTP server
@@ -548,7 +561,6 @@ Requires:   libtool >= 2:2.4.6
 %{?with_pcre:Requires: pcre2-8-devel >= 10.30}
 Requires:      shtool
 Provides:      php-devel = %{epoch}:%{version}-%{release}
-Obsoletes:     php-devel
 Obsoletes:     php-pear-devel
 Obsoletes:     php4-devel
 Obsoletes:     php52-devel
@@ -2040,11 +2052,6 @@ ix86=: x8664=: \
        sh -xe %{_sourcedir}/skip-tests.sh
 
 %build
-get_version() {
-       local define="$1" filename="$2"
-       awk -vdefine="$define" '/#define/ && $2 == define {print $3}' "$filename" | xargs
-}
-
 API=$(awk '/#define PHP_API_VERSION/{print $3}' main/php.h)
 if [ $API != %{php_api_version} ]; then
        echo "Set %%define php_api_version to $API and re-run."
@@ -2076,7 +2083,7 @@ if test "$ver" != "PHP_VERSION"; then
        : Update the fileinfover macro and rebuild.
        exit 1
 fi
-ver=$(get_version PHP_PHAR_VERSION ext/phar/php_phar.h)
+ver=$(awk '/#define PHP_PHAR_VERSION/ {print $3}' ext/phar/php_phar.h | xargs)
 if test "$ver" != "PHP_VERSION"; then
        : Error: Upstream PHAR version is now ${ver}, expecting %{pharver}.
        : Update the pharver macro and rebuild.
@@ -2110,7 +2117,7 @@ if test "$ver" != "%{phpdbgver}"; then
        : Update the phpdbgver macro and rebuild.
        exit 1
 fi
-ver=$(get_version PHP_BZ2_VERSION ext/bz2/php_bz2.h)
+ver=$(awk '/#define PHP_BZ2_VERSION/ {print $3}' ext/bz2/php_bz2.h | xargs)
 if test "$ver" != "PHP_VERSION"; then
        : Error: Upstream BZIP2 version is now ${ver}, expecting %{bz2ver}.
        : Update the bz2ver macro and rebuild.
@@ -2120,13 +2127,13 @@ ver=$(awk '/#define PHP_ENCHANT_VERSION/ {print $3}' ext/enchant/php_enchant.h |
 if test "$ver" != "PHP_VERSION"; then
        exit 1
 fi
-ver=$(get_version PHP_HASH_VERSION ext/hash/php_hash.h)
+ver=$(awk '/#define PHP_HASH_VERSION/ {print $3}' ext/hash/php_hash.h | xargs)
 if test "$ver" != "PHP_VERSION"; then
        : Error: Upstream HASH version is now ${ver}, expecting %{hashver}.
        : Update the hashver macro and rebuild.
        exit 1
 fi
-ver=$(get_version PHP_INTL_VERSION ext/intl/php_intl.h)
+ver=$(awk '/#define PHP_INTL_VERSION/ {print $3}' ext/intl/php_intl.h | xargs)
 if test "$ver" != "PHP_VERSION"; then
        : Error: Upstream Intl version is now ${ver}, expecting %{intlver}.
        : Update the intlver macro and rebuild.
@@ -2480,7 +2487,7 @@ install -d $RPM_BUILD_ROOT{%{_libdir}/{php,apache{,1}},%{_sysconfdir}/{apache,cg
 cp -pf php_config.h.cli main/php_config.h
 cp -pf Makefile.cli Makefile
 %{__make} install \
-       phpbuilddir=%{_libdir}/%{name}/build \
+       phpbuilddir=%{_libdir}/php/php%{php_suffix}/build \
        INSTALL_ROOT=$RPM_BUILD_ROOT
 
 # version the .phar files
@@ -2605,17 +2612,17 @@ install -d $RPM_BUILD_ROOT%{_sysconfdir}/{cgi-fcgi,cli,apache,apache2handler}.d
 %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/{conf.d/readline.ini,cli.d}
 
 # use system automake and {lib,sh}tool
-ln -snf /usr/share/automake/config.{guess,sub} $RPM_BUILD_ROOT%{_libdir}/%{name}/build
-ln -snf %{_bindir}/shtool $RPM_BUILD_ROOT%{_libdir}/%{name}/build
+ln -snf /usr/share/automake/config.{guess,sub} $RPM_BUILD_ROOT%{_libdir}/php/php%{php_suffix}/build
+ln -snf %{_bindir}/shtool $RPM_BUILD_ROOT%{_libdir}/php/php%{php_suffix}/build
 for fn in libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4; do
        f=%{_aclocaldir}/$fn
        test -f $f || continue
-       ln -snf $f $RPM_BUILD_ROOT%{_libdir}/%{name}/build
+       ln -snf $f $RPM_BUILD_ROOT%{_libdir}/php/php%{php_suffix}/build
 done
 for fn in ltmain.sh config/ltmain.sh build-aux/ltmain.sh; do
        f=/usr/share/libtool/$fn
        test -f $f || continue
-       ln -snf $f $RPM_BUILD_ROOT%{_libdir}/%{name}/build
+       ln -snf $f $RPM_BUILD_ROOT%{_libdir}/php/php%{php_suffix}/build
        break
 done
 sed -i -e '/^phpdir/ s,/php/build,/%{name}/build,' $RPM_BUILD_ROOT%{_bindir}/phpize%{php_suffix}
@@ -2632,7 +2639,7 @@ cp -a tests/* $RPM_BUILD_ROOT%{php_datadir}/tests/php
 # fix install paths, avoid evil rpaths
 sed -i -e "s|^libdir=.*|libdir='%{_libdir}'|" $RPM_BUILD_ROOT%{_libdir}/libphp_common%{php_suffix}.la
 # better solution?
-sed -i -e 's|libphp_common.la|$(libdir)/libphp_common%{php_suffix}.la|' $RPM_BUILD_ROOT%{_libdir}/%{name}/build/acinclude.m4
+sed -i -e 's|libphp_common.la|$(libdir)/libphp_common%{php_suffix}.la|' $RPM_BUILD_ROOT%{_libdir}/php/php%{php_suffix}/build/acinclude.m4
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -2856,9 +2863,12 @@ fi
 %files -n apache-mod_%{name}
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/httpd/conf.d/*_mod_php.conf
+%attr(755,root,root) %{_libdir}/apache/mod_php.so
+
+%files -n apache-mod_%{name}-core
+%defattr(644,root,root,755)
 %dir %{_sysconfdir}/apache2handler.d
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php-apache2handler.ini
-%attr(755,root,root) %{_libdir}/apache/mod_php.so
 %attr(755,root,root) %{_libdir}/apache/libphp%{php_suffix}.so
 %endif
 
@@ -2941,7 +2951,7 @@ fi
 %attr(755,root,root) %{_libdir}/libphp_common%{php_suffix}.so
 %{_libdir}/libphp_common%{php_suffix}.la
 %{_includedir}/php/php%{php_suffix}
-%{_libdir}/%{name}/build
+%{_libdir}/php/php%{php_suffix}/build
 %{_mandir}/man1/php-config%{php_suffix}.1*
 %ghost %{_mandir}/man1/php-config.1*
 %{_mandir}/man1/phpize%{php_suffix}.1*