]> TLD Linux GIT Repositories - packages/php.git/blobdiff - php.spec
- Up to 8.3.7
[packages/php.git] / php.spec
index 15cd0bb194b41364fa7478d3556e6180456acef1..bc3e64d6a2352364ad1770d3e69cfc70e71d7a81 100644 (file)
--- a/php.spec
+++ b/php.spec
 %endif
 
 %define                orgname php
-%define                php_suffix 82
+%define                php_suffix 83
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
 Summary(pl.UTF-8):     Język skryptowy PHP
@@ -124,8 +124,8 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       8.2.2
-Release:       2
+Version:       8.3.7
+Release:       1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
@@ -133,7 +133,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       https://php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: fa93816863003f4908f638a3fd7757ac
+# Source0-md5: 81986a54500ebc40d1f911112682e0e1
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
@@ -216,7 +216,7 @@ BuildRequires:      libxml2-devel >= 1:2.7.6-4
 %{?with_zip:BuildRequires:     libzip-devel >= 1.3.1}
 %{?with_snmp:%{?with_tests:BuildRequires:      mibs-net-snmp}}
 %{?with_mm:BuildRequires:      mm-devel >= 1.3.0}
-%{!?with_mysqli:BuildRequires: mysql-devel >= 4.1.13}
+%{!?with_mysqli:BuildRequires: mysql-devel}
 %{!?with_pdo_mysql:BuildRequires:      mysql-devel}
 %{?with_snmp:BuildRequires:    net-snmp-devel >= 5.3}
 BuildRequires: oniguruma-devel
@@ -257,9 +257,9 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _sysconfdir             %{php_sysconfdir}
 
 # must be in sync with source. extra check ensuring that it is so is done in %%build
-%define                php_api_version         20220829
-%define                zend_module_api         20220829
-%define                zend_extension_api      420220829
+%define                php_api_version         20230831
+%define                zend_module_api         20230831
+%define                zend_extension_api      420230831
 %define                php_pdo_api_version     20170320
 
 # Extension versions
@@ -271,7 +271,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                jsonver         %{version}
 %define                pharver         %{version}
 %define                sqlite3ver      %{version}
-%define                zipver          1.21.1
+%define                zipver          1.22.3
 %define                phpdbgver       %{version}
 %define                sodiumver       %{version}
 
@@ -1028,7 +1028,7 @@ URL:              http://php.net/manual/en/book.mysqli.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 %{?with_mysqlnd:Requires:      %{name}-mysqlnd = %{epoch}:%{version}-%{release}}
 Requires:      %{name}-spl = %{epoch}:%{version}-%{release}
-Requires:      mysql-libs >= 4.1.13
+Requires:      mysql-libs
 Provides:      php(mysqli)
 Obsoletes:     php-mysqli < 4:5.3.28-7
 
@@ -2039,11 +2039,6 @@ export CPPFLAGS="-DDEBUG_FASTCGI -DHAVE_STRNDUP %{rpmcppflags}"
 export CXXFLAGS="%{rpmcxxflags} -fPIC -DPIC"
 export CFLAGS="%{rpmcflags} -fPIC -DPIC"
 
-%if %{with intl}
-# icu 59+ C++ API requires C++ >= 11
-CXXFLAGS="$CXXFLAGS -std=c++11"
-%endif
-
 sapis="
 cli
 %if %{with cgi}