]> TLD Linux GIT Repositories - packages/php.git/blobdiff - php.spec
- updated to 5.6.40
[packages/php.git] / php.spec
index 9e9370a1d63389dfc5fa3b508989ded3402a7abd..f32db3a9cb6aaf1efc98c5924badc341c7aa82be 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -148,7 +148,7 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 5 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       5.6.35
+Version:       5.6.40
 Release:       1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
@@ -157,7 +157,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: 50afbbc745ad433b9f368c5885bd73bf
+# Source0-md5: c7dde3afb16ce7b761abf2805125d372
 Source2:       %{orgname}-mod_%{orgname}.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
@@ -266,7 +266,6 @@ BuildRequires:      openssl-devel >= 0.9.7d
 BuildRequires: pam-devel
 %{?with_pcre:BuildRequires:    pcre-devel >= 8.10}
 BuildRequires: pkgconfig
-%{?with_pgsql:BuildRequires:   postgresql-backend-devel >= 7.2}
 %{?with_pgsql:BuildRequires:   postgresql-devel}
 BuildRequires: readline-devel
 %{?with_recode:BuildRequires:  recode-devel >= 3.5d-3}
@@ -2748,7 +2747,7 @@ update-alternatives \
 
 %postun cli
 if [ $1 -eq 0 ]; then
-       update-alternatives --remove php %{_bindir}/php || :
+       update-alternatives --remove php %{_bindir}/php%{php_suffix} || :
 fi
 
 %post  common -p /sbin/ldconfig
@@ -2764,8 +2763,8 @@ update-alternatives \
 
 %postun devel
 if [ $1 -eq 0 ]; then
-       update-alternatives --remove phpize %{_bindir}/phpize || :
-       update-alternatives --remove php-config %{_bindir}/php-config || :
+       update-alternatives --remove phpize %{_bindir}/phpize%{php_suffix} || :
+       update-alternatives --remove php-config %{_bindir}/php-config%{php_suffix} || :
 fi
 
 %pre fpm
@@ -2780,7 +2779,7 @@ update-alternatives --install %{_sbindir}/php-fpm php-fpm %{_sbindir}/php%{php_s
 if [ "$1" = "0" ]; then
        %service %{name}-fpm stop
        /sbin/chkconfig --del %{name}-fpm
-       update-alternatives --remove php-fpm %{_sbindir}/php-fpm || :
+       update-alternatives --remove php-fpm %{_sbindir}/php%{php_suffix}-fpm || :
 fi
 
 %postun fpm
@@ -2946,7 +2945,7 @@ update-alternatives \
 %postun phar
 %ext_postun
 if [ $1 -eq 0 ]; then
-       update-alternatives --remove phar %{_bindir}/phar || :
+       update-alternatives --remove phar %{_bindir}/phar%{php_suffix}.phar || :
 fi
 
 %if %{with apache2}