]> TLD Linux GIT Repositories - packages/php.git/blobdiff - php.spec
- updated to 5.5.17
[packages/php.git] / php.spec
index 0b6df42659f6ad70b2d1b3facb220f24fb10d1fc..fa07c4eab72ebe27a895738543b132ab5821d391 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -42,7 +42,8 @@
 # Reflection
 #
 # Conditional build:
-%bcond_without default_php     # use this PHP as default PHP in distro
+
+%bcond_with    default_php     # use this PHP as default PHP in distro
 %bcond_with    interbase_inst  # use InterBase install., not Firebird  (BR: proprietary libs)
 %bcond_with    oci8            # with Oracle oci8 extension module     (BR: proprietary libs)
 %bcond_with    instantclient   # build Oracle oci8 extension module against oracle-instantclient package
@@ -139,13 +140,13 @@ Summary(pt_BR.UTF-8):     A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 5 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       5.5.3
+Version:       5.5.17
 Release:       %{rel}%{?with_type_hints:.th}%{?with_oci8:.oci}
 Epoch:         4
 License:       PHP
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{orgname}-%{version}.tar.bz2
-# Source0-md5: 886b08ee6865d654911a6bb02ae98ee8
+# Source0-md5: b36c1eb5c40b872517b35d65bd840316
 Source2:       %{orgname}-mod_%{orgname}.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
@@ -165,7 +166,6 @@ Patch4:             %{orgname}-libpq_fs_h_path.patch
 Patch5:                %{orgname}-filter-shared.patch
 Patch6:                %{orgname}-build_modules.patch
 Patch7:                %{orgname}-sapi-ini-file.patch
-Patch8:                %{orgname}-config-file-scan-dir.patch
 Patch9:                %{orgname}-sh.patch
 Patch10:       %{orgname}-ini.patch
 Patch11:       embed.patch
@@ -311,12 +311,12 @@ BuildRoot:        %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # Extension versions
 %define                bz2ver          1.0
 %define                enchantver      1.1.0
-%define                fileinfover     1.0.5-dev
+%define                fileinfover     1.0.5
 %define                hashver         1.0
 %define                intlver         1.1.0
 %define                jsonver         1.2.1
-%define                opcachever      7.0.3-dev
-%define                pharver         2.0.1
+%define                opcachever      7.0.4-dev
+%define                pharver         2.0.2
 %define                sqlite3ver      0.7-dev
 %define                zipver          1.11.0
 
@@ -563,6 +563,8 @@ Obsoletes:  php-devel
 Obsoletes:     php-pear-devel
 Obsoletes:     php4-devel
 Obsoletes:     php52-devel
+Obsoletes:     php53-devel
+Obsoletes:     php54-devel
 
 %description devel
 The php-devel package lets you compile dynamic extensions to PHP.
@@ -1873,7 +1875,6 @@ Moduł PHP umożliwiający używanie kompresji zlib.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
-%patch8 -p1
 %patch7 -p1
 %patch9 -p1
 cp -p php.ini-production php.ini
@@ -2053,7 +2054,7 @@ if test "$ver" != "%{jsonver}"; then
        : Update the jsonver macro and rebuild.
        exit 1
 fi
-ver=$(sed -n '/#define ACCELERATOR_VERSION /{s/.* "//;s/".*$//;p}' ext/opcache/ZendAccelerator.h)
+ver=$(sed -n '/#define PHP_ZENDOPCACHE_VERSION /{s/.* "//;s/".*$//;p}' ext/opcache/ZendAccelerator.h)
 if test "$ver" != "%{opcachever}"; then
        : Error: Upstream Zend Opcachge version is now ${ver}, expecting %{opcachever}.
        : Update the opcachever macro and rebuild.