]> TLD Linux GIT Repositories - packages/php.git/commitdiff
- PHP 5.6.6
authorBartosz Świątek <shadzik@tld-linux.org>
Tue, 24 Feb 2015 11:43:04 +0000 (12:43 +0100)
committerBartosz Świątek <shadzik@tld-linux.org>
Tue, 24 Feb 2015 11:43:04 +0000 (12:43 +0100)
php-fcgi-error_log-no-newlines.patch
php.spec

index e35648e84bfea474782e67f04731ac581a0439df..321452f97514890793464c640e7697a9b99d0646 100644 (file)
@@ -1,16 +1,14 @@
---- ./sapi/cgi/cgi_main.c~     2007-08-09 02:51:57.000000000 +0300
-+++ ./sapi/cgi/cgi_main.c      2007-09-05 20:54:19.390089070 +0300
-@@ -558,12 +558,7 @@
-               request = (fcgi_request*) SG(server_context);
-               if (request) {                  
-                       int len = strlen(message);
--                      char *buf = malloc(len+2);
--
+--- php-5.6.6/sapi/cgi/cgi_main.c.orig 2015-02-24 12:35:21.097436930 +0100
++++ php-5.6.6/sapi/cgi/cgi_main.c      2015-02-24 12:38:49.851431030 +0100
+@@ -739,10 +739,7 @@
+                       int ret, len = strlen(message);
+                       char *buf = malloc(len+2);
 -                      memcpy(buf, message, len);
 -                      memcpy(buf + len, "\n", sizeof("\n"));
--                      fcgi_write(request, FCGI_STDERR, buf, len+1);
+-                      ret = fcgi_write(request, FCGI_STDERR, buf, len + 1);
 -                      free(buf);
 +                      fcgi_write(request, FCGI_STDERR, message, len);
-               } else {
-                       fprintf(stderr, "%s\n", message);
-               }
+                       if (ret < 0) {
+                               php_handle_aborted_connection();
+                       }
index 1dc68ed3d7ca0d7b0d1a600d288da431e189409e..45b25191837284f318617729a7266c4137d20cfc 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -133,7 +133,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define                rel     2
+%define                rel     1
 %define                orgname php
 %define                ver_suffix 56
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -144,13 +144,13 @@ Summary(pt_BR.UTF-8):     A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 5 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       5.6.5
+Version:       5.6.6
 Release:       %{rel}%{?with_type_hints:.th}
 Epoch:         4
 License:       PHP
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: 541a480e1f8747219074c99f3e9edbcc
+# Source0-md5: ed0c9ad2419fffde1d8c03a2d8164179
 Source2:       %{orgname}-mod_%{orgname}.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini