]> TLD Linux GIT Repositories - packages/php.git/commitdiff
- updated to 7.4.9
authorMarcin Krol <hawk@tld-linux.org>
Thu, 6 Aug 2020 12:02:24 +0000 (14:02 +0200)
committerMarcin Krol <hawk@tld-linux.org>
Thu, 6 Aug 2020 12:02:24 +0000 (14:02 +0200)
bug-52078-fileinode.patch [deleted file]
php.spec

diff --git a/bug-52078-fileinode.patch b/bug-52078-fileinode.patch
deleted file mode 100644 (file)
index 419be68..0000000
+++ /dev/null
@@ -1,370 +0,0 @@
---- php-5.3.3/ext/standard/tests/file/fileinode_basic.phpt~    2007-11-05 19:43:21.000000000 +0200
-+++ php-5.3.3/ext/standard/tests/file/fileinode_basic.phpt     2010-07-26 19:31:43.613553760 +0300
-@@ -28,9 +28,9 @@
- ?>
- --EXPECTF--
- *** Testing fileinode() with file, directory ***
--%d
--%d
--%d
--%d
-+%i
-+%i
-+%i
-+%i
- *** Done ***
---- php-5.3.3/ext/standard/tests/file/fileinode_variation.phpt~        2007-11-05 19:43:21.000000000 +0200
-+++ php-5.3.3/ext/standard/tests/file/fileinode_variation.phpt 2010-07-26 19:34:01.610414378 +0300
-@@ -89,24 +89,24 @@
- --EXPECTF--
- *** Testing fileinode() with files, links and directories ***
- -- Testing with files --
--%d
--%d
-+%i
-+%i
- -- Testing with links: hard link --
--%d
--%d
-+%i
-+%i
- -- Testing with links: soft link --
--%d
--%d
-+%i
-+%i
- -- Testing after copying a file --
--%d
--%d
-+%i
-+%i
- -- Testing after renaming the file --
--%d
--%d
-+%i
-+%i
- -- Testing with directories --
--%d
--%d
-+%i
-+%i
- -- Testing with binary input --
--%d
--%d
-+%i
-+%i
- *** Done ***
---- php-5.3.3/ext/standard/tests/file/fileinode_variation1.phpt~       2008-11-26 12:10:19.000000000 +0200
-+++ php-5.3.3/ext/standard/tests/file/fileinode_variation1.phpt        2010-07-26 19:35:31.216291870 +0300
-@@ -42,7 +42,7 @@
- --EXPECTF--
- *** Testing fileinode() with links ***
--int(%d)
--int(%d)
-+int(%i)
-+int(%i)
- *** Done ***
---- php-5.3.3/ext/standard/tests/file/filestat.phpt~   2006-11-15 19:27:03.000000000 +0200
-+++ php-5.3.3/ext/standard/tests/file/filestat.phpt    2010-07-26 19:37:10.367060798 +0300
-@@ -30,17 +30,17 @@
- echo "Done\n";
- ?>
- --EXPECTF--
-+int(%i)
- int(%d)
- int(%d)
- int(%d)
- int(%d)
-+int(%i)
- int(%d)
- int(%d)
- int(%d)
- int(%d)
--int(%d)
--int(%d)
--int(%d)
-+int(%i)
- int(%d)
- int(%d)
- int(%d)
---- php-5.3.3/ext/standard/tests/file/lstat_stat_variation18.phpt~     2010-07-26 19:43:12.000000000 +0300
-+++ php-5.3.3/ext/standard/tests/file/lstat_stat_variation18.phpt      2010-07-26 19:43:14.470984630 +0300
-@@ -66,7 +66,7 @@
-   [0]=>
-   int(%d)
-   [1]=>
--  int(%d)
-+  int(%i)
-   [2]=>
-   int(%d)
-   [3]=>
-@@ -92,7 +92,7 @@
-   ["dev"]=>
-   int(%d)
-   ["ino"]=>
--  int(%d)
-+  int(%i)
-   ["mode"]=>
-   int(%d)
-   ["nlink"]=>
-@@ -122,7 +122,7 @@
-   [0]=>
-   int(%d)
-   [1]=>
--  int(%d)
-+  int(%i)
-   [2]=>
-   int(%d)
-   [3]=>
-@@ -148,7 +148,7 @@
-   ["dev"]=>
-   int(%d)
-   ["ino"]=>
--  int(%d)
-+  int(%i)
-   ["mode"]=>
-   int(%d)
-   ["nlink"]=>
---- php-5.3.3/ext/standard/tests/file/lstat_stat_variation19.phpt~     2007-11-05 19:43:21.000000000 +0200
-+++ php-5.3.3/ext/standard/tests/file/lstat_stat_variation19.phpt      2010-07-26 19:44:58.320079730 +0300
-@@ -67,7 +67,7 @@
-   [0]=>
-   int(%d)
-   [1]=>
--  int(%d)
-+  int(%i)
-   [2]=>
-   int(%d)
-   [3]=>
-@@ -93,7 +93,7 @@
-   ["dev"]=>
-   int(%d)
-   ["ino"]=>
--  int(%d)
-+  int(%i)
-   ["mode"]=>
-   int(%d)
-   ["nlink"]=>
-@@ -121,7 +121,7 @@
-   [0]=>
-   int(%d)
-   [1]=>
--  int(%d)
-+  int(%i)
-   [2]=>
-   int(%d)
-   [3]=>
-@@ -147,7 +147,7 @@
-   ["dev"]=>
-   int(%d)
-   ["ino"]=>
--  int(%d)
-+  int(%i)
-   ["mode"]=>
-   int(%d)
-   ["nlink"]=>
-@@ -177,7 +177,7 @@
-   [0]=>
-   int(%d)
-   [1]=>
--  int(%d)
-+  int(%i)
-   [2]=>
-   int(%d)
-   [3]=>
-@@ -203,7 +203,7 @@
-   ["dev"]=>
-   int(%d)
-   ["ino"]=>
--  int(%d)
-+  int(%i)
-   ["mode"]=>
-   int(%d)
-   ["nlink"]=>
-@@ -231,7 +231,7 @@
-   [0]=>
-   int(%d)
-   [1]=>
--  int(%d)
-+  int(%i)
-   [2]=>
-   int(%d)
-   [3]=>
-@@ -257,7 +257,7 @@
-   ["dev"]=>
-   int(%d)
-   ["ino"]=>
--  int(%d)
-+  int(%i)
-   ["mode"]=>
-   int(%d)
-   ["nlink"]=>
---- php-5.3.3/ext/standard/tests/file/lstat_stat_variation20.phpt~     2007-07-26 16:38:24.000000000 +0300
-+++ php-5.3.3/ext/standard/tests/file/lstat_stat_variation20.phpt      2010-07-26 19:46:33.907004377 +0300
-@@ -69,7 +69,7 @@
-   [0]=>
-   int(%d)
-   [1]=>
--  int(%d)
-+  int(%i)
-   [2]=>
-   int(%d)
-   [3]=>
-@@ -95,7 +95,7 @@
-   ["dev"]=>
-   int(%d)
-   ["ino"]=>
--  int(%d)
-+  int(%i)
-   ["mode"]=>
-   int(%d)
-   ["nlink"]=>
-@@ -125,7 +125,7 @@
-   [0]=>
-   int(%d)
-   [1]=>
--  int(%d)
-+  int(%i)
-   [2]=>
-   int(%d)
-   [3]=>
-@@ -151,7 +151,7 @@
-   ["dev"]=>
-   int(%d)
-   ["ino"]=>
--  int(%d)
-+  int(%i)
-   ["mode"]=>
-   int(%d)
-   ["nlink"]=>
-@@ -179,7 +179,7 @@
-   [0]=>
-   int(%d)
-   [1]=>
--  int(%d)
-+  int(%i)
-   [2]=>
-   int(%d)
-   [3]=>
-@@ -205,7 +205,7 @@
-   ["dev"]=>
-   int(%d)
-   ["ino"]=>
--  int(%d)
-+  int(%i)
-   ["mode"]=>
-   int(%d)
-   ["nlink"]=>
-@@ -233,7 +233,7 @@
-   [0]=>
-   int(%d)
-   [1]=>
--  int(%d)
-+  int(%i)
-   [2]=>
-   int(%d)
-   [3]=>
-@@ -259,7 +259,7 @@
-   ["dev"]=>
-   int(%d)
-   ["ino"]=>
--  int(%d)
-+  int(%i)
-   ["mode"]=>
-   int(%d)
-   ["nlink"]=>
---- php-5.3.3/ext/standard/tests/file/tempnam_variation1.phpt~ 2008-11-26 12:10:19.000000000 +0200
-+++ php-5.3.3/ext/standard/tests/file/tempnam_variation1.phpt  2010-07-26 20:24:46.505943227 +0300
-@@ -66,51 +66,51 @@
- -- Iteration 1 --
- File name is => %s%etempnam_variation1.tmp%s
- File permissions are => 100600
--File inode is => %d
-+File inode is => %i
- File created in => directory specified
- -- Iteration 2 --
- File name is => %s%etempnam_variation1.tmp%s
- File permissions are => 100600
--File inode is => %d
-+File inode is => %i
- File created in => directory specified
- -- Iteration 3 --
- File name is => %s%etempnam_variation1.tmp%s
- File permissions are => 100600
--File inode is => %d
-+File inode is => %i
- File created in => directory specified
- -- Iteration 4 --
- File name is => %s%etempnam_variation1.tmp%s
- File permissions are => 100600
--File inode is => %d
-+File inode is => %i
- File created in => directory specified
- -- Iteration 5 --
- File name is => %s%etempnam_variation1.tmp%s
- File permissions are => 100600
--File inode is => %d
-+File inode is => %i
- File created in => directory specified
- -- Iteration 6 --
- File name is => %s%etempnam_variation1.tmp%s
- File permissions are => 100600
--File inode is => %d
-+File inode is => %i
- File created in => directory specified
- -- Iteration 7 --
- File name is => %s%etempnam_variation1.tmp%s
- File permissions are => 100600
--File inode is => %d
-+File inode is => %i
- File created in => directory specified
- -- Iteration 8 --
- File name is => %s%etempnam_variation1.tmp%s
- File permissions are => 100600
--File inode is => %d
-+File inode is => %i
- File created in => directory specified
- -- Iteration 9 --
- File name is => %s%etempnam_variation1.tmp%s
- File permissions are => 100600
--File inode is => %d
-+File inode is => %i
- File created in => directory specified
- -- Iteration 10 --
- File name is => %s%etempnam_variation1.tmp%s
- File permissions are => 100600
--File inode is => %d
-+File inode is => %i
- File created in => directory specified
- *** Done ***
---- php-5.3.3/tests/security/open_basedir_fileinode.phpt~      2008-05-09 11:39:44.000000000 +0300
-+++ php-5.3.3/tests/security/open_basedir_fileinode.phpt       2010-07-27 22:51:29.603089549 +0300
-@@ -46,10 +46,10 @@
- Warning: fileinode(): open_basedir restriction in effect. File(./../.) is not within the allowed path(s): (.) in %s on line %d
- bool(false)
--int(%d)
--int(%d)
--int(%d)
--int(%d)
--int(%d)
-+int(%i)
-+int(%i)
-+int(%i)
-+int(%i)
-+int(%i)
- *** Finished testing open_basedir configuration [fileinode] ***
---- php-5.3.3/ext/spl/tests/SplFileInfo_getInode_basic.phpt~   2010-08-04 16:25:21.000000000 +0300
-+++ php-5.3.3/ext/spl/tests/SplFileInfo_getInode_basic.phpt    2010-08-04 16:28:32.722932851 +0300
-@@ -11,6 +11,7 @@
- --SKIPIF--
- <?php
- if (substr(PHP_OS, 0, 3) == 'WIN') die("skip this test not for Windows platforms");
-+if (PHP_INT_SIZE == 4) die("skip this test is for >32bit platform only (inodes overflow there)");
- ?>
- --FILE--
- <?php
index d002e4030e279c94abd32ea17a34c37fb00263b2..77d6b7c6a9a18b3b1242c12085714967844afd02 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -125,7 +125,7 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 7 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       7.4.7
+Version:       7.4.9
 Release:       1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
@@ -134,7 +134,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       http://php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: bba97ede87109a2bdaa164e7c2f8d229
+# Source0-md5: b623bef0da0b7c48477853ca50c989c5
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
@@ -172,7 +172,6 @@ Patch43:    %{orgname}-silent-session-cleanup.patch
 Patch44:       %{orgname}-include_path.patch
 Patch50:       extension-shared-optional-dep.patch
 Patch53:       fix-test-run.patch
-Patch55:       bug-52078-fileinode.patch
 Patch59:       %{orgname}-systzdata.patch
 Patch66:       php-db.patch
 Patch67:       mysql-lib-ver-mismatch.patch
@@ -1842,7 +1841,6 @@ cp -p php.ini-production php.ini
 %patch50 -p1
 %patch53 -p1
 %undos ext/spl/tests/SplFileInfo_getInode_basic.phpt
-%patch55 -p1
 %patch59 -p1 -b .systzdata
 %patch66 -p1
 %patch67 -p1