]> TLD Linux GIT Repositories - packages/poldek.git/blobdiff - poldek.spec
- 0.42.2 from PLD with rpm.org RPM support
[packages/poldek.git] / poldek.spec
index 4eee4cad3d4b91d335980961d954a324fcdd791d..55eae0510a0ede89a4522a0c99f9fae3b1af76bf 100644 (file)
@@ -6,52 +6,59 @@
 %bcond_with    static  # don't use shared libraries
 %bcond_without imode   # don't build interactive mode
 %bcond_without python  # don't build python bindings
+%bcond_with    tests   # tests
 
 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
-# NOTE: poldek links with "system db" (-ldb) anyway if it exists
-%define                db_pkg          db4.7
-%define                ver_db          4.7.25
-%define                ver_db_rel      1
-%define                ver_rpm         4.5-49
+%define                db_pkg          db
+%define                ver_db          5.3
+%define                ver_rpm         1:4.14
+%define                ver_db_devel    %(rpm -q --qf '%|E?{%{E}:}|%{V}-%{R}' --what-provides db-devel)
 
-%define                rel     8
 Summary:       RPM packages management helper tool
 Summary(hu.UTF-8):     RPM csomagkezelést segítő eszköz
 Summary(pl.UTF-8):     Pomocnicze narzędzie do zarządzania pakietami RPM
 Name:          poldek
-Version:       0.32.2
-Release:       %{rel}
+Version:       0.42.2
+Release:       3
 License:       GPL v2
 Group:         Applications/System
-Source0:       https://launchpad.net/poldek/0.32/%{version}/+download/%{name}-%{version}.tar.xz
-# Source0-md5: 60b964723880569531f88f084cd3ae65
+#Source0:      http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
+Source0:       https://github.com/poldek-pm/poldek/releases/download/v%{version}/%{name}-%{version}.tar.xz
+# Source0-md5: 2759fe45bc50efb6084d5338d725411a
 Source1:       %{name}.conf
 Source2:       %{name}-multilib.conf
 Source3:       %{name}-config.sh
 Source5:       %{name}-aliases.conf
 Source6:       %{name}.desktop
 Source7:       %{name}.png
-Patch0:                %{name}-size-type.patch
-Patch1:                %{name}-config.patch
-Patch2:                pm-hooks.patch
-Patch3:                WTERMSIG.patch
-Patch4:                %{name}-multiproto.patch
-Patch5:                %{name}-python-fix.patch
-Patch6:                %{name}-libdb.patch
-Patch7:                openssl.patch
+# Source7-md5: ee487abede50874e9eceb6495d5ee150
+Patch0:                %{name}-config.patch
+Patch1:                pm-hooks.patch
+Patch2:                %{name}-ext-down-enable.patch
+Patch3:                %{name}-pc.patch
+Patch4:                %{name}-info.patch
+Patch5:                %{name}-multiarch-x32.patch
+Patch6:                rpm-4.15.patch
+Patch7:                db-index-format.patch
+Patch8:                rpm4-uname-deps.patch
 URL:           http://poldek.pld-linux.org/
-BuildRequires: %{db_pkg}-devel >= %{ver_db}-%{ver_db_rel}
-BuildRequires: autoconf
+BuildRequires: %{db_pkg}-devel >= %{ver_db}
+BuildRequires: autoconf >= 2.63
 BuildRequires: automake >= 1:1.11
 BuildRequires: bzip2-devel
 BuildRequires: check-devel
 BuildRequires: docbook-dtd412-xml
-BuildRequires: gettext-tools
+BuildRequires: docbook2X
+BuildRequires: gettext-tools >= 0.11.5
 BuildRequires: libgomp-devel
 BuildRequires: libtool
-BuildRequires: libxml2-devel
+BuildRequires: libxml2-devel >= 2
+BuildRequires: ncurses-devel
 BuildRequires: openssl-devel >= 0.9.7d
 BuildRequires: pcre-devel
+BuildRequires: perl-XML-Simple
+BuildRequires: perl-base
+BuildRequires: perl-modules
 BuildRequires: pkgconfig
 BuildRequires: popt-devel
 %{?with_python:BuildRequires:  python-devel}
@@ -59,11 +66,13 @@ BuildRequires:      readline-devel >= 5.0
 BuildRequires: rpm-devel >= %{ver_rpm}
 %{?with_python:BuildRequires:  rpm-pythonprov}
 BuildRequires: tar >= 1:1.22
+BuildRequires: texinfo
 BuildRequires: xmlto
 BuildRequires: xz
 BuildRequires: zlib-devel
+BuildRequires: zstd-devel
 %if %{with static}
-BuildRequires: %{db_pkg}-static >= %{ver_db}-%{ver_db_rel}
+BuildRequires: %{db_pkg}-static >= %{ver_db}
 BuildRequires: bzip2-static
 BuildRequires: glibc-static
 BuildRequires: libxml2-static
@@ -74,20 +83,21 @@ BuildRequires:      popt-static
 BuildRequires: readline-static
 BuildRequires: rpm-static
 BuildRequires: zlib-static
+BuildRequires: zstd-static
 %endif
-Requires(triggerpostun):       awk
-Requires(triggerpostun):       sed >= 4.0
-Requires:      %{db_pkg} >= %{ver_db}-%{ver_db_rel}
+Requires(postun):      awk
+Requires(postun):      sed >= 4.0
+Requires:      %{db_pkg} >= %{ver_db_devel}
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      /bin/run-parts
 Requires:      rpm >= %{ver_rpm}
-Requires:      rpm-db-ver = %{ver_db}
 Requires:      rpm-lib >= %{ver_rpm}
 Requires:      sed
 Conflicts:     etckeeper < 1.18-2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _libexecdir     %{_prefix}/lib/%{name}
+# it could be %{_libexecdir}/%{name}, but beware of compatibility (path hardcoded in configurations)
+%define                pkglibexecdir   %{_prefix}/lib/%{name}
 
 %description
 poldek is an RPM package management tool which allows you to easily
@@ -208,6 +218,7 @@ Moduły języka Python dla poldka.
 %patch6 -p1
 %patch7 -p1
 
+%{__rm} doc/poldek.info
 %{__rm} m4/libtool.m4 m4/lt*.m4
 
 # cleanup backups after patching
@@ -235,47 +246,48 @@ cd ../trurlib
 %{__automake}
 cd ..
 
-CPPFLAGS="%{rpmcppflags} -std=gnu99 -fgnu89-inline -D_GNU_SOURCE=1"
 %configure \
        %{?with_static:--enable-static --disable-shared} \
        %{!?with_imode:--disable-imode} \
-       --with-pkglibdir=%{_libexecdir} \
+       --with-pkglibdir=%{pkglibexecdir} \
        --enable-nls \
        %{?with_python:--with-python}
-%{__make} -j1
-#      --enable-trace
+%{__make}
+
+%{__make} -C doc poldek.info
 
 %if %{with python}
 %{__make} -C python
 %endif
 
+%if %{with tests}
+%{__make} check
+%endif
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/var/cache/%{name}
 
-%{__make} install -j1 \
+%{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/poldek-config
 
 %if %{with python}
-%{__make} -C python -j1 install \
+%{__make} -C python install \
        DESTDIR=$RPM_BUILD_ROOT \
        py_sitedir=%{py_sitedir}
 %endif
 
 %{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
 
-%ifarch i686
+%ifarch i686 aarch64
        %define         ftp_arch        %{_target_cpu}
 %endif
 %ifarch %{x8664}
        %define         ftp_arch        x86_64
        %define         ftp_alt_arch    i686
 %endif
-%ifarch pentium2 pentium3 pentium4
-       %define         ftp_arch        i686
-%endif
 
 %define        tld_conf %{SOURCE1}
 
@@ -368,15 +380,15 @@ fi
 %triggerpostun -- %{name} < 0.30.1-8
 if [ $1 -le 1 ]; then
        # revert change on  --downgrade
-       %{__sed} -i -re 's,^pm command = %{_libexecdir}/pm-command.sh,#&,' %{_sysconfdir}/%{name}/%{name}.conf
+       %{__sed} -i -re 's,^pm command = %{pkglibexecdir}/pm-command.sh,#&,' %{_sysconfdir}/%{name}/%{name}.conf
 else
        # setup pm command
-       %{__sed} -i -re 's,#?(pm command =).*,\1 %{_libexecdir}/pm-command.sh,' %{_sysconfdir}/%{name}/%{name}.conf
+       %{__sed} -i -re 's,#?(pm command =).*,\1 %{pkglibexecdir}/pm-command.sh,' %{_sysconfdir}/%{name}/%{name}.conf
 fi
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc ChangeLog README* NEWS TODO configs
+%doc ChangeLog README* NEWS configs
 %dir %{_sysconfdir}/%{name}
 %dir %{_sysconfdir}/%{name}/pre-install.d
 %{_sysconfdir}/%{name}/pre-install.d/README
@@ -395,13 +407,13 @@ fi
 %attr(755,root,root) %{_bindir}/poldek
 %attr(755,root,root) %{_bindir}/poldek-config
 %attr(755,root,root) %{_bindir}/rpmvercmp
-%dir %{_libexecdir}
-%attr(755,root,root) %{_libexecdir}/pm-command.sh
-%attr(755,root,root) %{_libexecdir}/poldekuser-setup.sh
-%attr(755,root,root) %{_libexecdir}/vfcompr
-%attr(755,root,root) %{_libexecdir}/vfjuggle
-%attr(755,root,root) %{_libexecdir}/vfsmb
-%attr(755,root,root) %{_libexecdir}/zlib-in-rpm.sh
+%dir %{pkglibexecdir}
+%attr(755,root,root) %{pkglibexecdir}/pm-command.sh
+%attr(755,root,root) %{pkglibexecdir}/poldekuser-setup.sh
+%attr(755,root,root) %{pkglibexecdir}/vfcompr
+%attr(755,root,root) %{pkglibexecdir}/vfjuggle
+%attr(755,root,root) %{pkglibexecdir}/vfsmb
+%attr(755,root,root) %{pkglibexecdir}/zlib-in-rpm.sh
 %{_mandir}/man1/%{name}*.1*
 %lang(pl) %{_mandir}/pl/man1/%{name}*
 %{_infodir}/poldek.info*
@@ -419,8 +431,8 @@ fi
 %attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
 %attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
 %attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
-%attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
+%attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.1
+%attr(755,root,root) %ghost %{_libdir}/libpoldek.so.3
 %attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
 %attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
 %attr(755,root,root) %ghost %{_libdir}/libvfile.so.0