]> TLD Linux GIT Repositories - packages/poldek.git/blobdiff - poldek.spec
- https-redirect.patch from PLD
[packages/poldek.git] / poldek.spec
index 55eae0510a0ede89a4522a0c99f9fae3b1af76bf..5d9f58a60b88c6b3866c918796b679d7ffff5958 100644 (file)
@@ -5,29 +5,27 @@
 # Conditional build:
 %bcond_with    static  # don't use shared libraries
 %bcond_without imode   # don't build interactive mode
-%bcond_without python  # don't build python bindings
+%bcond_with    python  # don't build python bindings
 %bcond_with    tests   # tests
 
 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
-%define                db_pkg          db
-%define                ver_db          5.3
 %define                ver_rpm         1:4.14
-%define                ver_db_devel    %(rpm -q --qf '%|E?{%{E}:}|%{V}-%{R}' --what-provides db-devel)
 
 Summary:       RPM packages management helper tool
 Summary(hu.UTF-8):     RPM csomagkezelést segítő eszköz
 Summary(pl.UTF-8):     Pomocnicze narzędzie do zarządzania pakietami RPM
 Name:          poldek
 Version:       0.42.2
-Release:       3
+Release:       18
 License:       GPL v2
 Group:         Applications/System
 #Source0:      http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
 Source0:       https://github.com/poldek-pm/poldek/releases/download/v%{version}/%{name}-%{version}.tar.xz
 # Source0-md5: 2759fe45bc50efb6084d5338d725411a
-Source1:       %{name}.conf
-Source2:       %{name}-multilib.conf
-Source3:       %{name}-config.sh
+Source1:       tld.conf
+Source2:       tld-multilib.conf
+Source3:       tld-debuginfo.conf
+Source4:       %{name}-config.sh
 Source5:       %{name}-aliases.conf
 Source6:       %{name}.desktop
 Source7:       %{name}.png
@@ -41,8 +39,23 @@ Patch5:              %{name}-multiarch-x32.patch
 Patch6:                rpm-4.15.patch
 Patch7:                db-index-format.patch
 Patch8:                rpm4-uname-deps.patch
+Patch9:                sqlite-rpmdb.patch
+Patch10:       rpm4-cpuinfo-deps.patch
+Patch11:       rpm4-no-dir-deps.patch
+Patch12:       rpm4-rpmvercmp.patch
+Patch13:       trurlib-shared.patch
+Patch14:       rpm4-script-req-workaround.patch
+Patch15:       skip-buildid-obsoletes.patch
+Patch16:       verify-signature.patch
+Patch17:       %{name}-rsa_sig_rpmorg.patch
+Patch18:       no-bdb-for-rpm-org.patch
+Patch19:       more-trace.patch
+Patch20:       boolean-deps.patch
+Patch21:       sorted-ls-upgradable.patch
+Patch22:       egrep-is-obsolete.patch
+Patch23:       minus.patch
+Patch24:       %{name}-https-redirect.patch
 URL:           http://poldek.pld-linux.org/
-BuildRequires: %{db_pkg}-devel >= %{ver_db}
 BuildRequires: autoconf >= 2.63
 BuildRequires: automake >= 1:1.11
 BuildRequires: bzip2-devel
@@ -53,6 +66,7 @@ BuildRequires:        gettext-tools >= 0.11.5
 BuildRequires: libgomp-devel
 BuildRequires: libtool
 BuildRequires: libxml2-devel >= 2
+BuildRequires: lua54-devel
 BuildRequires: ncurses-devel
 BuildRequires: openssl-devel >= 0.9.7d
 BuildRequires: pcre-devel
@@ -72,7 +86,6 @@ BuildRequires:        xz
 BuildRequires: zlib-devel
 BuildRequires: zstd-devel
 %if %{with static}
-BuildRequires: %{db_pkg}-static >= %{ver_db}
 BuildRequires: bzip2-static
 BuildRequires: glibc-static
 BuildRequires: libxml2-static
@@ -87,7 +100,6 @@ BuildRequires:       zstd-static
 %endif
 Requires(postun):      awk
 Requires(postun):      sed >= 4.0
-Requires:      %{db_pkg} >= %{ver_db_devel}
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      /bin/run-parts
 Requires:      rpm >= %{ver_rpm}
@@ -217,6 +229,25 @@ Moduły języka Python dla poldka.
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
+%patch8 -p1
+%patch9 -p1
+%patch10 -p1
+%patch11 -p1
+%patch12 -p1
+cd trurlib
+%patch13 -p1
+cd ..
+%patch14 -p1
+%patch15 -p1
+%patch16 -p1
+%patch17 -p1
+%patch18 -p1
+%patch19 -p1
+%patch20 -p1
+%patch21 -p1
+%patch22 -p1
+%patch23 -p1
+%patch24 -p1
 
 %{__rm} doc/poldek.info
 %{__rm} m4/libtool.m4 m4/lt*.m4
@@ -271,7 +302,7 @@ install -d $RPM_BUILD_ROOT/var/cache/%{name}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/poldek-config
+install -p %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/poldek-config
 
 %if %{with python}
 %{__make} -C python install \
@@ -281,7 +312,7 @@ install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/poldek-config
 
 %{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
 
-%ifarch i686 aarch64
+%ifarch i686 aarch64 %{arm}
        %define         ftp_arch        %{_target_cpu}
 %endif
 %ifarch %{x8664}
@@ -292,15 +323,19 @@ install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/poldek-config
 %define        tld_conf %{SOURCE1}
 
 %ifarch %{x8664}
-       %define tld_multilib_conf %{SOURCE2}
+       %define         tld_multilib_conf       %{SOURCE2}
 %endif
 
+%define        tld_debuginfo_conf %{SOURCE3}
+
 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{tld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/tld.conf
 
 %if 0%{?tld_multilib_conf:1}
        %{__sed} 's|%%ARCH%%|%{ftp_alt_arch}|g' < %{tld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/tld-multilib.conf
 %endif
 
+%{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{tld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/tld-debuginfo.conf
+
 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
 
 %if %{with imode}
@@ -403,6 +438,7 @@ fi
 %if 0%{?tld_multilib_conf:1}
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/tld-multilib.conf
 %endif
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/tld-debuginfo.conf
 %attr(755,root,root) %{_bindir}/ipoldek
 %attr(755,root,root) %{_bindir}/poldek
 %attr(755,root,root) %{_bindir}/poldek-config