]> TLD Linux GIT Repositories - packages/poldek.git/blobdiff - poldek.spec
- https-redirect.patch from PLD
[packages/poldek.git] / poldek.spec
index b6454f4aba1897e10e6818a3aca3e309495639f4..5d9f58a60b88c6b3866c918796b679d7ffff5958 100644 (file)
@@ -9,17 +9,14 @@
 %bcond_with    tests   # tests
 
 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
-%define                db_pkg          db
-%define                ver_db          5.3
 %define                ver_rpm         1:4.14
-%define                ver_db_devel    %(rpm -q --qf '%|E?{%{E}:}|%{V}-%{R}' --what-provides db-devel)
 
 Summary:       RPM packages management helper tool
 Summary(hu.UTF-8):     RPM csomagkezelést segítő eszköz
 Summary(pl.UTF-8):     Pomocnicze narzędzie do zarządzania pakietami RPM
 Name:          poldek
 Version:       0.42.2
-Release:       6
+Release:       18
 License:       GPL v2
 Group:         Applications/System
 #Source0:      http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
@@ -49,8 +46,16 @@ Patch12:     rpm4-rpmvercmp.patch
 Patch13:       trurlib-shared.patch
 Patch14:       rpm4-script-req-workaround.patch
 Patch15:       skip-buildid-obsoletes.patch
+Patch16:       verify-signature.patch
+Patch17:       %{name}-rsa_sig_rpmorg.patch
+Patch18:       no-bdb-for-rpm-org.patch
+Patch19:       more-trace.patch
+Patch20:       boolean-deps.patch
+Patch21:       sorted-ls-upgradable.patch
+Patch22:       egrep-is-obsolete.patch
+Patch23:       minus.patch
+Patch24:       %{name}-https-redirect.patch
 URL:           http://poldek.pld-linux.org/
-BuildRequires: %{db_pkg}-devel >= %{ver_db}
 BuildRequires: autoconf >= 2.63
 BuildRequires: automake >= 1:1.11
 BuildRequires: bzip2-devel
@@ -61,6 +66,7 @@ BuildRequires:        gettext-tools >= 0.11.5
 BuildRequires: libgomp-devel
 BuildRequires: libtool
 BuildRequires: libxml2-devel >= 2
+BuildRequires: lua54-devel
 BuildRequires: ncurses-devel
 BuildRequires: openssl-devel >= 0.9.7d
 BuildRequires: pcre-devel
@@ -80,7 +86,6 @@ BuildRequires:        xz
 BuildRequires: zlib-devel
 BuildRequires: zstd-devel
 %if %{with static}
-BuildRequires: %{db_pkg}-static >= %{ver_db}
 BuildRequires: bzip2-static
 BuildRequires: glibc-static
 BuildRequires: libxml2-static
@@ -95,7 +100,6 @@ BuildRequires:       zstd-static
 %endif
 Requires(postun):      awk
 Requires(postun):      sed >= 4.0
-Requires:      %{db_pkg} >= %{ver_db_devel}
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      /bin/run-parts
 Requires:      rpm >= %{ver_rpm}
@@ -235,6 +239,15 @@ cd trurlib
 cd ..
 %patch14 -p1
 %patch15 -p1
+%patch16 -p1
+%patch17 -p1
+%patch18 -p1
+%patch19 -p1
+%patch20 -p1
+%patch21 -p1
+%patch22 -p1
+%patch23 -p1
+%patch24 -p1
 
 %{__rm} doc/poldek.info
 %{__rm} m4/libtool.m4 m4/lt*.m4
@@ -299,7 +312,7 @@ install -p %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/poldek-config
 
 %{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
 
-%ifarch i686 aarch64
+%ifarch i686 aarch64 %{arm}
        %define         ftp_arch        %{_target_cpu}
 %endif
 %ifarch %{x8664}
@@ -310,7 +323,7 @@ install -p %{SOURCE4} $RPM_BUILD_ROOT%{_bindir}/poldek-config
 %define        tld_conf %{SOURCE1}
 
 %ifarch %{x8664}
-       %define tld_multilib_conf %{SOURCE2}
+       %define         tld_multilib_conf       %{SOURCE2}
 %endif
 
 %define        tld_debuginfo_conf %{SOURCE3}