]> TLD Linux GIT Repositories - packages/poldek.git/commitdiff
- merged update to 0.30.0 from PLD
authorMarcin Krol <hawk@tld-linux.org>
Fri, 12 Jul 2013 17:35:00 +0000 (17:35 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Fri, 12 Jul 2013 17:35:00 +0000 (17:35 +0000)
- s/Titanium/TLD Linux/, cosmetics

ac-prog-libtool.patch [deleted file]
poldek-config.patch
poldek-git.patch [deleted file]
poldek-multilib.conf
poldek-vserver-packages.patch [deleted file]
poldek.conf
poldek.spec

diff --git a/ac-prog-libtool.patch b/ac-prog-libtool.patch
deleted file mode 100644 (file)
index c17bf8c..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- poldek-0.30/configure.ac~  2010-08-22 14:57:05.000000000 +0300
-+++ poldek-0.30/configure.ac   2010-08-22 14:58:09.298819202 +0300
-@@ -48,6 +48,7 @@
- dnl Checks for programs.
- LT_INIT
-+AC_PROG_LIBTOOL
- AC_PROG_CC()
- #AC_PROG_CXX()
- AC_C_INLINE
index 5f1f5a35da8030483231cc26d7a1fd45dfbe31a9..f89f30478bbbc9426ea3b1530a85558880c87c5e 100644 (file)
@@ -1,48 +1,17 @@
---- poldek-0.30/doc/poldek.conf.xml    2012-04-04 11:37:12.737381529 +0300
-+++ poldek-0.30/doc/poldek.conf.xml    2012-04-04 11:38:47.231352866 +0300
-@@ -369,7 +369,7 @@
-     </description>
-   </option>
--  <option name="choose equivalents manually" type="boolean" default="no" op="EQPKG_ASKUSER">
-+  <option name="choose equivalents manually" type="boolean" default="yes" op="EQPKG_ASKUSER">
-     <description>
-     Let the user select package among equivalents.
-     </description>
-@@ -598,7 +598,7 @@
-     </description>
-   </option>
--  <option name="hold" type="string" list="yes" default="" multiple="yes">
-+  <option name="hold" type="string" list="yes" default="kernel*" multiple="yes">
-     <description>
-     Have the same meaning as [ global ] parameter. Example:
-     [screen]
---- poldek-0.30/conf/poldek.conf~      2010-08-22 14:19:51.000000000 +0300
-+++ poldek-0.30/conf/poldek.conf       2010-08-22 14:20:28.524878981 +0300
-@@ -128,11 +128,11 @@
- #confirm removal = yes
- # Let the user select package among equivalents.
--#choose equivalents manually = no
-+choose equivalents manually = yes
+--- poldek-0.30.0/conf/poldek.conf     2013-07-08 14:19:35.294351501 +0300
++++ poldek-0.30.0/conf/poldek.conf     2013-07-08 14:06:38.722878665 +0300
+@@ -132,12 +132,11 @@
  
  # Prevent package listed from being upgraded if they are already installed.
--# hold = kernel* foo*.i686 th-test:* *-smp-* th-ready:bar*.x86_64
+ # hold = kernel* foo*.i686 th-test:* *-smp-* th-ready:bar*.x86_64
 -#hold = 
-+# hold = kernel* foo*.i686 ti-ready:bar*.x86_64
 +hold = kernel*
  
  # Ignore package list - packages fits given mask will be invisible.
  # ignore = *-smp-* foo*
---- poldek-0.30/conf_sections.c~       2012-04-04 12:01:04.000000000 +0300
-+++ poldek-0.30/conf_sections.c        2012-04-04 12:04:46.080171888 +0300
-@@ -173,7 +173,7 @@
-              
-    { "choose equivalents manually", 
-      CONF_TYPE_BOOLEAN,
--             "no",
-+             "yes",
-              POLDEK_OP_EQPKG_ASKUSER, { 0 } },
-              
-    { "hold", 
+-# ignore = vserver-packages
+-#ignore = vserver-packages
++ignore = vserver-packages
+ # Conflicts with already installed packages are treated as resolved
+ # if at least one of multiple-installed package satisfies conflict.
diff --git a/poldek-git.patch b/poldek-git.patch
deleted file mode 100644 (file)
index 44c4125..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-commit 9ecd484cd077adba94649b83b3f3bfd639644056
-Author: Marcin Banasiak <marcin.banasiak@gmail.com>
-Date:   Wed Mar 20 00:09:57 2013 +0100
-
-    rpmvercmp: read macro configuration files before using rpmEVRparse()
-
-diff --git a/pm/rpm/rpmvercmp.c b/pm/rpm/rpmvercmp.c
-index 968489a..d83f26b 100644
---- a/pm/rpm/rpmvercmp.c
-+++ b/pm/rpm/rpmvercmp.c
-@@ -1,6 +1,6 @@
- /*
-   Copyright (C) 2000 - 2008 Pawel A. Gajda <mis@pld-linux.org>
--  Copyright (C) 2010 - 2012 Marcin Banasiak <marcin.banasiak@gmail.com>
-+  Copyright (C) 2010 - 2013 Marcin Banasiak <marcin.banasiak@gmail.com>
-   This program is free software; you can redistribute it and/or modify
-   it under the terms of the GNU General Public License, version 2 as
-@@ -20,7 +20,10 @@
- #include <stdlib.h>
- #ifdef HAVE_RPM_5
-+# include <rpm/rpmrc.h>
- # include <rpm/rpmtag.h>
-+#else
-+# include <rpm/rpmlib.h>
- #endif
- #define _RPMEVR_INTERNAL
-@@ -61,6 +64,11 @@ int main(int argc, char *argv[])
-         exit(1);
-     }
-+    if (rpmReadConfigFiles(NULL, NULL) < 0) {
-+      fprintf(stderr, "Failed to read configuration files\n");
-+      exit(2);
-+    }
-+
-     evr1 = malloc(sizeof(struct EVR_s));
-     evr2 = malloc(sizeof(struct EVR_s));
index d92597fa0e3eee35eab487c89ad0ac2d989d62dd..6c31e725b5752284796339b26d10c2989b3bf82e 100644 (file)
@@ -1,5 +1,4 @@
-# Titanium Linux Distribution, multilib config
-# http://www.tld-linux.org/
+# TLD Linux -  http://www.tld-linux.org/
 
 _arch   = %ARCH%
 _prefix = ftp://ftp.tld-linux.org/TLD
@@ -7,7 +6,7 @@ _prefix = ftp://ftp.tld-linux.org/TLD
 ############################################################
 
 ###
-# Titanium (Ti) Stable
+# TLD Linux Stable
 [source]
 type   = pndir
 name   = ti-%{_arch}
@@ -16,7 +15,7 @@ auto   = no
 autoup = no
 
 ###
-# Titanium (Ti) Stable, test packages
+# TLD Linux Stable, test packages
 [source]
 type   = pndir
 name   = ti-test-%{_arch}
@@ -27,7 +26,7 @@ autoup = no
 ############################################################
 
 ###
-# Titanium (Ti) Devel
+# TLD Linux Devel
 [source]
 type   = pndir
 name   = ti-dev-%{_arch}
@@ -36,7 +35,7 @@ auto   = no
 autoup = no
 
 ###
-# Titanium (Ti) Devel, test packages
+# TLD Linux Devel, test packages
 [source]
 type   = pndir
 name   = ti-dev-test-%{_arch}
diff --git a/poldek-vserver-packages.patch b/poldek-vserver-packages.patch
deleted file mode 100644 (file)
index ad0040c..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- poldek/conf/poldek.conf~   2008-02-26 17:10:23.000000000 +0100
-+++ poldek/conf/poldek.conf    2008-02-26 17:11:24.789742706 +0100
-@@ -138,7 +138,7 @@
- # Ignore package list - packages fits given mask will be invisible.
- # ignore = *-smp-* foo*
--# ignore = vserver-packages
-+ignore = vserver-packages
- #ignore = 
- # Conflicts with already installed packages are treated as resolved 
index 9d302b24136234a76bbb57d79ed0be851a6b4b0b..1500bfedb442cbbabb2ebfe67baf01c571478dd5 100644 (file)
@@ -1,13 +1,11 @@
-# Titanium Linux Distribution
-# http://www.tld-linux.org/
+# TLD Linux - http://www.tld-linux.org/
 
 _arch   = %ARCH%
 _prefix = ftp://ftp.tld-linux.org/TLD
 
 ############################################################
 
-###
-# Titanium (Ti) Stable
+# TLD Linux Stable
 [source]
 type   = pndir
 name   = ti
@@ -18,8 +16,7 @@ type   = pndir
 name   = ti
 path   = %{_prefix}/stable/main/noarch/RPMS/
 
-###
-# Titanium (Ti) Stable, test packages
+# TLD Linux Stable, test packages
 [source]
 type   = pndir
 name   = ti-test
@@ -34,8 +31,7 @@ path   = %{_prefix}/stable/test/noarch/RPMS/
 auto   = no
 autoup = no
 
-###
-# Titanium (Ti) Stable, archived packages
+# TLD Linux Stable, archived packages
 [source]
 type   = pndir
 name   = ti-archive
@@ -52,8 +48,7 @@ autoup = no
 
 ############################################################
 
-###
-# Titanium (Ti) Devel
+# TLD Linux Devel
 [source]
 type   = pndir
 name   = ti-dev
@@ -68,8 +63,7 @@ path   = %{_prefix}/devel/main/noarch/RPMS/
 auto   = no
 autoup = no
 
-###
-# Titanium (Ti) Devel, test packages
+# TLD Linux Devel, test packages
 [source]
 type   = pndir
 name   = ti-dev-test
index 8c9470fd41ae27fa009c6ffeb49ed8465420dd02..42cce4e371fada52096be57dc4d96149000563d7 100644 (file)
@@ -1,41 +1,41 @@
+#
 # Conditional build:
 %bcond_with    static  # don't use shared libraries
 %bcond_without imode   # don't build interactive mode
 %bcond_without python  # don't build python bindings
 
 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
-%define        ver_db          4.5.20
-%define        ver_db_rel      8
-%define        ver_rpm         4.5-49
+%define                db_pkg          db4.5
+%define                ver_db          4.5.20
+%define                ver_db_rel      3
+%define                ver_rpm         4.5-71
 
-%define                snap    rc7
 %define                rel     1
 Summary:       RPM packages management helper tool
 Summary(hu.UTF-8):     RPM csomagkezelést segítő eszköz
 Summary(pl.UTF-8):     Pomocnicze narzędzie do zarządzania pakietami RPM
 Name:          poldek
 Version:       0.30.0
-Release:       1.%{snap}.%{rel}
+Release:       %{rel}
 License:       GPL v2
 Group:         Applications/System
-Source0:       http://carme.pld-linux.org/~megabajt/snaps/poldek/%{name}-%{version}%{snap}.tar.xz
-# Source0-md5: 56ba9e7b709a99965f42e24e65eb2d7f
+#Source0:      http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
+Source0:       http://carme.pld-linux.org/~megabajt/releases/poldek/%{name}-%{version}.tar.xz
+# Source0-md5: 392cfa125912fbedb6cc6d54dfbb80e3
 Source1:       %{name}.conf
 Source2:       %{name}-multilib.conf
 Source5:       %{name}-aliases.conf
 Source6:       %{name}.desktop
 Source7:       %{name}.png
-Patch0:                %{name}-vserver-packages.patch
-Patch1:                %{name}-config.patch
-Patch2:                %{name}-size-type.patch
-Patch3:                %{name}-Os-fail-workaround.patch
-Patch4:                %{name}-git.patch
+Patch0:                %{name}-size-type.patch
+Patch1:                %{name}-Os-fail-workaround.patch
+Patch2:                %{name}-config.patch
 URL:           http://poldek.pld-linux.org/
+BuildRequires: %{db_pkg}-devel >= %{ver_db}-%{ver_db_rel}
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bzip2-devel
 BuildRequires: check-devel
-BuildRequires: db-devel >= %{ver_db}-%{ver_db_rel}
 BuildRequires: docbook-dtd412-xml
 BuildRequires: gettext-devel
 BuildRequires: libtool
@@ -50,11 +50,13 @@ BuildRequires:      readline-devel >= 5.0
 BuildRequires: rpm-devel >= %{ver_rpm}
 %{?with_python:BuildRequires:  rpm-pythonprov}
 BuildRequires: swig-python
+BuildRequires: tar >= 1:1.22
 BuildRequires: xmlto
+BuildRequires: xz
 BuildRequires: zlib-devel
 %if %{with static}
+BuildRequires: %{db_pkg}-static >= %{ver_db}-%{ver_db_rel}
 BuildRequires: bzip2-static
-BuildRequires: db-static >= %{ver_db}-%{ver_db_rel}
 BuildRequires: glibc-static
 BuildRequires: libselinux-static
 BuildRequires: libxml2-static
@@ -68,15 +70,18 @@ BuildRequires:      zlib-static
 %endif
 Requires(triggerpostun):       awk
 Requires(triggerpostun):       sed >= 4.0
+Requires:      %{db_pkg} >= %{ver_db}-%{ver_db_rel}
 Requires:      %{name}-libs = %{version}-%{release}
-Requires:      db >= %{ver_db}-%{ver_db_rel}
 Requires:      rpm >= %{ver_rpm}
 Requires:      rpm-db-ver = %{ver_db}
-Requires:      rpm-lib = %(rpm -q --qf '%{V}' rpm-lib)
+#Requires:     rpm-lib = %(rpm -q --qf '%{V}' rpm-lib)
+Requires:      rpm-lib >= %{ver_rpm}
 # vf* scripts use sed
 Requires:      sed
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _libexecdir     %{_prefix}/lib/%{name}
+
 %description
 poldek is an RPM package management tool which allows you to easily
 perform package verification, installation (including system
@@ -174,7 +179,7 @@ Summary(hu.UTF-8):  Python modulok poldek-hez
 Summary(pl.UTF-8):     Moduły języka Python dla poldka
 Group:         Libraries/Python
 Requires:      %{name}-libs = %{version}-%{release}
-%pyrequires_eq python-libs
+Requires:      python-libs
 
 %description -n python-poldek
 Python modules for poldek.
@@ -190,8 +195,6 @@ Moduły języka Python dla poldka.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
-%patch4 -p1
 
 %{__rm} m4/libtool.m4 m4/lt*.m4
 
@@ -223,6 +226,7 @@ CPPFLAGS="%{rpmcppflags} -std=gnu99"
 %configure \
        %{?with_static:--enable-static --disable-shared} \
        %{!?with_imode:--disable-imode} \
+       --with-pkglibdir=%{_libexecdir} \
        --enable-nls \
        %{?with_python:--with-python}
 %{__make} -j1
@@ -243,16 +247,13 @@ install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name}/repos.d,/var/cache/%{name}}
 
 %{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
 
-%ifarch i586 i686 ppc sparc alpha athlon
+%ifarch i686
        %define         _ftp_arch       %{_target_cpu}
 %endif
 %ifarch %{x8664}
        %define         _ftp_arch       x86_64
        %define         _ftp_alt_arch   i686
 %endif
-%ifarch i586
-       %define         _ftp_arch       i586
-%endif
 %ifarch pentium2 pentium3 pentium4
        %define         _ftp_arch       i686
 %endif
@@ -398,8 +399,8 @@ fi
 %attr(755,root,root) %{_bindir}/ipoldek
 %attr(755,root,root) %{_bindir}/poldek
 %attr(755,root,root) %{_bindir}/rpmvercmp
-%dir %{_libdir}/%{name}
-%attr(755,root,root) %{_libdir}/%{name}/*
+%dir %{_libexecdir}
+%attr(755,root,root) %{_libexecdir}/*
 %{_mandir}/man1/%{name}*.1*
 %lang(pl) %{_mandir}/pl/man1/%{name}*
 %{_infodir}/poldek.info*