]> TLD Linux GIT Repositories - packages/postfix.git/blobdiff - postfix-link.patch
- updated to 3.8.6
[packages/postfix.git] / postfix-link.patch
index 7cdd0cf85374c1b7a53b788005a221731f1d08ed..58eefb8f45600e833543908c8e3214242265c3a4 100644 (file)
@@ -1,48 +1,48 @@
-diff -ur postfix-2.7.1/src/dns/Makefile.in postfix-2.7.1-libs/src/dns/Makefile.in
---- postfix-2.7.1/src/dns/Makefile.in  2010-11-08 20:14:18.394139054 +0100
-+++ postfix-2.7.1-libs/src/dns/Makefile.in     2010-11-08 20:12:39.300139053 +0100
-@@ -31,7 +31,7 @@
- root_tests:
+diff -ur postfix-3.0.2.orig/src/dns/Makefile.in postfix-3.0.2/src/dns/Makefile.in
+--- postfix-3.0.2.orig/src/dns/Makefile.in     2015-01-28 00:13:11.000000000 +0000
++++ postfix-3.0.2/src/dns/Makefile.in  2015-07-26 21:11:11.550001565 +0000
+@@ -37,7 +37,7 @@
  $(LIB):       $(OBJS)
--      gcc -shared -Wl,-soname,libpostfix-dns.so.1 -o $(LIB) $(OBJS)
-+      gcc -shared -Wl,-soname,libpostfix-dns.so.1 -o $(LIB) $(OBJS) $(LIBS) -lresolv
+       $(AR) $(ARFL) $(LIB) $?
+       $(RANLIB) $(LIB)
+-      $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(OBJS) $(SHLIB_SYSLIBS)
++      $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(OBJS) $(SHLIB_SYSLIBS) $(LIBS)
  
  $(LIB_DIR)/$(LIB): $(LIB)
        cp $(LIB) $(LIB_DIR)
-diff -ur postfix-2.7.1/src/global/Makefile.in postfix-2.7.1-libs/src/global/Makefile.in
---- postfix-2.7.1/src/global/Makefile.in       2010-11-08 20:14:18.424139054 +0100
-+++ postfix-2.7.1-libs/src/global/Makefile.in  2010-11-08 20:10:05.004139060 +0100
-@@ -120,7 +120,7 @@
- test: $(TESTPROG)
+diff -ur postfix-3.0.2.orig/src/global/Makefile.in postfix-3.0.2/src/global/Makefile.in
+--- postfix-3.0.2.orig/src/global/Makefile.in  2015-01-28 00:13:10.000000000 +0000
++++ postfix-3.0.2/src/global/Makefile.in       2015-07-26 21:11:37.799001565 +0000
+@@ -142,7 +142,7 @@
  $(LIB):       $(OBJS)
--      gcc -shared -Wl,-soname,libpostfix-global.so.1 -o $(LIB) $(OBJS)
-+      gcc -shared -Wl,-soname,libpostfix-global.so.1 -o $(LIB) $(OBJS) $(LIBS)
- $(LDAPSO): dict_ldap.o $(LIB)
-       gcc -shared -Wl,-soname,dict_ldap.so -o $@ $? -lldap -llber -L../../lib -lutil -L. -lglobal
-diff -ur postfix-2.7.1/src/master/Makefile.in postfix-2.7.1-libs/src/master/Makefile.in
---- postfix-2.7.1/src/master/Makefile.in       2010-11-08 20:14:18.400139054 +0100
-+++ postfix-2.7.1-libs/src/master/Makefile.in  2010-11-08 20:10:24.072139054 +0100
-@@ -39,7 +39,7 @@
- root_tests:
+       $(AR) $(ARFL) $(LIB) $?
+       $(RANLIB) $(LIB)
+-      $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(OBJS) $(SHLIB_SYSLIBS)
++      $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(OBJS) $(SHLIB_SYSLIBS) $(LIBS)
  
+ $(LIB_DIR)/$(LIB): $(LIB)
+       cp $(LIB) $(LIB_DIR)
+diff -ur postfix-3.0.2.orig/src/master/Makefile.in postfix-3.0.2/src/master/Makefile.in
+--- postfix-3.0.2.orig/src/master/Makefile.in  2015-01-28 00:13:12.000000000 +0000
++++ postfix-3.0.2/src/master/Makefile.in       2015-07-26 21:12:33.635001565 +0000
+@@ -44,7 +44,7 @@
  $(LIB):       $(LIB_OBJ)
--      gcc -shared -Wl,-soname,libpostfix-master.so.1 -o $(LIB) $(LIB_OBJ)
-+      gcc -shared -Wl,-soname,libpostfix-master.so.1 -o $(LIB) $(LIB_OBJ) $(LIBS)
+       $(AR) $(ARFL) $(LIB) $?
+       $(RANLIB) $(LIB)
+-      $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(LIB_OBJ) $(SHLIB_SYSLIBS)
++      $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(LIB_OBJ) $(SHLIB_SYSLIBS) $(LIBS)
  
  $(LIB_DIR)/$(LIB): $(LIB)
        cp $(LIB) $(LIB_DIR)/$(LIB)
-diff -ur postfix-2.7.1/src/util/Makefile.in postfix-2.7.1-libs/src/util/Makefile.in
---- postfix-2.7.1/src/util/Makefile.in 2010-11-08 20:14:18.465139054 +0100
-+++ postfix-2.7.1-libs/src/util/Makefile.in    2010-11-08 20:12:49.982139058 +0100
-@@ -126,7 +126,7 @@
-       gcc -shared -Wl,-soname,dict_pcre.so -o $@ $? -lpcre -L. -lutil
+diff -ur postfix-3.0.2.orig/src/tls/Makefile.in postfix-3.0.2/src/tls/Makefile.in
+--- postfix-3.0.2.orig/src/tls/Makefile.in     2015-01-28 00:13:11.000000000 +0000
++++ postfix-3.0.2/src/tls/Makefile.in  2015-07-26 21:11:24.396001565 +0000
+@@ -44,7 +44,7 @@
  $(LIB):       $(OBJS)
--      gcc -shared -Wl,-soname,libpostfix-util.so.1 -o $(LIB) $(OBJS) -ldl
-+      gcc -shared -Wl,-soname,libpostfix-util.so.1 -o $(LIB) $(OBJS) -ldl -lcdb -lnsl -ldb
+       $(AR) $(ARFL) $(LIB) $?
+       $(RANLIB) $(LIB)
+-      $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(OBJS) $(SHLIB_SYSLIBS)
++      $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(OBJS) $(SHLIB_SYSLIBS) $(LIBS)
  
  $(LIB_DIR)/$(LIB): $(LIB)
        cp $(LIB) $(LIB_DIR)