]> TLD Linux GIT Repositories - packages/postfix.git/commitdiff
- we need this back due to incorrect interal libraries linking
authorMarcin Krol <hawk@tld-linux.org>
Mon, 27 Jul 2015 10:26:33 +0000 (10:26 +0000)
committerMarcin Krol <hawk@tld-linux.org>
Mon, 27 Jul 2015 10:26:33 +0000 (10:26 +0000)
postfix-link.patch [new file with mode: 0644]

diff --git a/postfix-link.patch b/postfix-link.patch
new file mode 100644 (file)
index 0000000..f4762f8
--- /dev/null
@@ -0,0 +1,60 @@
+diff -ur postfix-3.0.2.orig/src/dns/Makefile.in postfix-3.0.2/src/dns/Makefile.in
+--- postfix-3.0.2.orig/src/dns/Makefile.in     2015-01-28 00:13:11.000000000 +0000
++++ postfix-3.0.2/src/dns/Makefile.in  2015-07-26 21:11:11.550001565 +0000
+@@ -37,7 +37,7 @@
+ $(LIB):       $(OBJS)
+       $(AR) $(ARFL) $(LIB) $?
+       $(RANLIB) $(LIB)
+-      $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(OBJS) $(SHLIB_SYSLIBS)
++      $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(OBJS) $(SHLIB_SYSLIBS) -L../util -lpostfix-util -L../global -lpostfix-global
+ $(LIB_DIR)/$(LIB): $(LIB)
+       cp $(LIB) $(LIB_DIR)
+diff -ur postfix-3.0.2.orig/src/global/Makefile.in postfix-3.0.2/src/global/Makefile.in
+--- postfix-3.0.2.orig/src/global/Makefile.in  2015-01-28 00:13:10.000000000 +0000
++++ postfix-3.0.2/src/global/Makefile.in       2015-07-26 21:11:37.799001565 +0000
+@@ -142,7 +142,7 @@
+ $(LIB):       $(OBJS)
+       $(AR) $(ARFL) $(LIB) $?
+       $(RANLIB) $(LIB)
+-      $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(OBJS) $(SHLIB_SYSLIBS)
++      $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(OBJS) $(SHLIB_SYSLIBS) -L../util -lpostfix-util
+ $(LIB_DIR)/$(LIB): $(LIB)
+       cp $(LIB) $(LIB_DIR)
+diff -ur postfix-3.0.2.orig/src/master/Makefile.in postfix-3.0.2/src/master/Makefile.in
+--- postfix-3.0.2.orig/src/master/Makefile.in  2015-01-28 00:13:12.000000000 +0000
++++ postfix-3.0.2/src/master/Makefile.in       2015-07-26 21:12:33.635001565 +0000
+@@ -44,7 +44,7 @@
+ $(LIB):       $(LIB_OBJ)
+       $(AR) $(ARFL) $(LIB) $?
+       $(RANLIB) $(LIB)
+-      $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(LIB_OBJ) $(SHLIB_SYSLIBS)
++      $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(LIB_OBJ) $(SHLIB_SYSLIBS) -L../util -lpostfix-util -L../global -lpostfix-global
+ $(LIB_DIR)/$(LIB): $(LIB)
+       cp $(LIB) $(LIB_DIR)/$(LIB)
+diff -ur postfix-3.0.2.orig/src/tls/Makefile.in postfix-3.0.2/src/tls/Makefile.in
+--- postfix-3.0.2.orig/src/tls/Makefile.in     2015-01-28 00:13:11.000000000 +0000
++++ postfix-3.0.2/src/tls/Makefile.in  2015-07-26 21:11:24.396001565 +0000
+@@ -44,7 +44,7 @@
+ $(LIB):       $(OBJS)
+       $(AR) $(ARFL) $(LIB) $?
+       $(RANLIB) $(LIB)
+-      $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(OBJS) $(SHLIB_SYSLIBS)
++      $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(OBJS) $(SHLIB_SYSLIBS) -L../util -lpostfix-util -L../global -lpostfix-global -L../dns -lpostfix-dns
+ $(LIB_DIR)/$(LIB): $(LIB)
+       cp $(LIB) $(LIB_DIR)
+diff -ur postfix-3.0.2.orig/src/util/Makefile.in postfix-3.0.2/src/util/Makefile.in
+--- postfix-3.0.2.orig/src/util/Makefile.in    2015-07-25 18:33:26.000000000 +0000
++++ postfix-3.0.2/src/util/Makefile.in 2015-07-26 21:10:58.110001565 +0000
+@@ -148,7 +148,7 @@
+ $(LIB):       $(OBJS)
+       $(AR) $(ARFL) $(LIB) $?
+       $(RANLIB) $(LIB)
+-      $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(OBJS) $(SHLIB_SYSLIBS)
++      $(SHLIB_LD) $(SHLIB_RPATH) -o $(LIB) $(OBJS) $(SHLIB_SYSLIBS) 
+ $(LIB_DIR)/$(LIB): $(LIB)
+       cp $(LIB) $(LIB_DIR)