]> TLD Linux GIT Repositories - packages/postgresql.git/blobdiff - per-version-dirs.patch
- updated to 13.14
[packages/postgresql.git] / per-version-dirs.patch
index 46e8c453b4fdf1abb8a1a6d1e68618e464a69aa5..34e1c4f22418b122180b263de17111b53dbe8745 100644 (file)
@@ -1,6 +1,7 @@
---- a/src/Makefile.global.in
-+++ b/src/Makefile.global.in
-@@ -120,7 +120,7 @@ libdir := @libdir@
+diff -urNp -x '*.orig' postgresql-13.6.org/src/Makefile.global.in postgresql-13.6/src/Makefile.global.in
+--- postgresql-13.6.org/src/Makefile.global.in 2022-02-07 22:17:41.000000000 +0100
++++ postgresql-13.6/src/Makefile.global.in     2022-04-04 17:54:23.042839497 +0200
+@@ -119,7 +119,7 @@ libdir := @libdir@
  pkglibdir = $(libdir)
  ifeq "$(findstring pgsql, $(pkglibdir))" ""
  ifeq "$(findstring postgres, $(pkglibdir))" ""
@@ -9,7 +10,7 @@
  endif
  endif
  
-@@ -168,7 +168,7 @@ endif # PGXS
+@@ -167,7 +167,7 @@ endif # PGXS
  
  # These derived path variables aren't separately configurable.
  
 +includedir_server = $(pkgincludedir)/@PG_MAJORVERSION@/server
  includedir_internal = $(pkgincludedir)/internal
  pgxsdir = $(pkglibdir)/pgxs
---- a/src/bin/pg_config/pg_config.c
-+++ b/src/bin/pg_config/pg_config.c
+ bitcodedir = $(pkglibdir)/bitcode
+diff -urNp -x '*.orig' postgresql-13.6.org/src/bin/pg_config/pg_config.c postgresql-13.6/src/bin/pg_config/pg_config.c
+--- postgresql-13.6.org/src/bin/pg_config/pg_config.c  2022-02-07 22:17:41.000000000 +0100
++++ postgresql-13.6/src/bin/pg_config/pg_config.c      2022-04-04 17:54:23.042839497 +0200
 @@ -27,6 +27,8 @@
- #include "port.h"
  #include "common/config_info.h"
+ #include "port.h"
  
 +#include "../port/pg_config_paths.h"
 +
  static const char *progname;
  
  /*
-@@ -148,11 +150,7 @@ main(int argc, char **argv)
+@@ -149,11 +151,7 @@ main(int argc, char **argv)
                }
        }