]> TLD Linux GIT Repositories - packages/postgresql.git/blobdiff - postgresql-link.patch
- updated to 11.20
[packages/postgresql.git] / postgresql-link.patch
index 1e89ba17f66faf5c6d306a708011a8a6c47c2367..07b59f14205839c2caa19eff416503c4bb3f75cb 100644 (file)
@@ -1,18 +1,37 @@
---- postgresql-9.5.0/configure.in.orig 2016-01-14 18:59:41.640973653 +0100
-+++ postgresql-9.5.0/configure.in      2016-01-14 21:10:21.783977990 +0100
-@@ -1192,7 +1192,9 @@
+diff -urNp -x '*.orig' postgresql-11.15.org/configure.in postgresql-11.15/configure.in
+--- postgresql-11.15.org/configure.in  2022-04-04 18:21:51.824651401 +0200
++++ postgresql-11.15/configure.in      2022-04-04 18:21:56.988663338 +0200
+@@ -1477,6 +1477,7 @@ fi
  
  if test "$with_bonjour" = yes ; then
    AC_CHECK_HEADER(dns_sd.h, [], [AC_MSG_ERROR([header file <dns_sd.h> is required for Bonjour])])
 +  AC_CHECK_LIB(dns_sd, DNSServiceRegister, [BONJOUR_LIBS=-ldns_sd])
+ dnl At some point we might add something like
+ dnl AC_SEARCH_LIBS(DNSServiceRegister, dns_sd)
+ dnl but right now, what that would mainly accomplish is to encourage
+@@ -1484,6 +1485,7 @@ dnl people to try to use the avahi imple
+ dnl If you want to use Apple's own Bonjour code on another platform,
+ dnl just add -ldns_sd to LIBS manually.
  fi
 +AC_SUBST([BONJOUR_LIBS])
  
  # for contrib/uuid-ossp
  if test "$with_uuid" = bsd ; then
---- postgresql-9.5.0/src/backend/Makefile.orig 2016-01-04 22:29:34.000000000 +0100
-+++ postgresql-9.5.0/src/backend/Makefile      2016-01-14 21:10:48.093976872 +0100
-@@ -54,7 +54,7 @@
+diff -urNp -x '*.orig' postgresql-11.15.org/src/Makefile.global.in postgresql-11.15/src/Makefile.global.in
+--- postgresql-11.15.org/src/Makefile.global.in        2022-04-04 18:21:51.822651396 +0200
++++ postgresql-11.15/src/Makefile.global.in    2022-04-04 18:21:56.989663340 +0200
+@@ -173,6 +173,7 @@ includedir_internal = $(pkgincludedir)/i
+ pgxsdir = $(pkglibdir)/pgxs
+ bitcodedir = $(pkglibdir)/bitcode
++BONJOUR_LIBS            = @BONJOUR_LIBS@
+ ##########################################################################
+ #
+diff -urNp -x '*.orig' postgresql-11.15.org/src/backend/Makefile postgresql-11.15/src/backend/Makefile
+--- postgresql-11.15.org/src/backend/Makefile  2022-02-07 22:20:23.000000000 +0100
++++ postgresql-11.15/src/backend/Makefile      2022-04-04 18:21:56.989663340 +0200
+@@ -60,7 +60,7 @@ ifneq ($(PORTNAME), win32)
  ifneq ($(PORTNAME), aix)
  
  postgres: $(OBJS)
  
  endif
  endif
---- postgresql-9.5.0/src/Makefile.global.in.orig       2016-01-04 22:29:34.000000000 +0100
-+++ postgresql-9.5.0/src/Makefile.global.in    2016-01-14 21:11:50.820640805 +0100
-@@ -216,6 +216,7 @@
- PTHREAD_CFLAGS                = @PTHREAD_CFLAGS@
- PTHREAD_LIBS          = @PTHREAD_LIBS@
-+BONJOUR_LIBS            = @BONJOUR_LIBS@
- ##########################################################################
- #