]> TLD Linux GIT Repositories - packages/postgresql.git/blobdiff - postgresql-link.patch
- updated to 15.2
[packages/postgresql.git] / postgresql-link.patch
index 032f381e2a173a484b92ed655b943247fbf2a6cd..4c6cefbed4eaa76760198591d7c4c71483488436 100644 (file)
@@ -1,6 +1,6 @@
---- postgresql-9.5.0/configure.in.orig   2018-02-21 03:23:25.335399998 +0100
-+++ postgresql-9.5.0/configure.in        2018-02-21 03:28:24.392066743 +0100
-@@ -1203,6 +1203,7 @@
+--- postgresql-15.2/configure.ac       2023-03-07 23:37:05.721401513 +0100
++++ postgresql-15.2/configure.ac       2023-03-07 23:37:22.414607273 +0100
+@@ -1603,6 +1603,7 @@
  
  if test "$with_bonjour" = yes ; then
    AC_CHECK_HEADER(dns_sd.h, [], [AC_MSG_ERROR([header file <dns_sd.h> is required for Bonjour])])
@@ -8,7 +8,7 @@
  dnl At some point we might add something like
  dnl AC_SEARCH_LIBS(DNSServiceRegister, dns_sd)
  dnl but right now, what that would mainly accomplish is to encourage
-@@ -1210,6 +1211,7 @@
+@@ -1610,6 +1611,7 @@
  dnl If you want to use Apple's own Bonjour code on another platform,
  dnl just add -ldns_sd to LIBS manually.
  fi
  
  # for contrib/uuid-ossp
  if test "$with_uuid" = bsd ; then
---- postgresql-9.5.0/src/backend/Makefile.orig 2016-01-04 22:29:34.000000000 +0100
-+++ postgresql-9.5.0/src/backend/Makefile      2016-01-14 21:10:48.093976872 +0100
-@@ -54,7 +54,7 @@
+--- postgresql-15.2/src/backend/Makefile       2023-03-07 23:37:05.607400108 +0100
++++ postgresql-15.2/src/backend/Makefile       2023-03-07 23:37:22.415607285 +0100
+@@ -64,7 +64,7 @@
  ifneq ($(PORTNAME), aix)
  
  postgres: $(OBJS)
--      $(CC) $(CFLAGS) $(LDFLAGS) $(LDFLAGS_EX) $(export_dynamic) $(call expand_subsys,$^) $(LIBS) -o $@
-+      $(CC) $(CFLAGS) $(LDFLAGS) $(LDFLAGS_EX) $(export_dynamic) $(call expand_subsys,$^) $(LIBS) $(BONJOUR_LIBS) -o $@
+-      $(CC) $(CFLAGS) $(call expand_subsys,$^) $(LDFLAGS) $(LDFLAGS_EX) $(export_dynamic) $(LIBS) -o $@
++      $(CC) $(CFLAGS) $(call expand_subsys,$^) $(LDFLAGS) $(LDFLAGS_EX) $(export_dynamic) $(LIBS) $(BONJOUR_LIBS) -o $@
  
  endif
  endif
---- postgresql-9.5.0/src/Makefile.global.in.orig       2016-01-04 22:29:34.000000000 +0100
-+++ postgresql-9.5.0/src/Makefile.global.in    2016-01-14 21:11:50.820640805 +0100
-@@ -216,6 +216,7 @@
- PTHREAD_CFLAGS                = @PTHREAD_CFLAGS@
- PTHREAD_LIBS          = @PTHREAD_LIBS@
+--- postgresql-15.2/src/Makefile.global.in     2023-03-07 23:37:05.481398555 +0100
++++ postgresql-15.2/src/Makefile.global.in     2023-03-07 23:37:22.415607285 +0100
+@@ -172,6 +172,7 @@
+ pgxsdir = $(pkglibdir)/pgxs
+ bitcodedir = $(pkglibdir)/bitcode
  
 +BONJOUR_LIBS            = @BONJOUR_LIBS@