]> TLD Linux GIT Repositories - packages/postgresql.git/blobdiff - postgresql-link.patch
- updated to 12.18
[packages/postgresql.git] / postgresql-link.patch
index 1e89ba17f66faf5c6d306a708011a8a6c47c2367..78ef3baaa14a74f35dee52c98fd2733ecf33872e 100644 (file)
@@ -1,33 +1,42 @@
---- postgresql-9.5.0/configure.in.orig 2016-01-14 18:59:41.640973653 +0100
-+++ postgresql-9.5.0/configure.in      2016-01-14 21:10:21.783977990 +0100
-@@ -1192,7 +1192,9 @@
+diff -urNp -x '*.orig' postgresql-12.10.org/configure.in postgresql-12.10/configure.in
+--- postgresql-12.10.org/configure.in  2022-04-04 18:13:47.309531402 +0200
++++ postgresql-12.10/configure.in      2022-04-04 18:13:51.731541624 +0200
+@@ -1510,6 +1510,7 @@ fi
  
  if test "$with_bonjour" = yes ; then
    AC_CHECK_HEADER(dns_sd.h, [], [AC_MSG_ERROR([header file <dns_sd.h> is required for Bonjour])])
 +  AC_CHECK_LIB(dns_sd, DNSServiceRegister, [BONJOUR_LIBS=-ldns_sd])
+ dnl At some point we might add something like
+ dnl AC_SEARCH_LIBS(DNSServiceRegister, dns_sd)
+ dnl but right now, what that would mainly accomplish is to encourage
+@@ -1517,6 +1518,7 @@ dnl people to try to use the avahi imple
+ dnl If you want to use Apple's own Bonjour code on another platform,
+ dnl just add -ldns_sd to LIBS manually.
  fi
 +AC_SUBST([BONJOUR_LIBS])
  
  # for contrib/uuid-ossp
  if test "$with_uuid" = bsd ; then
---- postgresql-9.5.0/src/backend/Makefile.orig 2016-01-04 22:29:34.000000000 +0100
-+++ postgresql-9.5.0/src/backend/Makefile      2016-01-14 21:10:48.093976872 +0100
-@@ -54,7 +54,7 @@
+diff -urNp -x '*.orig' postgresql-12.10.org/src/Makefile.global.in postgresql-12.10/src/Makefile.global.in
+--- postgresql-12.10.org/src/Makefile.global.in        2022-04-04 18:13:47.306531395 +0200
++++ postgresql-12.10/src/Makefile.global.in    2022-04-04 18:13:51.731541624 +0200
+@@ -173,6 +173,7 @@ includedir_internal = $(pkgincludedir)/i
+ pgxsdir = $(pkglibdir)/pgxs
+ bitcodedir = $(pkglibdir)/bitcode
++BONJOUR_LIBS            = @BONJOUR_LIBS@
+ ##########################################################################
+ #
+diff -urNp -x '*.orig' postgresql-12.10.org/src/backend/Makefile postgresql-12.10/src/backend/Makefile
+--- postgresql-12.10.org/src/backend/Makefile  2022-02-07 22:19:04.000000000 +0100
++++ postgresql-12.10/src/backend/Makefile      2022-04-04 18:13:51.731541624 +0200
+@@ -60,7 +60,7 @@ ifneq ($(PORTNAME), win32)
  ifneq ($(PORTNAME), aix)
  
  postgres: $(OBJS)
--      $(CC) $(CFLAGS) $(LDFLAGS) $(LDFLAGS_EX) $(export_dynamic) $(call expand_subsys,$^) $(LIBS) -o $@
-+      $(CC) $(CFLAGS) $(LDFLAGS) $(LDFLAGS_EX) $(export_dynamic) $(call expand_subsys,$^) $(LIBS) $(BONJOUR_LIBS) -o $@
+-      $(CC) $(CFLAGS) $(call expand_subsys,$^) $(LDFLAGS) $(LDFLAGS_EX) $(export_dynamic) $(LIBS) -o $@
++      $(CC) $(CFLAGS) $(call expand_subsys,$^) $(LDFLAGS) $(LDFLAGS_EX) $(export_dynamic) $(LIBS) $(BONJOUR_LIBS) -o $@
  
  endif
  endif
---- postgresql-9.5.0/src/Makefile.global.in.orig       2016-01-04 22:29:34.000000000 +0100
-+++ postgresql-9.5.0/src/Makefile.global.in    2016-01-14 21:11:50.820640805 +0100
-@@ -216,6 +216,7 @@
- PTHREAD_CFLAGS                = @PTHREAD_CFLAGS@
- PTHREAD_LIBS          = @PTHREAD_LIBS@
-+BONJOUR_LIBS            = @BONJOUR_LIBS@
- ##########################################################################
- #