]> TLD Linux GIT Repositories - packages/postgresql.git/blobdiff - postgresql-link.patch
- updated to 16.2
[packages/postgresql.git] / postgresql-link.patch
index 4c6cefbed4eaa76760198591d7c4c71483488436..d983f4c058dc6abeb2d7af7e838f48f922c1fe03 100644 (file)
@@ -1,6 +1,7 @@
---- postgresql-15.2/configure.ac       2023-03-07 23:37:05.721401513 +0100
-+++ postgresql-15.2/configure.ac       2023-03-07 23:37:22.414607273 +0100
-@@ -1603,6 +1603,7 @@
+diff -ur postgresql-16.1.orig/configure.ac postgresql-16.1/configure.ac
+--- postgresql-16.1.orig/configure.ac  2023-12-13 21:41:13.777653991 +0100
++++ postgresql-16.1/configure.ac       2023-12-13 21:42:33.649673374 +0100
+@@ -1616,6 +1616,7 @@
  
  if test "$with_bonjour" = yes ; then
    AC_CHECK_HEADER(dns_sd.h, [], [AC_MSG_ERROR([header file <dns_sd.h> is required for Bonjour])])
@@ -8,7 +9,7 @@
  dnl At some point we might add something like
  dnl AC_SEARCH_LIBS(DNSServiceRegister, dns_sd)
  dnl but right now, what that would mainly accomplish is to encourage
-@@ -1610,6 +1611,7 @@
+@@ -1623,6 +1624,7 @@
  dnl If you want to use Apple's own Bonjour code on another platform,
  dnl just add -ldns_sd to LIBS manually.
  fi
  
  # for contrib/uuid-ossp
  if test "$with_uuid" = bsd ; then
---- postgresql-15.2/src/backend/Makefile       2023-03-07 23:37:05.607400108 +0100
-+++ postgresql-15.2/src/backend/Makefile       2023-03-07 23:37:22.415607285 +0100
-@@ -64,7 +64,7 @@
+diff -ur postgresql-16.1.orig/src/backend/Makefile postgresql-16.1/src/backend/Makefile
+--- postgresql-16.1.orig/src/backend/Makefile  2023-11-06 23:04:27.000000000 +0100
++++ postgresql-16.1/src/backend/Makefile       2023-12-13 21:43:07.594106591 +0100
+@@ -65,7 +65,7 @@
  ifneq ($(PORTNAME), aix)
  
  postgres: $(OBJS)
--      $(CC) $(CFLAGS) $(call expand_subsys,$^) $(LDFLAGS) $(LDFLAGS_EX) $(export_dynamic) $(LIBS) -o $@
-+      $(CC) $(CFLAGS) $(call expand_subsys,$^) $(LDFLAGS) $(LDFLAGS_EX) $(export_dynamic) $(LIBS) $(BONJOUR_LIBS) -o $@
+-      $(CC) $(CFLAGS) $(call expand_subsys,$^) $(LDFLAGS) $(LIBS) -o $@
++      $(CC) $(CFLAGS) $(call expand_subsys,$^) $(LDFLAGS) $(LIBS) $(BONJOUR_LIBS) -o $@
  
  endif
  endif
---- postgresql-15.2/src/Makefile.global.in     2023-03-07 23:37:05.481398555 +0100
-+++ postgresql-15.2/src/Makefile.global.in     2023-03-07 23:37:22.415607285 +0100
+diff -ur postgresql-16.1.orig/src/Makefile.global.in postgresql-16.1/src/Makefile.global.in
+--- postgresql-16.1.orig/src/Makefile.global.in        2023-12-13 21:41:13.774653953 +0100
++++ postgresql-16.1/src/Makefile.global.in     2023-12-13 21:42:33.649673374 +0100
 @@ -172,6 +172,7 @@
  pgxsdir = $(pkglibdir)/pgxs
  bitcodedir = $(pkglibdir)/bitcode