]> TLD Linux GIT Repositories - packages/postgresql.git/blobdiff - postgresql-link.patch
- updated to 16.2
[packages/postgresql.git] / postgresql-link.patch
index cf79e14a979f67c9d38426f20c590f677639e9c6..d983f4c058dc6abeb2d7af7e838f48f922c1fe03 100644 (file)
@@ -1,7 +1,7 @@
-diff -ur postgresql-14.0.orig/configure.ac postgresql-14.0/configure.ac
---- postgresql-14.0.orig/configure.ac  2021-11-01 14:52:54.420842615 +0100
-+++ postgresql-14.0/configure.ac       2021-11-01 14:53:49.104982037 +0100
-@@ -1494,6 +1494,7 @@
+diff -ur postgresql-16.1.orig/configure.ac postgresql-16.1/configure.ac
+--- postgresql-16.1.orig/configure.ac  2023-12-13 21:41:13.777653991 +0100
++++ postgresql-16.1/configure.ac       2023-12-13 21:42:33.649673374 +0100
+@@ -1616,6 +1616,7 @@
  
  if test "$with_bonjour" = yes ; then
    AC_CHECK_HEADER(dns_sd.h, [], [AC_MSG_ERROR([header file <dns_sd.h> is required for Bonjour])])
@@ -9,7 +9,7 @@ diff -ur postgresql-14.0.orig/configure.ac postgresql-14.0/configure.ac
  dnl At some point we might add something like
  dnl AC_SEARCH_LIBS(DNSServiceRegister, dns_sd)
  dnl but right now, what that would mainly accomplish is to encourage
-@@ -1501,6 +1502,7 @@
+@@ -1623,6 +1624,7 @@
  dnl If you want to use Apple's own Bonjour code on another platform,
  dnl just add -ldns_sd to LIBS manually.
  fi
@@ -17,21 +17,21 @@ diff -ur postgresql-14.0.orig/configure.ac postgresql-14.0/configure.ac
  
  # for contrib/uuid-ossp
  if test "$with_uuid" = bsd ; then
-diff -ur postgresql-14.0.orig/src/backend/Makefile postgresql-14.0/src/backend/Makefile
---- postgresql-14.0.orig/src/backend/Makefile  2021-11-01 14:52:54.349842434 +0100
-+++ postgresql-14.0/src/backend/Makefile       2021-11-01 14:53:49.105982039 +0100
-@@ -63,7 +63,7 @@
+diff -ur postgresql-16.1.orig/src/backend/Makefile postgresql-16.1/src/backend/Makefile
+--- postgresql-16.1.orig/src/backend/Makefile  2023-11-06 23:04:27.000000000 +0100
++++ postgresql-16.1/src/backend/Makefile       2023-12-13 21:43:07.594106591 +0100
+@@ -65,7 +65,7 @@
  ifneq ($(PORTNAME), aix)
  
  postgres: $(OBJS)
--      $(CC) $(CFLAGS) $(call expand_subsys,$^) $(LDFLAGS) $(LDFLAGS_EX) $(export_dynamic) $(LIBS) -o $@
-+      $(CC) $(CFLAGS) $(call expand_subsys,$^) $(LDFLAGS) $(LDFLAGS_EX) $(export_dynamic) $(LIBS) $(BONJOUR_LIBS) -o $@
+-      $(CC) $(CFLAGS) $(call expand_subsys,$^) $(LDFLAGS) $(LIBS) -o $@
++      $(CC) $(CFLAGS) $(call expand_subsys,$^) $(LDFLAGS) $(LIBS) $(BONJOUR_LIBS) -o $@
  
  endif
  endif
-diff -ur postgresql-14.0.orig/src/Makefile.global.in postgresql-14.0/src/Makefile.global.in
---- postgresql-14.0.orig/src/Makefile.global.in        2021-11-01 14:52:54.297842301 +0100
-+++ postgresql-14.0/src/Makefile.global.in     2021-11-01 14:53:49.105982039 +0100
+diff -ur postgresql-16.1.orig/src/Makefile.global.in postgresql-16.1/src/Makefile.global.in
+--- postgresql-16.1.orig/src/Makefile.global.in        2023-12-13 21:41:13.774653953 +0100
++++ postgresql-16.1/src/Makefile.global.in     2023-12-13 21:42:33.649673374 +0100
 @@ -172,6 +172,7 @@
  pgxsdir = $(pkglibdir)/pgxs
  bitcodedir = $(pkglibdir)/bitcode